发布时间 :2006-04-13 06:02:00
修订时间 :2011-08-22 00:00:00

[原文]PHP remote file inclusion vulnerability in functions.php in Circle R Monster Top List (MTL) 1.4 allows remote attackers to execute arbitrary PHP code via a URL in the root_path parameter. NOTE: It was later reported that 1.4.2 and earlier are affected.

[CNNVD]Monster Top List Functions.PHP 远程文件包含漏洞 (CNNVD-200604-207)

        Circle R Monster Top List (MTL) 1.4 中的functions.php页面存在PHP远程文件包含漏洞。这使得远程攻击者可以借助于 root_path 参数中的URL执行任意PHP代码。注意:后来报告称1.4.2及更早版本受此问题的影响。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  monstertoplist-functions-file-include(25774)
(UNKNOWN)  BID  23074
(UNKNOWN)  BID  17546

- 漏洞信息

Monster Top List Functions.PHP 远程文件包含漏洞
高危 代码注入
2006-04-13 00:00:00 2007-08-27 00:00:00
        Circle R Monster Top List (MTL) 1.4 中的functions.php页面存在PHP远程文件包含漏洞。这使得远程攻击者可以借助于 root_path 参数中的URL执行任意PHP代码。注意:后来报告称1.4.2及更早版本受此问题的影响。

- 公告与补丁


- 漏洞信息

Monster Top List sources/functions.php root_path Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Monster Top List contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to sources/functions.php not properly sanitizing user input supplied to the 'root_path' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-04-12 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Monster Top List Functions.PHP Remote File Include Vulnerability
Input Validation Error 17546
Yes No
2006-04-17 12:00:00 2006-04-18 05:01:00
r0t is credited with the discovery of this vulnerability.

- 受影响的程序版本

Monster Top List Monster Top List 1.4

- 漏洞讨论

Monster Top List is prone to a remote file-include vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker can exploit this issue to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

- 漏洞利用

This issue can be exploited through a web client.

The following proof-of-concept URI is available:[path]/sources/functions.php?root_path=

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 相关参考