CVE-2006-1778
CVSS7.5
发布时间 :2006-04-13 06:02:00
修订时间 :2011-03-07 21:34:06
NMCO    

[原文]Multiple SQL injection vulnerabilities in Jeremy Ashcraft Simplog 0.9.2 and earlier allow remote attackers to execute arbitrary SQL commands via the (1) blogid parameter in (a) index.php and (b) archive.php, the (2) m and (3) y parameters in archive.php, and the (4) sql parameter in (c) server.php.


[CNNVD]Simplog多个输入验证漏洞(CNNVD-200604-209)

        Simplog是一款简单易用的Blog程序,用PHP编写,兼容很多数据库。
        Simplog中存在多个安全漏洞,恶意用户可以利用这些漏洞收集系统信息、执行跨站脚本和SQL注入攻击、执行任意SQL代码或完全入侵系统。
        1) 在包含文件前没有正确验证"doc/index.php"中的"s"参数,导致可以包含任意外部或本地资源的文件。
        2) 在SQL查询中使用之前没有正确过滤对"index.php"中"blogid"参数以及"archive.php"中"blogid"、"m"和"y"参数的输入,导致可以通过注入任意SQL代码操控SQL查询。
        3) 没有对"adodb/server.php"和"adodb/tests/tmssql.php"脚本执行安全的测试,导致可以执行任意SQL代码或调用任意PHP函数。
        
        4) 在返回用户之前没有正确的过滤对"login.php"中"btag"参数的输入,导致可以在用户浏览器会话中以受影响站点的权限执行任意HTML和脚本代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1778
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1778
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-209
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1332
(UNKNOWN)  VUPEN  ADV-2006-1332
http://www.securityfocus.com/bid/17491
(UNKNOWN)  BID  17491
http://www.securityfocus.com/archive/1/archive/1/430743/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060412 Simplog <=0.9.2 multiple vulnerabilities
http://www.osvdb.org/24561
(UNKNOWN)  OSVDB  24561
http://www.osvdb.org/24560
(UNKNOWN)  OSVDB  24560
http://securitytracker.com/id?1015904
(UNKNOWN)  SECTRACK  1015904
http://secunia.com/advisories/19628
(VENDOR_ADVISORY)  SECUNIA  19628
http://retrogod.altervista.org/simplog_092_incl_xpl.html
(UNKNOWN)  MISC  http://retrogod.altervista.org/simplog_092_incl_xpl.html
http://milw0rm.com/exploits/1663
(UNKNOWN)  MILW0RM  1663
http://xforce.iss.net/xforce/xfdb/25776
(UNKNOWN)  XF  simplog-index-archive-sql-injection(25776)
http://securityreason.com/securityalert/702
(UNKNOWN)  SREASON  702

- 漏洞信息

Simplog多个输入验证漏洞
高危 SQL注入
2006-04-13 00:00:00 2006-08-11 00:00:00
远程  
        Simplog是一款简单易用的Blog程序,用PHP编写,兼容很多数据库。
        Simplog中存在多个安全漏洞,恶意用户可以利用这些漏洞收集系统信息、执行跨站脚本和SQL注入攻击、执行任意SQL代码或完全入侵系统。
        1) 在包含文件前没有正确验证"doc/index.php"中的"s"参数,导致可以包含任意外部或本地资源的文件。
        2) 在SQL查询中使用之前没有正确过滤对"index.php"中"blogid"参数以及"archive.php"中"blogid"、"m"和"y"参数的输入,导致可以通过注入任意SQL代码操控SQL查询。
        3) 没有对"adodb/server.php"和"adodb/tests/tmssql.php"脚本执行安全的测试,导致可以执行任意SQL代码或调用任意PHP函数。
        
        4) 在返回用户之前没有正确的过滤对"login.php"中"btag"参数的输入,导致可以在用户浏览器会话中以受影响站点的权限执行任意HTML和脚本代码。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.simplog.org/

- 漏洞信息

24560
Simplog index.php blogid Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Simplog contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the index.php script not properly sanitizing user-supplied input to the 'blogid' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-04-11 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站