CVE-2006-1753
CVSS3.6
发布时间 :2006-04-18 16:02:00
修订时间 :2008-09-05 17:02:45
NMCOS    

[原文]A cron job in fcheck before 2.7.59 allows local users to overwrite arbitrary files via a symlink attack on a temporary file.


[CNNVD]FCheck 不安全临时文件创建漏洞 (CNNVD-200604-270)

        fcheck 2.7.59之前的版本中的cron任务允许本地用户借助于对临时文件的符号链接攻击重写任意文件。

- CVSS (基础分值)

CVSS分值: 3.6 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:debian:debian_linux:3.1::amd64
cpe:/o:debian:debian_linux:3.1::sparc
cpe:/o:debian:debian_linux:3.1::ia-64
cpe:/o:debian:debian_linux:3.1:r1
cpe:/o:debian:debian_linux:3.1::m68k
cpe:/o:debian:debian_linux:3.1::hppa
cpe:/o:debian:debian_linux:3.1::alpha
cpe:/o:debian:debian_linux:3.1::s-390
cpe:/o:debian:debian_linux:3.1::ia-32
cpe:/o:debian:debian_linux:3.1::mipsel
cpe:/o:debian:debian_linux:3.1::ppc
cpe:/o:debian:debian_linux:3.1::mips
cpe:/o:debian:debian_linux:3.1Debian Debian Linux 3.1
cpe:/o:debian:debian_linux:3.1::arm

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1753
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1753
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-270
(官方数据源) CNNVD

- 其它链接及资源

http://www.us.debian.org/security/2006/dsa-1035
(VENDOR_ADVISORY)  DEBIAN  DSA-1035
http://secunia.com/advisories/19675
(VENDOR_ADVISORY)  SECUNIA  19675
http://www.securityfocus.com/bid/17524
(UNKNOWN)  BID  17524
http://xforce.iss.net/xforce/xfdb/25830
(UNKNOWN)  XF  fcheck-tmpfile-symlink(25830)

- 漏洞信息

FCheck 不安全临时文件创建漏洞
低危 设计错误
2006-04-18 00:00:00 2006-04-19 00:00:00
本地  
        fcheck 2.7.59之前的版本中的cron任务允许本地用户借助于对临时文件的符号链接攻击重写任意文件。

- 公告与补丁

        暂无数据

- 漏洞信息

24633
fcheck Cron Temporary File Symlink Arbitrary File Overwrite
Local Access Required Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2006-04-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.7.59-7sarge1, 2.7.59-8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

FCheck Insecure Temporary File Creation Vulnerability
Design Error 17524
No Yes
2006-04-15 12:00:00 2006-04-17 09:01:00
This vulnerability was discovered by Steve Kemp.

- 受影响的程序版本

FCheck fcheck 2.7.59
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

FCheck creates temporary files in an insecure manner.

An attacker with local access could potentially exploit this issue to view files and obtain privileged information. The attacker may also perform symlink attacks, overwriting arbitrary files in the context of the affected application.

A successful attack would most likely result in loss of confidentiality and theft of privileged information. Successful exploitation of a symlink attack may allow an attacker to overwrite sensitive files. This may result in a denial of service; other attacks may also be possible.

- 漏洞利用

An exploit is not required.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.commailto:vuldb@securityfocus.com

Please see the references for vendor advisories and fixes.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站