发布时间 :2006-04-12 18:02:00
修订时间 :2008-09-05 17:02:44

[原文]Cross-site scripting (XSS) vulnerability in XMB Forum 1.9.5 allows remote attackers to inject arbitrary web script or HTML by uploading a Flash (.SWF) video that contains a getURL function call, which causes the video to be rendered without disabling ActionScript.

[CNNVD]XMB Forum getURL函数 跨站脚本攻击漏洞(CNNVD-200604-189)

        XMB Forum 1.9.5中存在跨站脚本攻击漏洞。这使得远程攻击者可以通过上传包含getURL函数调用的Flash(.SWF)视频注入任意Web脚本或HTML。该漏洞在不禁用ActionScript的条件下使视频得到渲染。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  17445
(UNKNOWN)  BUGTRAQ  20060409 XMB Forum 1.9.5-Final XSS
(UNKNOWN)  XF  xmb-swf-geturl-xss(25737)

- 漏洞信息

XMB Forum getURL函数 跨站脚本攻击漏洞
低危 跨站脚本
2006-04-12 00:00:00 2006-04-19 00:00:00
        XMB Forum 1.9.5中存在跨站脚本攻击漏洞。这使得远程攻击者可以通过上传包含getURL函数调用的Flash(.SWF)视频注入任意Web脚本或HTML。该漏洞在不禁用ActionScript的条件下使视频得到渲染。

- 公告与补丁


- 漏洞信息

XMB Forum .swf Actionscript Execution
Remote / Network Access
Loss of Confidentiality Upgrade
Exploit Public Vendor Verified

- 漏洞描述

- 时间线

2006-04-09 Unknow
2006-04-09 2008-05-10

- 解决方案

Upgrade to version 1.9.10 or higher, as it has been reported to fix this vulnerability. In addition, The XMB Group has released a fix for version 1.9.8 in the third service pack.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

XMB Forum Flash Video Cross-Site Scripting Vulnerability
Input Validation Error 17445
Yes No
2006-04-10 12:00:00 2008-09-10 09:00:00 is credited with the discovery of this vulnerability.

- 受影响的程序版本

XMB Forum 1.9.8 SP2
XMB Forum 1.9.8
XMB Forum 1.9.6 Final
XMB Forum 1.9.6
XMB Forum 1.9.5 Final
XMB Forum 1.9.3
XMB Forum 1.9.2
XMB Forum 1.9.1
XMB Forum 1.9 beta
XMB Forum 1.9
XMB Forum 1.8 SP3
XMB Forum 1.8 SP2
XMB Forum 1.8 SP1
XMB Forum 1.8
XMB Forum 1.9.10

- 不受影响的程序版本

XMB Forum 1.9.10

- 漏洞讨论

XMB Forum is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

- 漏洞利用

This issue can be exploited through a web client.

- 解决方案

A vendor update is available. Contact the vendor for more information.

- 相关参考