CVE-2006-1681
CVSS4.3
发布时间 :2006-04-10 20:02:00
修订时间 :2011-03-07 21:33:34
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Cherokee HTTPD 0.5 and earlier allows remote attackers to inject arbitrary web script or HTML via a malformed request that generates an HTTP 400 error, which is not properly handled when the error message is generated.


[CNNVD]Cherokee HTTPD 跨站脚本攻击漏洞(CNNVD-200604-123)

        Cherokee HTTPD 0.5及早期版本中存在跨站脚本攻击(XSS)漏洞。这使得远程攻击者可以借助于产生HTTP 400错误的畸形请求注入任意Web脚本或HTML。当出错信息产生时,该请求没有得到正确地处理。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:cherokee:cherokee_httpd:0.2
cpe:/a:cherokee:cherokee_httpd:0.1.5
cpe:/a:cherokee:cherokee_httpd:0.4.9
cpe:/a:cherokee:cherokee_httpd:0.2.6
cpe:/a:cherokee:cherokee_httpd:0.2.5
cpe:/a:cherokee:cherokee_httpd:0.1
cpe:/a:cherokee:cherokee_httpd:0.5
cpe:/a:cherokee:cherokee_httpd:0.4.7
cpe:/a:cherokee:cherokee_httpd:0.4.8
cpe:/a:cherokee:cherokee_httpd:0.2.7
cpe:/a:cherokee:cherokee_httpd:0.4.6
cpe:/a:cherokee:cherokee_httpd:0.1.6
cpe:/a:cherokee:cherokee_httpd:0.4.17

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1681
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1681
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-123
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/19587
(PATCH)  SECUNIA  19587
http://www.vupen.com/english/advisories/2006/1292
(UNKNOWN)  VUPEN  ADV-2006-1292
http://www.securityfocus.com/bid/17408
(UNKNOWN)  BID  17408
http://www.securityfocus.com/archive/1/archive/1/430385/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060406 XSS Bug in Cherokee Webserver
http://xforce.iss.net/xforce/xfdb/25698
(UNKNOWN)  XF  cherokee-handlererror-xss(25698)
http://www.osvdb.org/24469
(UNKNOWN)  OSVDB  24469

- 漏洞信息

Cherokee HTTPD 跨站脚本攻击漏洞
中危 跨站脚本
2006-04-10 00:00:00 2006-04-11 00:00:00
远程  
        Cherokee HTTPD 0.5及早期版本中存在跨站脚本攻击(XSS)漏洞。这使得远程攻击者可以借助于产生HTTP 400错误的畸形请求注入任意Web脚本或HTML。当出错信息产生时,该请求没有得到正确地处理。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.alobbs.com/
        

- 漏洞信息

24469
Cherokee Web Server Error 400 XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Cherokee contains a flaw that allows a remote cross site scripting attack. This flaw exists because the server does not validate user-supplied input when non-existant URLs with embedded scripting code are requested. This could allow an attacker to create a specially crafted URL that would not be understood by the web server and result in a 400 Error page, enabling them to execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-04-06 Unknow
2006-04-06 Unknow

- 解决方案

Upgrade to version 0.5.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站