CVE-2006-1669
CVSS6.4
发布时间 :2006-04-07 06:04:00
修订时间 :2008-09-05 17:02:31
NMCO    

[原文]SQL injection vulnerability in chat/messagesL.php3 in phpHeaven Team PHPMyChat 0.14.5 and earlier allows remote attackers to execute arbitrary SQL commands via the T parameter. NOTE: this issue can be leveraged to execute arbitrary shell commands since the username is later processed in an eval() call, but since the username originated from the SQL injection, it could be a resultant issue.


[CNNVD]phpHeaven Team PHPMyChat chat/messagesL.PHP3 SQL注入漏洞(CNNVD-200604-100)

        phpHeaven Team PHPMyChat 0.14.5以及早期版本的chat/messagesL.php3中存在SQL注入漏洞,可让远程攻击者通过T参数执行任意的SQL命令。备注:由于username在eval()调用中是延后处理的,因此这个漏洞可被用来执行任意的shell命令,并且由于username来自于SQL的注入,因此才导致这样的问题。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpheaven:phpmychat:0.14.5
cpe:/a:phpheaven:phpmychat:0.14.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1669
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1669
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-100
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/17382
(UNKNOWN)  BID  17382
http://www.securityfocus.com/archive/1/archive/1/430358/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060405 PHPMyChat <= 0.14.5 remote commands execution
http://securitytracker.com/id?1015873
(UNKNOWN)  SECTRACK  1015873
http://milw0rm.com/exploits/1646
(UNKNOWN)  MILW0RM  1646
http://xforce.iss.net/xforce/xfdb/25687
(UNKNOWN)  XF  phpmychat-messagesl-sql-injection(25687)

- 漏洞信息

phpHeaven Team PHPMyChat chat/messagesL.PHP3 SQL注入漏洞
中危 SQL注入
2006-04-07 00:00:00 2007-01-04 00:00:00
远程  
        phpHeaven Team PHPMyChat 0.14.5以及早期版本的chat/messagesL.php3中存在SQL注入漏洞,可让远程攻击者通过T参数执行任意的SQL命令。备注:由于username在eval()调用中是延后处理的,因此这个漏洞可被用来执行任意的shell命令,并且由于username来自于SQL的注入,因此才导致这样的问题。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://phpmychat.sourceforge.net/
        

- 漏洞信息

24655
phpMyChat messagesL.php3 T Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-04-05 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站