CVE-2006-1636
CVSS7.5
发布时间 :2006-04-06 06:04:00
修订时间 :2011-08-22 00:00:00
NMCO    

[原文]PHP remote file inclusion vulnerability in get_header.php in VWar 1.5.0 R12 and earlier allows remote attackers to execute arbitrary PHP code via a URL in the vwar_root parameter. NOTE: this is a different vulnerability than CVE-2006-1503.


[CNNVD]VWar get_header.php 远程文件包含漏洞(CNNVD-200604-059)

        VWar 1.5.0 R12以及早期版本的get_header.php中存在PHP远程文件包含漏洞,可让远程攻击者通过vwar_root参数的一个URL执行任意的PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)

cpe:/a:vwar:virtual_war:1.0.5VWar Virtual War 1.0.5
cpe:/a:vwar:virtual_war:1.2.0VWar Virtual War 1.2.0
cpe:/a:vwar:virtual_war:1.5.0_r6
cpe:/a:vwar:virtual_war:1.0.7VWar Virtual War 1.0.7
cpe:/a:vwar:virtual_war:1.5.0_r12
cpe:/a:vwar:virtual_war:1.5VWar Virtual War 1.5
cpe:/a:vwar:virtual_war:1.1.1VWar Virtual War 1.1.1
cpe:/a:vwar:virtual_war:1.5.0_r11
cpe:/a:vwar:virtual_war:1.0.4VWar Virtual War 1.0.4
cpe:/a:vwar:virtual_war:1.5.0_r8
cpe:/a:vwar:virtual_war:1.5.0_r4
cpe:/a:vwar:virtual_war:1.1.0VWar Virtual War 1.1.0
cpe:/a:vwar:virtual_war:1.5.0_r2
cpe:/a:vwar:virtual_war:1.0.9VWar Virtual War 1.0.9
cpe:/a:vwar:virtual_war:1.5.0_r7
cpe:/a:vwar:virtual_war:1.5.0_r5
cpe:/a:vwar:virtual_war:1.0.6VWar Virtual War 1.0.6
cpe:/a:vwar:virtual_war:1.5.0_r9
cpe:/a:vwar:virtual_war:1.1.4VWar Virtual War 1.1.4
cpe:/a:vwar:virtual_war:1.1.8VWar Virtual War 1.1.8
cpe:/a:vwar:virtual_war:1.5.0_r1
cpe:/a:vwar:virtual_war:1.2.1VWar Virtual War 1.2.1
cpe:/a:vwar:virtual_war:1.3VWar Virtual War 1.3
cpe:/a:vwar:virtual_war:1.5.0_r10
cpe:/a:vwar:virtual_war:1.1.2VWar Virtual War 1.1.2
cpe:/a:vwar:virtual_war:1.0.1VWar Virtual War 1.0.1
cpe:/a:vwar:virtual_war:1.2.2VWar Virtual War 1.2.2
cpe:/a:vwar:virtual_war:1.0.3VWar Virtual War 1.0.3
cpe:/a:vwar:virtual_war:1.4VWar Virtual War 1.4
cpe:/a:vwar:virtual_war:1.5.0_r3
cpe:/a:vwar:virtual_war:1.1.5VWar Virtual War 1.1.5
cpe:/a:vwar:virtual_war:1.0.0VWar Virtual War 1.0.0
cpe:/a:vwar:virtual_war:1.1.6VWar Virtual War 1.1.6
cpe:/a:vwar:virtual_war:1.0.8VWar Virtual War 1.0.8
cpe:/a:vwar:virtual_war:1.1.7VWar Virtual War 1.1.7
cpe:/a:vwar:virtual_war:1.0.2VWar Virtual War 1.0.2
cpe:/a:vwar:virtual_war:1.1.3VWar Virtual War 1.1.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1636
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1636
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-059
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/19524
(VENDOR_ADVISORY)  SECUNIA  19524
http://www.vupen.com/english/advisories/2006/1228
(VENDOR_ADVISORY)  VUPEN  ADV-2006-1228
http://www.securityfocus.com/bid/17358
(UNKNOWN)  BID  17358
http://www.securityfocus.com/archive/1/archive/1/429742/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060402 VWar <= 1.5.0 R12 Remote File Inclusion Exploit
http://www.osvdb.org/24480
(UNKNOWN)  OSVDB  24480
http://downloads.securityfocus.com/vulnerabilities/exploits/VWar_1.5.0_R12.pl
(UNKNOWN)  MISC  http://downloads.securityfocus.com/vulnerabilities/exploits/VWar_1.5.0_R12.pl

- 漏洞信息

VWar get_header.php 远程文件包含漏洞
高危 代码注入
2006-04-06 00:00:00 2006-04-25 00:00:00
远程  
        VWar 1.5.0 R12以及早期版本的get_header.php中存在PHP远程文件包含漏洞,可让远程攻击者通过vwar_root参数的一个URL执行任意的PHP代码。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.vwar.de/
        

- 漏洞信息

24480
Virtual War (Vwar) includes/get_header.php vwar_root Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Virtual War contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to includes/get_header.php not properly sanitizing user input supplied to the 'vwar_root' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-04-02 Unknow
2006-04-02 Unknow

- 解决方案

Upgrade to version 1.5.0 R13 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站