CVE-2006-1629
CVSS9.0
发布时间 :2006-04-06 18:04:00
修订时间 :2011-03-07 21:33:27
NMCOS    

[原文]OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.


[CNNVD]OpenVPN LD_PRELOAD环境变量传输漏洞(CNNVD-200604-073)

        OpenVPN是一个基于OpenSSL库的应用层VPN实现。
        OpenVPN客户端允许服务器通过"setenv"配置指令向客户端shell传送包括LD_PRELOAD在内的环境变量。攻击者可以在已知位置放置恶意文件并加载该文件来执行任意代码。

- CVSS (基础分值)

CVSS分值: 9 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:openvpn:openvpn:2.0.3
cpe:/a:openvpn:openvpn:2.0.5
cpe:/a:openvpn:openvpn:2.0
cpe:/a:openvpn:openvpn:2.0.1
cpe:/a:openvpn:openvpn:2.0.2
cpe:/a:openvpn:openvpn:2.0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1629
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1629
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-073
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/17392
(PATCH)  BID  17392
http://secunia.com/advisories/19531
(VENDOR_ADVISORY)  SECUNIA  19531
http://openvpn.net/changelog.html
(PATCH)  CONFIRM  http://openvpn.net/changelog.html
http://www.vupen.com/english/advisories/2006/1261
(UNKNOWN)  VUPEN  ADV-2006-1261
http://www.osreviews.net/reviews/security/openvpn-print
(UNKNOWN)  MISC  http://www.osreviews.net/reviews/security/openvpn-print
http://sourceforge.net/mailarchive/forum.php?thread_id=10093825&forum_id=8482
(UNKNOWN)  CONFIRM  http://sourceforge.net/mailarchive/forum.php?thread_id=10093825&forum_id=8482
http://xforce.iss.net/xforce/xfdb/25667
(UNKNOWN)  XF  openvpn-ldpreload-code-execution(25667)
http://www.osvdb.org/24444
(UNKNOWN)  OSVDB  24444
http://www.novell.com/linux/security/advisories/2006_04_28.html
(UNKNOWN)  SUSE  SUSE-SR:2006:009
http://www.mandriva.com/security/advisories?name=MDKSA-2006:069
(UNKNOWN)  MANDRIVA  MDKSA-2006:069
http://www.debian.org/security/2006/dsa-1045
(UNKNOWN)  DEBIAN  DSA-1045
http://secunia.com/advisories/19897
(UNKNOWN)  SECUNIA  19897
http://secunia.com/advisories/19837
(UNKNOWN)  SECUNIA  19837
http://secunia.com/advisories/19598
(UNKNOWN)  SECUNIA  19598

- 漏洞信息

OpenVPN LD_PRELOAD环境变量传输漏洞
高危 输入验证
2006-04-06 00:00:00 2006-04-07 00:00:00
远程  
        OpenVPN是一个基于OpenSSL库的应用层VPN实现。
        OpenVPN客户端允许服务器通过"setenv"配置指令向客户端shell传送包括LD_PRELOAD在内的环境变量。攻击者可以在已知位置放置恶意文件并加载该文件来执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        http://openvpn.net/download.html#stable

- 漏洞信息

24444
OpenVPN LD_PRELOAD Environment Variable Pushing Arbitrary Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

OpenVPN contains a flaw that may allow a malicious user to execute arbitrary code. The issue is caused due to OpenVPN clients allowing the server to transmit environment variables including LD_PRELOAD to client-side shell scripts via 'setenv' configuration directives. It is possible that the flaw may allow arbitrary code execution by placing and loading a file in a known location resulting in a loss of integrity.

- 时间线

2006-04-05 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

OpenVPN Client Remote Code Execution Vulnerability
Input Validation Error 17392
Yes No
2006-04-06 12:00:00 2006-12-05 08:14:00
Discovery is credited to Hendrik Weimer.

- 受影响的程序版本

S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 10.0
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
OpenVPN OpenVPN 2.0.5
OpenVPN OpenVPN 2.0.4
OpenVPN OpenVPN 2.0.3
OpenVPN OpenVPN 2.0.2
OpenVPN OpenVPN 2.0.1
OpenVPN OpenVPN 2.0
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
Mandriva Linux Mandrake 2006.0 x86_64
Mandriva Linux Mandrake 2006.0
MandrakeSoft Multi Network Firewall 2.0
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
OpenVPN OpenVPN 2.0.6

- 不受影响的程序版本

OpenVPN OpenVPN 2.0.6

- 漏洞讨论

OpenVPN is reported prone to a remote code-execution vulnerability. This issue is due to a lack of proper sanitization of server-supplied data.

A remote attacker may exploit this issue to execute arbitrary code with elevated privileges on a vulnerable computer to gain unauthorized access.

To be vulnerable to this issue, client OpenVPN computers must be configured to use 'up' or 'down' scripts and must have either the 'pull' configuration directive or a 'client' macro set up.

OpenVPN versions 2.0.0 through 2.0.5 are affected by this issue.

- 漏洞利用

An attacker can use the standard OpenVPN server application to exploit this issue.

- 解决方案

The vendor has released version 2.0.6 of OpenVPN to address this issue.

Please see the references for more information and vendor advisories.


OpenVPN OpenVPN 2.0

OpenVPN OpenVPN 2.0.1

OpenVPN OpenVPN 2.0.2

OpenVPN OpenVPN 2.0.3

OpenVPN OpenVPN 2.0.4

OpenVPN OpenVPN 2.0.5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站