CVE-2006-1627
CVSS7.5
发布时间 :2006-04-13 14:02:00
修订时间 :2011-03-07 21:33:27
NMCOS    

[原文]Adobe Document Server for Reader Extensions 6.0 does not provide proper access control, which allows remote authenticated users to perform privileged actions by modifying the (1) actionID and (2) pageID parameters. NOTE: due to an error during reservation, this identifier was inadvertently associated with multiple issues. Other CVE identifiers have been assigned to handle other problems that are covered by the same disclosure.


[CNNVD]Adobe Document Server for Reader Extensions多个远程漏洞(CNNVD-200604-192)

        Adobe Documet Server for Reader Extensions允许用户与外部组织和人员共享交互式与智能型的Adobe PDF文件。
        Adobe Document Server for Reader Extensions中存在多个漏洞,可能允许恶意用户绕过一些安全限制并执行脚本注入攻击,或获取敏感信息或执行跨站脚本攻击。
        1) Adobe Document Server for Reader Extensions(ads-readerext)缺少访问控制限制,可能允许已认证用户通过actionID和pageID参数访问本不应访问的功能。
        成功攻击允许拥有Draft权限的低权限用户创建新的管理用户帐号。
        2) ads-readerext没有正确地过滤"Update Download Site"中对ReaderURL变量的输入。攻击者可以利用这个漏洞注入有"ftp://" 或"http://" 前缀的任意脚本代码,然后在管理用户登录时在用户浏览器会话中执行该代码。
        正常情况下编辑这个字段要求管理权限,但如果结合上一个漏洞的话任何有效用户都可以利用这个漏洞。
        3) 在返回给用户之前没有正确过滤ads-readerext中对"actionID"参数的输入;以及Adobe Server Web Services(AlterCast)中对"op"参数的输入,可能导致在有漏洞站点环境下在用户浏览器会话中执行任意HTML和脚本代码。
        4) 在试图登录到ads-readerext时会返回不同的错误消息,具体取决于是否存在所提供的用户名。攻击者可以利用这个漏洞枚举有效帐号。
        5) ads-readerext的用户会话ID传送给了URL的"jsessionid"参数并在"Referer:"首部中泄漏给其他站点。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1627
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1627
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-192
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1342
(UNKNOWN)  VUPEN  ADV-2006-1342
http://www.adobe.com/support/techdocs/322699.html
(UNKNOWN)  CONFIRM  http://www.adobe.com/support/techdocs/322699.html
http://secunia.com/secunia_research/2005-68/advisory/
(VENDOR_ADVISORY)  MISC  http://secunia.com/secunia_research/2005-68/advisory/
http://secunia.com/advisories/15924
(VENDOR_ADVISORY)  SECUNIA  15924
http://xforce.iss.net/xforce/xfdb/25769
(UNKNOWN)  XF  adobe-access-control-bypass(25769)
http://www.securityfocus.com/bid/17500
(UNKNOWN)  BID  17500
http://www.securityfocus.com/archive/1/archive/1/430869/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060413 Secunia Research: Adobe Document Server for Reader ExtensionsMultiple Vulnerabilities
http://securitytracker.com/id?1015905
(UNKNOWN)  SECTRACK  1015905

- 漏洞信息

Adobe Document Server for Reader Extensions多个远程漏洞
高危 资料不足
2006-04-13 00:00:00 2006-04-14 00:00:00
远程  
        Adobe Documet Server for Reader Extensions允许用户与外部组织和人员共享交互式与智能型的Adobe PDF文件。
        Adobe Document Server for Reader Extensions中存在多个漏洞,可能允许恶意用户绕过一些安全限制并执行脚本注入攻击,或获取敏感信息或执行跨站脚本攻击。
        1) Adobe Document Server for Reader Extensions(ads-readerext)缺少访问控制限制,可能允许已认证用户通过actionID和pageID参数访问本不应访问的功能。
        成功攻击允许拥有Draft权限的低权限用户创建新的管理用户帐号。
        2) ads-readerext没有正确地过滤"Update Download Site"中对ReaderURL变量的输入。攻击者可以利用这个漏洞注入有"ftp://" 或"http://" 前缀的任意脚本代码,然后在管理用户登录时在用户浏览器会话中执行该代码。
        正常情况下编辑这个字段要求管理权限,但如果结合上一个漏洞的话任何有效用户都可以利用这个漏洞。
        3) 在返回给用户之前没有正确过滤ads-readerext中对"actionID"参数的输入;以及Adobe Server Web Services(AlterCast)中对"op"参数的输入,可能导致在有漏洞站点环境下在用户浏览器会话中执行任意HTML和脚本代码。
        4) 在试图登录到ads-readerext时会返回不同的错误消息,具体取决于是否存在所提供的用户名。攻击者可以利用这个漏洞枚举有效帐号。
        5) ads-readerext的用户会话ID传送给了URL的"jsessionid"参数并在"Referer:"首部中泄漏给其他站点。
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.adobe.com/support/products/enterprise/

- 漏洞信息

24587
Adobe Document Server for Reader Extensions ads-readerext Permission Weakness Privilege Escalation
Remote / Network Access Authentication Management
Loss of Confidentiality, Loss of Integrity Upgrade
Exploit Public RBS Confirmed, Vendor Verified, Coordinated Disclosure

- 漏洞描述

Adobe Document Server for Reader Extensions implements improper access controls that may allow an attacker to access functionality not intended to be accessible to that user by manipulating the 'actionID' and 'pageID' parameters.

- 时间线

2006-04-13 2005-07-26
Unknow Unknow

- 解决方案

Upgrade to version 6.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Adobe Document Server for Reader Extensions Multiple Remote Vulnerabilities
Unknown 17500
Yes No
2006-04-13 12:00:00 2006-04-13 09:57:00
Discovered by Tan Chew Keong and Carsten Eiram, Secunia Research.

- 受影响的程序版本

Adobe Graphics Server 2.1
Adobe Document Server 6.0

- 漏洞讨论

Adobe Document Server for Reader Extensions, included with Graphics Server and Document Server, is prone to multiple vulnerabilities that may allow remote attackers to:

- perform cross-site scripting attacks
- gain access to potentially sensitive information
- bypass security restrictions to gain administrative access to the application.

Adobe Document Server for Reader Extensions version 6.0, included with Adobe Graphics Server 2.1 and Adobe Document Server 6.0, is vulnerable; other versions may also be affected.

- 漏洞利用

These issues may be exploited with a web browser.

Example URIs have been provided to demonstrate the cross-site scripting vulnerabilities:

http://www.example.com:8019/ads-readerext/ads-readerext?actionID=[code]
http://www.example.com:8019/altercast/AlterCast?op=[code]

- 解决方案

Adobe has released advisories and updated software to address these issues. Please see the referenced advisories for further information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站