发布时间 :2006-04-05 06:04:00
修订时间 :2011-03-07 21:33:26

[原文]Format string vulnerability in the (1) Con_message and (2) conPrintf functions in con_main.c in Doomsday engine 1.8.6 allows remote attackers to execute arbitrary code via format string specifiers in an argument to the JOIN command, and possibly other command arguments.

[CNNVD]Doomsday con_main.c 多个远程格式化字符串漏洞(CNNVD-200604-055)


- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-1221
(UNKNOWN)  XF  doomsday-conmessage-conprintf-format-string(25622)
(UNKNOWN)  BID  17369
(UNKNOWN)  BUGTRAQ  20060403 Format string in Doomsday 1.8.6
(UNKNOWN)  FULLDISC  20060403 Format string in Doomsday 1.8.6

- 漏洞信息

Doomsday con_main.c 多个远程格式化字符串漏洞
高危 格式化字符串
2006-04-05 00:00:00 2006-04-05 00:00:00

- 公告与补丁


- 漏洞信息

Doomsday con_main.c Multiple Function Format String
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-04-03 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Doomsday Multiple Remote Format String Vulnerabilities
Input Validation Error 17369
Yes No
2006-04-04 12:00:00 2006-04-10 05:27:00
Discovery is credited to Luigi Auriemma.

- 受影响的程序版本

Gentoo Linux
Doomsday HQ Doomsday Engine 1.9
Doomsday HQ Doomsday Engine 1.8.6

- 漏洞讨论

Doomsday is prone to multiple remote format-string vulnerabilities.

These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker can exploit these issues to execute arbitrary code in the context of the vulnerable application or crash the affected game server, effectively denying service to legitimate users.

- 漏洞利用

This issue can be exploited through a web client.

The following proof of concept is sufficient to crash an affected game server:

Telnet to TCP port 13209 and issue the following command:
JOIN 1234 %n%n%n%n%n%n

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

Please see the references for more information and vendor advisories.

- 相关参考