CVE-2006-1599
CVSS7.5
发布时间 :2006-04-03 13:04:00
修订时间 :2011-03-07 21:33:24
NMCO    

[原文]Unspecified vulnerability in VCEngine.php in v-creator before 1.3-pre3, when the VC_CRYPTO_METHOD option is OPENSSL, allows remote attackers to execute arbitrary commands, possibly due to problems in the (1) enrypt and (2) decrypt functions.


[CNNVD]V-creator远程代码执行漏洞(CNNVD-200604-015)

        v_creator1.3-pre3之前版本的VCEngine.php文件中存在不确定漏洞,当VC_CRYPTO_METHOD选项为OPENSSL时,可使远程攻击者执行任意命令,可能由于在(1)enrypt和(2)decrpt函数中存在问题。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1599
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1599
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-015
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/25560
(PATCH)  XF  vcreator-vcengine-command-execution(25560)
http://secunia.com/advisories/19453
(VENDOR_ADVISORY)  SECUNIA  19453
http://www.vupen.com/english/advisories/2006/1189
(UNKNOWN)  VUPEN  ADV-2006-1189
http://www.securityfocus.com/bid/17328
(UNKNOWN)  BID  17328
http://sourceforge.net/forum/forum.php?forum_id=557129
(UNKNOWN)  CONFIRM  http://sourceforge.net/forum/forum.php?forum_id=557129
http://www.osvdb.org/24304
(UNKNOWN)  OSVDB  24304

- 漏洞信息

V-creator远程代码执行漏洞
高危 输入验证
2006-04-03 00:00:00 2006-04-04 00:00:00
远程  
        v_creator1.3-pre3之前版本的VCEngine.php文件中存在不确定漏洞,当VC_CRYPTO_METHOD选项为OPENSSL时,可使远程攻击者执行任意命令,可能由于在(1)enrypt和(2)decrpt函数中存在问题。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        v-creator.com v-creator 1.3-pre2
        v-creator.com v-creator_1.3-pre3.tgz
        http://prdownloads.sourceforge.net/vcreator/v-creator_1.3-pre3.tgz
        

- 漏洞信息

24304
v-creator VCEngine.php OPENSSL Command Injection
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

v-creator contains a flaw that may allow a malicious user to execute arbitrary shell commands. The issue is triggered due to an input validation error in the 'enrypt()' and 'decrypt()' functions in VCEngine.php. It is possible that the flaw may allow arbitrary command execution resulting in a loss of integrity.

- 时间线

2006-03-30 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.3-pre3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站