CVE-2006-1594
CVSS7.5
发布时间 :2006-04-03 06:04:00
修订时间 :2011-03-07 21:33:24
NMCO    

[原文]Multiple directory traversal vulnerabilities in document/rqmkhtml.php in Claroline 1.7.4 and earlier allow remote attackers to use ".." (dot dot) sequences to (1) read arbitrary files via the file parameter in a rqEditHtml command to document/rqmkhtml.php or (2) execute arbitrary code via the includePath parameter to learnPath/include/scormExport.inc.php.


[CNNVD]Claroline Rqmkhtml.PHP信息泄露漏洞(CNNVD-200604-021)

        Claroline 1.7.4和以前版本中的document/rqmkhtml.php存在多个目录遍历漏洞,远程攻击者借助于访问document/rqmkhtml.php的rqEditHtml命令中file参数(参数值设置为'..')序列(1)可以读取任意文件,或者借助于到learnPath/include/srcormExport.inc.php的inlcudePath参数,执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:claroline:claroline:1.6_rc1
cpe:/a:claroline:claroline:1.5
cpe:/a:claroline:claroline:1.5.3
cpe:/a:claroline:claroline:1.7.4
cpe:/a:claroline:claroline:1.7.2
cpe:/a:claroline:claroline:1.6_beta
cpe:/a:claroline:claroline:1.5.4
cpe:/a:claroline:claroline:1.6

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1594
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1594
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-021
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1187
(UNKNOWN)  VUPEN  ADV-2006-1187
http://www.milw0rm.com/exploits/1627
(UNKNOWN)  MILW0RM  1627
http://secunia.com/advisories/19461
(VENDOR_ADVISORY)  SECUNIA  19461
http://retrogod.altervista.org/claroline_174_incl_xpl.html
(UNKNOWN)  MISC  http://retrogod.altervista.org/claroline_174_incl_xpl.html
http://xforce.iss.net/xforce/xfdb/25561
(UNKNOWN)  XF  claroline-rqmkhtml-directory-traversal(25561)
http://www.securityfocus.com/bid/17343
(UNKNOWN)  BID  17343

- 漏洞信息

Claroline Rqmkhtml.PHP信息泄露漏洞
高危 路径遍历
2006-04-03 00:00:00 2006-04-03 00:00:00
远程  
        Claroline 1.7.4和以前版本中的document/rqmkhtml.php存在多个目录遍历漏洞,远程攻击者借助于访问document/rqmkhtml.php的rqEditHtml命令中file参数(参数值设置为'..')序列(1)可以读取任意文件,或者借助于到learnPath/include/srcormExport.inc.php的inlcudePath参数,执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Claroline Claroline 1.5
        Claroline claroline.patch15401.zip
        Patch for versions 1.5.x
        http://www.claroline.net/dlarea/claroline.patch15401.zip>
        http://www.cl aroline.net/dlarea/claroline.patch15401.zip
        Claroline claroline175.tar.gz
        http://www.claroline.net/dlarea/claroline175.tar.gz
        Claroline Claroline 1.5.3
        Claroline claroline.patch15401.zip
        Patch for versions 1.5.x
        http://www.claroline.net/dlarea/claroline.patch15401.zip>
        http://www.cl aroline.net/dlarea/claroline.patch15401.zip
        Claroline claroline175.tar.gz
        http://www.claroline.net/dlarea/claroline175.tar.gz
        Claroline Claroline 1.5.4
        Claroline claroline.patch15401.zip
        Patch for versions 1.5.x
        http://www.claroline.net/dlarea/claroline.patch15401.zip>
        http://www.cl aroline.net/dlarea/claroline.patch15401.zip
        Claroline claroline175.tar.gz
        http://www.claroline.net/dlarea/claroline175.tar.gz
        Claroline Claroline 1.6
        Claroline claroline.patch16301.zip
        Patch for versions 1.6.x
        http://www.claroline.net/dlarea/claroline.patch16301.zip>
        http://www.cl aroline.net/dlarea/claroline.patch16301.zip
        Claroline claroline175.tar.gz
        http://www.claroline.net/dlarea/claroline175.tar.gz
        Claroline Claroline 1.6 rc1
        Claroline claroline.patch16301.zip
        Patch for versions 1.6.x
        http://www.claroline.net/dlarea/claroline.patch16301.zip>
        http://www.cl aroline.net/dlarea/claroline.patch16301.zip
        Claroline claroline175.tar.gz
        http://www.claroline.net/dlarea/claroline175.tar.gz
        Claroline Claroline 1.6 beta
        Claroline claroline.patch16301.zip
        Patch for versions 1.6.x
        http://www.claroline.net/dlarea/claroline.patch16301.zip>
        http://www.cl aroline.net/dlarea/claroline.patch16301.zip
        Claroline claroline175.tar.gz
        http://www.claroline.net/dlarea/claroline175.tar.gz
        Claroline Claroline 1.7.2
        Claroline claroline.patch17401.zip
        Patch for versions 1.7.x
        http://www.claroline.net/dlarea/claroline.patch17401.zip>
        http://www.cl aroline.net/dlarea/claroline.patch17401.zip
        Claroline claroline175.tar.gz
        http://www.claroline.net/dlarea/claroline175.tar.gz
        Claroline Claroline 1.7.4
        Claroline claroline.patch17401.zip
        Patch for versions 1.7.x
        http://www.claroline.net/dlarea/claroline.patch17401.zip>
        http://www.cl aroline.net/dlarea/claroline.patch17401.zip
        Claroline claroline175.tar.gz
        http://www.claroline.net/dlarea/claroline175.tar.gz
        

- 漏洞信息

24286
Claroline scormExport.inc.php includePath Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Claroline contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to scormExport.inc.php not properly sanitizing user input supplied to the 'includePath' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-03-30 Unknow
2006-03-30 Unknow

- 解决方案

Upgrade to version 1.7.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站