发布时间 :2006-04-03 06:04:00
修订时间 :2008-09-05 17:02:19

[原文]The bridge ioctl (if_bridge code) in NetBSD 1.6 through 3.0 does not clear sensitive memory before copying ioctl results to the requesting process, which allows local users to obtain portions of kernel memory.

[CNNVD]NetBSD If_Bridge(4)内核内存泄露漏洞(CNNVD-200604-014)

        NetBSD(从1.6到3.0版)中bridge ioctl(if_bridge代码)在拷贝iotcl结果到请求进程之前没有清除敏感内存,那将允许用户获得部分内核内存。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:netbsd:netbsd:2.0.3NetBSD 2.0.3
cpe:/o:netbsd:netbsd:2.0NetBSD 2.0
cpe:/o:netbsd:netbsd:2.1NetBSD 2.1
cpe:/o:netbsd:netbsd:1.6:betaNetBSD 1.6 Beta
cpe:/o:netbsd:netbsd:3.0NetBSD 3.0
cpe:/o:netbsd:netbsd:1.6.1NetBSD 1.6.1
cpe:/o:netbsd:netbsd:2.0.2NetBSD 2.0.2
cpe:/o:netbsd:netbsd:2.0.1NetBSD 2.0.1
cpe:/o:netbsd:netbsd:1.6NetBSD 1.6
cpe:/o:netbsd:netbsd:1.6.2NetBSD 1.6.2

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  SECTRACK  1015846
(UNKNOWN)  XF  bsd-ifbridge-information-disclosure(25582)

- 漏洞信息

NetBSD If_Bridge(4)内核内存泄露漏洞
低危 设计错误
2006-04-03 00:00:00 2006-04-03 00:00:00
        NetBSD(从1.6到3.0版)中bridge ioctl(if_bridge代码)在拷贝iotcl结果到请求进程之前没有清除敏感内存,那将允许用户获得部分内核内存。

- 公告与补丁


- 漏洞信息

NetBSD if_bridge(4) Function Arbitrary Kernel Memory Disclosure
Local Access Required Information Disclosure
Loss of Confidentiality
Exploit Unknown

- 漏洞描述

NetBSD contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when 'ioctl' calls are made on Ethernet bridge interfaces. The operating system's kernel will not fully zero out temporary stack memory to hold the results of the 'ioctl' call which could disclose kernel stack memory to the calling process, resulting in a loss of confidentiality.

- 时间线

2006-03-29 Unknow
Unknow Unknow

- 解决方案

The vendor has released upgrades for branches of NetBSD from 2.0 to 'current'. Upgrade to the version as of February 12, 2006 for branches 2.0 through 3.0. For the 'current' branch, upgrade to the version as of January 17, 2006. These update have been reported to fix this vulnerability. Note that the flaw was fixed without a change in version number. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者