CVE-2006-1577
CVSS6.8
发布时间 :2006-04-02 17:04:00
修订时间 :2011-03-07 21:33:20
NMCOPS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in view_all_set.php in Mantis 1.0.1, 1.0.0rc5, and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) start_day, (2) start_year, and (3) start_month parameters.


[CNNVD]Sun Secure Global Desktop多个跨站脚本攻击漏洞(CNNVD-200604-010)

        Sun Secure Global Desktop允许从各种客户端平台和设备安全的访问基于服务器应用。
        Sun Secure Global Desktop的一些脚本没有得到任何认证过程的保护,允许通过跨站脚本攻击执行任意代码或泄漏有关目标主机的主机名、软件版本、配置细节敏感信息。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mantis:mantis:1.0.0a1
cpe:/a:mantis:mantis:1.0.0_rc2
cpe:/a:mantis:mantis:1.0.0_rc3
cpe:/a:mantis:mantis:1.0.0_rc4
cpe:/a:mantis:mantis:1.0.1
cpe:/a:mantis:mantis:1.0.0a3
cpe:/a:mantis:mantis:1.0
cpe:/a:mantis:mantis:1.0.0a2
cpe:/a:mantis:mantis:1.0.0_rc1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1577
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1577
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-010
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1184
(UNKNOWN)  VUPEN  ADV-2006-1184
http://www.securityfocus.com/bid/17326
(UNKNOWN)  BID  17326
http://secunia.com/advisories/19471
(VENDOR_ADVISORY)  SECUNIA  19471
http://xforce.iss.net/xforce/xfdb/25579
(UNKNOWN)  XF  mantis-viewallset-script-xss(25579)
http://www.osvdb.org/24292
(UNKNOWN)  OSVDB  24292
http://www.debian.org/security/2006/dsa-1133
(UNKNOWN)  DEBIAN  DSA-1133
http://secunia.com/advisories/21400
(UNKNOWN)  SECUNIA  21400
http://pridels0.blogspot.com/2006/03/mantis-xss-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2006/03/mantis-xss-vuln.html

- 漏洞信息

Sun Secure Global Desktop多个跨站脚本攻击漏洞
中危 跨站脚本
2006-04-02 00:00:00 2006-04-03 00:00:00
远程  
        Sun Secure Global Desktop允许从各种客户端平台和设备安全的访问基于服务器应用。
        Sun Secure Global Desktop的一些脚本没有得到任何认证过程的保护,允许通过跨站脚本攻击执行任意代码或泄漏有关目标主机的主机名、软件版本、配置细节敏感信息。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://sunsolve.sun.com/security

- 漏洞信息 (F48993)

Debian Linux Security Advisory 1133-1 (PacketStormID:F48993)
2006-08-17 00:00:00
Debian  debian.org
advisory,remote,web,arbitrary,vulnerability
linux,debian
CVE-2006-0664,CVE-2006-0665,CVE-2006-0841,CVE-2006-1577
[点击下载]

Debian Security Advisory 1133-1 - Several remote vulnerabilities have been discovered in the Mantis bug tracking system, which may lead to the execution of arbitrary web scripts.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1133-1                    security@debian.org
http://www.debian.org/security/                         Moritz Muehlenhoff
August 1st, 2006                        http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : mantis
Vulnerability  : missing input sanitising
Problem-Type   : remote
Debian-specific: no
CVE ID         : CVE-2006-0664 CVE-2006-0665 CVE-2006-0841 CVE-2006-1577
Debian Bug     : 361138 378353

Several remote vulnerabilities have been discovered in the Mantis bug
tracking system, which may lead to the execution of arbitrary web script.
The Common Vulnerabilities and Exposures project identifies the following
problems:

CVE-2006-0664

    A cross-site scripting vulnerability was discovered in
    config_defaults_inc.php.

CVE-2006-0665

    Cross-site scripting vulnerabilities were discovered in query_store.php
    and manage_proj_create.php.

CVE-2006-0841

    Multiple cross-site scripting vulnerabilities were discovered in
    view_all_set.php, manage_user_page.php, view_filters_page.php and
    proj_doc_delete.php.

CVE-2006-1577

    Multiple cross-site scripting vulnerabilities were discovered in
    view_all_set.php.

For the stable distribution (sarge) these problems have been fixed in
version 0.19.2-5sarge4.1.

For the unstable distribution (sid) these problems have been fixed in
version 0.19.4-3.1.

We recommend that you upgrade your mantis package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge4.1.dsc
      Size/MD5 checksum:      586 186850cfa7493513907212591d8c550b
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge4.1.diff.gz
      Size/MD5 checksum:    42068 74a6598eff0b5f741df8c768c060edc4
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2.orig.tar.gz
      Size/MD5 checksum:  1298615 042c42c6de3bc536181391c1e9b25db3

  Architecture independent components:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge4.1_all.deb
      Size/MD5 checksum:   897142 6a94215892b6efedd61e042973060022

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFEz7cQXm3vHE4uyloRArHrAJ0ciGLJ5PM/Uzdw3QqKJOQ6Cb9e5wCfUpe2
Na9wvKwxWl0wLXMD//7BQbY=
=n6Lj
-----END PGP SIGNATURE-----

    

- 漏洞信息

24292
Mantis view_all_set.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Mantis contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'start_day', 'start_year', and 'start_month' variables upon submission to the view_all_set.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-03-31 Unknow
2006-03-31 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Mantis View_All_Set.PHP Multiple Cross-Site Scripting Vulnerabilities
Input Validation Error 17326
Yes No
2006-03-31 12:00:00 2006-09-21 12:41:00
r0t is credited with the discovery of these vulnerabilities.

- 受影响的程序版本

Mantis Mantis 1.0.1
Mantis Mantis 1.0 .0RC4
Mantis Mantis 1.0 .0RC3
Mantis Mantis 1.0 .0rc2
Mantis Mantis 1.0 .0rc1
Mantis Mantis 1.0 .0a3
Mantis Mantis 1.0 .0a2
Mantis Mantis 1.0 .0a1
Mantis Mantis 1.0
Mantis Mantis 1.0.0 RC5
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

Mantis is prone to multiple cross-site scripting vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage these issues to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

Mantis 1.0.1 and prior are considered vulnerable.

- 漏洞利用

Attackers can exploit these issues via a web client.

The following proof-of-concept examples are available:

http://www.example.com/view_all_set.php?type=1&temporary=y&do_filter_by_date=on&start_year=2006&start_month=03&start_day=[code]
http://www.example.com/view_all_set.php?type=1&temporary=y&do_filter_by_dateon&start_year=[code]
http://www.example.com/view_all_set.php?type=1&temporary=y&do_filter_by_date=on&start_year=2006&start_month=[code]

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.commailto:vuldb@securityfocus.com.

Please see the referenced advisories for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站