发布时间 :2006-03-31 19:04:00
修订时间 :2011-03-07 21:33:19

[原文]Multiple SQL injection vulnerabilities in loginprocess.php in qliteNews 2005.07.01 allow remote attackers to execute arbitrary SQL commands via the (1) username or (2) password parameters.

[CNNVD]qliteNews 'loginprocess.php'多个SQL注入漏洞(CNNVD-200603-527)

        qliteNews 2005.07.01的loginprocess.php中存在多个SQL注入漏洞,远程攻击者可通过(1) username或(2) password参数,执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-1182
(UNKNOWN)  XF  qlitenews-loginprocess-sql-injection(25565)
(UNKNOWN)  BID  17333
(UNKNOWN)  BUGTRAQ  20060413 [eVuln] qliteNews SQL Injection Vulnerability

- 漏洞信息

qliteNews 'loginprocess.php'多个SQL注入漏洞
中危 SQL注入
2006-03-31 00:00:00 2006-04-03 00:00:00
        qliteNews 2005.07.01的loginprocess.php中存在多个SQL注入漏洞,远程攻击者可通过(1) username或(2) password参数,执行任意SQL命令。

- 公告与补丁


- 漏洞信息

qliteNews loginprocess.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

qliteNews contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the loginprocess.php script not properly sanitizing user-supplied input to the 'username' or 'password' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-03-30 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

qliteNews Multiple SQL Injection Vulnerabilities
Input Validation Error 17333
Yes No
2006-03-31 12:00:00 2006-04-13 07:07:00
Aliaksandr Hartsuyeu is credited with the discovery of these vulnerabilities.

- 受影响的程序版本

r2xDesign qliteNews 2005.07.01

- 漏洞讨论

The qliteNews script is prone to multiple SQL-injection vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

A successful exploit could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

Version 2005.07.01 is reported to be vulnerable. Other versions may be affected as well.

- 漏洞利用

These issues can be exploited through a web client.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 相关参考