发布时间 :2006-03-31 06:06:00
修订时间 :2008-09-05 17:02:13

[原文]Cross-site scripting (XSS) vulnerability in VSNS Lemon 3.2.0 allows remote attackers to inject arbitrary web script or HTML via the name parameter while adding a comment.

[CNNVD]Tachyondecay VSNS Lemon跨站脚本攻击漏洞(CNNVD-200603-519)

        VSNS Lemon 3.2.0中存在跨站脚本攻击(XSS) 漏洞,远程攻击者可通过加入一条意见时的name参数,注入任意 web 脚本或 HTML。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  vsns-lemon-name-xss(25457)
(UNKNOWN)  BID  17395
(UNKNOWN)  BUGTRAQ  20060406 [eVuln] VSNS Lemon Multiple Vulnerabilities

- 漏洞信息

Tachyondecay VSNS Lemon跨站脚本攻击漏洞
低危 跨站脚本
2006-03-31 00:00:00 2006-03-31 00:00:00
        VSNS Lemon 3.2.0中存在跨站脚本攻击(XSS) 漏洞,远程攻击者可通过加入一条意见时的name参数,注入任意 web 脚本或 HTML。

- 公告与补丁


- 漏洞信息

VSNS Lemon Add Comment name Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

VSNS Lemon contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'name' variable upon submission to the Add Comment form. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-03-27 Unknow
2006-03-27 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Tachyondecay VSNS Lemon Add Comment HTML Injection Vulnerability
Input Validation Error 17395
Yes No
2006-04-06 12:00:00 2007-07-06 07:17:00
Aliaksandr Hartsuyeu is credited with the discovery of this vulnerability.

- 受影响的程序版本 VSNS Lemon 3.2

- 漏洞讨论

VSNS Lemon is prone to an HTML-injection vulnerability because the application fails to properly sanitize user-supplied input before using it in dynamically generated content.

Attacker-supplied HTML and script code would be executed in the context of the affected website, potentially allowing an attacker to steal cookie-based authentication credentials. An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

- 漏洞利用

This issue can be exploited via a web client.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at:

- 相关参考