发布时间 :2006-03-30 06:02:00
修订时间 :2011-03-07 21:33:17

[原文]Multiple cross-site scripting (XSS) vulnerabilities in news.php in vscripts (aka Kuba Kunkiewicz) VNews 1.2 allow remote attackers to inject arbitrary web script or HTML via the (1) autorkomentarza and (2) tresckomentarza parameters.

[CNNVD]Vnews 'news.php'多个跨站脚本攻击漏洞(CNNVD-200603-514)

        vscripts (又称Kuba Kunkiewicz) VNews 1.2的news.php中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可通过(1) autorkomentarza和(2) tresckomentarza参数,注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-1173
(UNKNOWN)  XF  vnews-news-xss(25530)
(UNKNOWN)  BID  17317
(UNKNOWN)  BUGTRAQ  20060411 [eVuln] VNews Multiple Vulnerabilities

- 漏洞信息

Vnews 'news.php'多个跨站脚本攻击漏洞
中危 跨站脚本
2006-03-30 00:00:00 2006-03-31 00:00:00
        vscripts (又称Kuba Kunkiewicz) VNews 1.2的news.php中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可通过(1) autorkomentarza和(2) tresckomentarza参数,注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

VNews news.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

VNews contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'autorkomentarza' or 'tresckomentarza' variables upon submission to the news.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-03-29 Unknow
2006-03-29 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

VNews Multiple Cross-Site Scripting Vulnerabilities
Input Validation Error 17317
Yes No
2006-03-30 12:00:00 2006-04-12 09:12:00
Aliaksandr Hartsuyeu is credited with the discovery of these vulnerabilities.

- 受影响的程序版本 VNews 1.2

- 漏洞讨论

VNews is prone to multiple cross-site scripting vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage these issues to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

- 漏洞利用

These issues can be exploited through a web client.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 相关参考