CVE-2006-1498
CVSS4.3
发布时间 :2006-03-29 19:06:00
修订时间 :2011-03-07 21:33:12
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in MediaWiki before 1.5.8 and 1.4.15 allows remote attackers to inject arbitrary web script or HTML via crafted encoded links.


[CNNVD]MediaWiki Encoded Page Link 跨站脚本攻击漏洞(CNNVD-200603-481)

        在MediaWiki 1.5.8和1.4.15之前版本中存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过伪编码链接注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mediawiki:mediawiki:1.5_beta2
cpe:/a:mediawiki:mediawiki:1.4.6MediaWiki 1.4.6
cpe:/a:mediawiki:mediawiki:1.5_beta3
cpe:/a:mediawiki:mediawiki:1.5_alpha1
cpe:/a:mediawiki:mediawiki:1.4.11MediaWiki 1.4.11
cpe:/a:mediawiki:mediawiki:1.4.2MediaWiki 1.4.2
cpe:/a:mediawiki:mediawiki:1.5_rc4
cpe:/a:mediawiki:mediawiki:1.4.8MediaWiki 1.4.8
cpe:/a:mediawiki:mediawiki:1.4.14MediaWiki 1.4.14
cpe:/a:mediawiki:mediawiki:1.4.3MediaWiki 1.4.3
cpe:/a:mediawiki:mediawiki:1.4.9MediaWiki 1.4.9
cpe:/a:mediawiki:mediawiki:1.5.1MediaWiki 1.5.1
cpe:/a:mediawiki:mediawiki:1.4.12MediaWiki 1.4.12
cpe:/a:mediawiki:mediawiki:1.5_beta1
cpe:/a:mediawiki:mediawiki:1.5.2MediaWiki 1.5.2
cpe:/a:mediawiki:mediawiki:1.5_alpha2
cpe:/a:mediawiki:mediawiki:1.4.10MediaWiki 1.4.10
cpe:/a:mediawiki:mediawiki:1.5.7MediaWiki 1.5.7
cpe:/a:mediawiki:mediawiki:1.4.1MediaWiki 1.4.1
cpe:/a:mediawiki:mediawiki:1.4.13MediaWiki 1.4.13
cpe:/a:mediawiki:mediawiki:1.5_beta4
cpe:/a:mediawiki:mediawiki:1.5_rc2
cpe:/a:mediawiki:mediawiki:1.5.4MediaWiki 1.5.4
cpe:/a:mediawiki:mediawiki:1.4.7MediaWiki 1.4.7
cpe:/a:mediawiki:mediawiki:1.5.6MediaWiki 1.5.6
cpe:/a:mediawiki:mediawiki:1.5.0MediaWiki 1.5.0
cpe:/a:mediawiki:mediawiki:1.5.5MediaWiki 1.5.5
cpe:/a:mediawiki:mediawiki:1.5_rc3
cpe:/a:mediawiki:mediawiki:1.4.5MediaWiki 1.4.5
cpe:/a:mediawiki:mediawiki:1.4.4MediaWiki 1.4.4
cpe:/a:mediawiki:mediawiki:1.5.3MediaWiki 1.5.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1498
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1498
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-481
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/17269
(PATCH)  BID  17269
http://mail.wikipedia.org/pipermail/mediawiki-announce/2006-March/000040.html
(PATCH)  MLIST  [MediaWiki-announce] 20060327 MediaWiki 1.5.8, 1.4.15 released [SECURITY]
http://www.vupen.com/english/advisories/2006/1194
(UNKNOWN)  VUPEN  ADV-2006-1194
http://www.mediawiki.org/wiki/MediaWiki
(UNKNOWN)  CONFIRM  http://www.mediawiki.org/wiki/MediaWiki
http://xforce.iss.net/xforce/xfdb/25588
(UNKNOWN)  XF  mediawiki-unspecified-xss(25588)
http://www.novell.com/linux/security/advisories/2006_07_sr.html
(UNKNOWN)  SUSE  SUSE-SR:2006:007
http://www.gentoo.org/security/en/glsa/glsa-200604-01.xml
(UNKNOWN)  GENTOO  GLSA-200604-01
http://secunia.com/advisories/19517
(UNKNOWN)  SECUNIA  19517
http://secunia.com/advisories/19508
(UNKNOWN)  SECUNIA  19508
http://secunia.com/advisories/19504
(UNKNOWN)  SECUNIA  19504

- 漏洞信息

MediaWiki Encoded Page Link 跨站脚本攻击漏洞
中危 跨站脚本
2006-03-29 00:00:00 2006-03-30 00:00:00
远程  
        在MediaWiki 1.5.8和1.4.15之前版本中存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过伪编码链接注入任意web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        MediaWiki MediaWiki 1.4.14
        MediaWiki mediawiki-1.4.15.tar.gz
        http://prdownloads.sourceforge.net/wikipedia/mediawiki-1.4.15.tar.gz
        MediaWiki MediaWiki 1.5.7
        MediaWiki mediawiki-1.5.8.tar.gz
        http://prdownloads.sourceforge.net/wikipedia/mediawiki-1.5.8.tar.gz

- 漏洞信息

24321
MediaWiki Encoded Links Unspecified XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-03-27 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.5.8, 1.4.15 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

MediaWiki Encoded Page Link HTML Injection Vulnerability
Input Validation Error 17269
Yes No
2006-03-27 12:00:00 2006-04-04 08:43:00
The vendor reported this vulnerability.

- 受影响的程序版本

S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
MediaWiki MediaWiki 1.5.7
MediaWiki MediaWiki 1.4.14
Gentoo Linux
MediaWiki MediaWiki 1.5.8
MediaWiki MediaWiki 1.4.15

- 不受影响的程序版本

MediaWiki MediaWiki 1.5.8
MediaWiki MediaWiki 1.4.15

- 漏洞讨论

MediaWiki is prone to an HTML-injection vulnerability. This issue is due to a lack of proper sanitization of user-supplied input before using it in dynamically generated content.

Attacker-supplied HTML and script code would be executed in the context of the affected website, potentially allowing an attacker to steal cookie-based authentication credentials. An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

- 漏洞利用

This issue can be exploited via a web client.

- 解决方案


The vendor has released versions 1.5.8 and 1.4.15 to address this issue.


MediaWiki MediaWiki 1.4.14

MediaWiki MediaWiki 1.5.7

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站