CVE-2006-1453
CVSS5.1
发布时间 :2006-05-12 16:06:00
修订时间 :2011-08-04 00:00:00
NMCOP    

[原文]Stack-based buffer overflow in Apple QuickTime before 7.1 allows remote attackers to execute arbitrary code via a crafted QuickDraw PICT image format file containing malformed font information.


[CNNVD]Apple QuickTime QuickDraw 栈溢出漏洞(CNNVD-200605-249)

        Apple QuickTime是一款流行的多媒体播放器,支持多种媒体格式。
        Apple QuickTime 7.1 之前的版本,QuickDraw在处理畸形的PICT文件时存在两个漏洞,畸形的字体信息可能导致栈溢出,畸形的图形数据可能导致堆溢出。攻击者可以创建特制的PICT图形。如果用户浏览了该图形就会导致执行任意指令。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:apple:quicktime:6.5.0Apple Quicktime 6.5.0
cpe:/a:apple:quicktime:6.5.1Apple Quicktime 6.5.1
cpe:/a:apple:quicktime:7.0.2Apple Quicktime 7.0.2
cpe:/a:apple:quicktime:7.0.1Apple Quicktime 7.0.1
cpe:/a:apple:quicktime:6.0.1Apple Quicktime 6.0.1
cpe:/a:apple:quicktime:6.1.0Apple Quicktime 6.1.0
cpe:/a:apple:quicktime:6.1.1Apple Quicktime 6.1.1
cpe:/a:apple:quicktime:6.5.2Apple Quicktime 6.5.2
cpe:/a:apple:quicktime:6.3.0Apple Quicktime 6.3.0
cpe:/a:apple:quicktime:7.0.3Apple Quicktime 7.0.3
cpe:/a:apple:quicktime:7.0.0Apple Quicktime 7.0.0
cpe:/a:apple:quicktime:6.2.0Apple Quicktime 6.2.0
cpe:/a:apple:quicktime:6.0.2Apple Quicktime 6.0.2
cpe:/a:apple:quicktime:4.1.2Apple Quicktime 4.1.2
cpe:/a:apple:quicktime:6.0Apple Quicktime 6.0
cpe:/a:apple:quicktime:7.0Apple Quicktime 7.0
cpe:/a:apple:quicktime:6.5Apple Quicktime 6.5
cpe:/a:apple:quicktime:5.0Apple Quicktime 5.0
cpe:/a:apple:quicktime:6.1Apple Quicktime 6.1
cpe:/a:apple:quicktime:6.4.0Apple Quicktime 6.4.0
cpe:/a:apple:quicktime:3.0Apple Quicktime 3.0
cpe:/a:apple:quicktime:5.0.1Apple Quicktime 5.0.1
cpe:/a:apple:quicktime:7.0.4Apple Quicktime 7.0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1453
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1453
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-249
(官方数据源) CNNVD

- 其它链接及资源

http://www.us-cert.gov/cas/techalerts/TA06-132A.html
(VENDOR_ADVISORY)  CERT  TA06-132A
http://www.us-cert.gov/cas/techalerts/TA06-132B.html
(UNKNOWN)  CERT  TA06-132B
http://www.securityfocus.com/bid/17953
(PATCH)  BID  17953
http://www.securityfocus.com/bid/17951
(PATCH)  BID  17951
http://securitytracker.com/id?1016075
(PATCH)  SECTRACK  1016075
http://securitytracker.com/id?1016067
(PATCH)  SECTRACK  1016067
http://secunia.com/advisories/20077
(VENDOR_ADVISORY)  SECUNIA  20077
http://secunia.com/advisories/20069
(VENDOR_ADVISORY)  SECUNIA  20069
http://lists.apple.com/archives/security-announce/2006/May/msg00003.html
(VENDOR_ADVISORY)  APPLE  APPLE-SA-2006-05-11
http://lists.apple.com/archives/security-announce/2006/May/msg00002.html
(VENDOR_ADVISORY)  APPLE  APPLE-SA-2006-05-11
http://xforce.iss.net/xforce/xfdb/26400
(UNKNOWN)  XF  quicktime-pict-font-bo(26400)
http://www.vupen.com/english/advisories/2006/1779
(UNKNOWN)  VUPEN  ADV-2006-1779
http://www.vupen.com/english/advisories/2006/1778
(VENDOR_ADVISORY)  VUPEN  ADV-2006-1778
http://www.securityfocus.com/archive/1/archive/1/433831/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060512 Apple QuickDraw/QuickTime Multiple Vulnerabilities
http://securityreason.com/securityalert/887
(UNKNOWN)  SREASON  887

- 漏洞信息

Apple QuickTime QuickDraw 栈溢出漏洞
中危 缓冲区溢出
2006-05-12 00:00:00 2006-05-24 00:00:00
远程  
        Apple QuickTime是一款流行的多媒体播放器,支持多种媒体格式。
        Apple QuickTime 7.1 之前的版本,QuickDraw在处理畸形的PICT文件时存在两个漏洞,畸形的字体信息可能导致栈溢出,畸形的图形数据可能导致堆溢出。攻击者可以创建特制的PICT图形。如果用户浏览了该图形就会导致执行任意指令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://wsidecar.apple.com/cgi-bin/nph-reg3rdpty1.pl/product=09374&cat=1&platform=osx&method=sa/mac.html

- 漏洞信息 (F46419)

McAfee-2006-0511.txt (PacketStormID:F46419)
2006-05-21 00:00:00
Mike Price  
advisory,arbitrary,vulnerability,code execution
windows,apple,osx
CVE-2006-1249,CVE-2006-1453,CVE-2006-1454,CVE-2006-1459,CVE-2006-1460,CVE-2006-1461,CVE-2006-1462,CVE-2006-1464,CVE-2006-1465
[点击下载]

Two code execution vulnerabilities are present in Apple QuickDraw PICT image format support. Twenty one code execution vulnerabilities are present in Apple QuickTime support for various multimedia formats including: MOV, H.264, MPEG 4, AVI, FPX and SWF. Exploitation could lead to execution of arbitrary code. In order for an attack to succeed user interaction is required and therefore the risk factor for these issues is medium. Vulnerable systems include Mac OS X versions 10.4.6 and below without the May 2006 security update installed, QuickTime versions 7.0.4 and below for Mac OS X, and QuickTime for Windows versions 7.0.4 and below.

____________________________________________________________________

McAfee, Inc.
McAfee Avert    

- 漏洞信息

25516
Apple QuickTime QuickDraw PICT Font Information Processing Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-09 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 7.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站