发布时间 :2006-04-03 10:04:00
修订时间 :2008-09-05 17:01:54

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Andy's PHP Knowledgebase (aphpkb) 0.57 allow remote attackers to inject arbitrary web script or HTML via the (1) keyword_list parameter to (a) index.php; (2) title, (3) article, (4) author, and (5) keywords parameters to (b) submit_article.php; and (6) Question, (7) Name, and (8) Email parameters to (c) submit_question.php.

[CNNVD]Andy's PHP Knowledgebase 多个跨站脚本漏洞(CNNVD-200604-023)

        Andy's PHP Knowledgebase(aphpkb) 0.57中存在多个跨站脚本漏洞,通过(1)到index.php的keyword_list参数;到submit_article.php的(2)标题,(3)文章,(4)作者,和(5)关键字参数;以及到submit_question.php的(6)问题,(7)名称,和(8)Email参数,可让远程攻击者注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  aphpkb-multiple-scripts-xss(25666)
(UNKNOWN)  BID  17377

- 漏洞信息

Andy's PHP Knowledgebase 多个跨站脚本漏洞
中危 跨站脚本
2006-04-03 00:00:00 2006-04-04 00:00:00
        Andy's PHP Knowledgebase(aphpkb) 0.57中存在多个跨站脚本漏洞,通过(1)到index.php的keyword_list参数;到submit_article.php的(2)标题,(3)文章,(4)作者,和(5)关键字参数;以及到submit_question.php的(6)问题,(7)名称,和(8)Email参数,可让远程攻击者注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

Andy's PHP Knowledgebase (aphpkb) index.php keyword_list Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public RBS Confirmed

- 漏洞描述

Andy's PHP Knowledgebase (aphpkb) contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'keyword_list' variable upon submission to the index.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-03-27 2006-03-23
2006-03-27 Unknow

- 解决方案

Upgrade to version 0.59 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Andy's PHP Knowledgebase Multiple Cross-Site Scripting Vulnerabilities
Input Validation Error 17377
Yes No
2006-03-27 12:00:00 2006-04-05 05:23:00
security curmudgeon is credited with the discovery of these vulnerabilities.

- 受影响的程序版本

aphpkb aphpkb 0.57

- 漏洞讨论

Andy's PHP Knowledgebase is prone to multiple cross-site scripting vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage these issues to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

- 漏洞利用

This issue can be exploited through a web client.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 相关参考