CVE-2006-1420
CVSS5.0
发布时间 :2006-03-28 15:02:00
修订时间 :2008-09-05 17:01:51
NMCO    

[原文]SQL injection vulnerability in print.php in SaphpLesson 2.0 allows remote attackers to execute arbitrary SQL commands via the lessid parameter.


[CNNVD]SaphpLesson 'Print.PHP' SQL注入漏洞(CNNVD-200603-447)

        在SaphpLesson 2.0中print.php中存在SQL注入漏洞,远程攻击者可以通过lessid参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1420
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1420
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-447
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/17239
(UNKNOWN)  BID  17239
http://www.securityfocus.com/archive/1/archive/1/428891/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060325 SQL Injection in SaphpLesson2.0
http://xforce.iss.net/xforce/xfdb/25453
(UNKNOWN)  XF  saphplesson-print-sql-injection(25453)
http://www.osvdb.org/24254
(UNKNOWN)  OSVDB  24254
http://securityreason.com/securityalert/629
(UNKNOWN)  SREASON  629

- 漏洞信息

SaphpLesson 'Print.PHP' SQL注入漏洞
中危 SQL注入
2006-03-28 00:00:00 2006-03-28 00:00:00
远程  
        在SaphpLesson 2.0中print.php中存在SQL注入漏洞,远程攻击者可以通过lessid参数执行任意SQL命令。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本。

- 漏洞信息

24254
SaphpLesson print.php lessid Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Saphplesson contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the print.php script not properly sanitizing user-supplied input to the 'lessid' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-03-25 Unknow
2006-03-25 Unknow

- 解决方案

Upgrade to version 3.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站