CVE-2006-1390
CVSS4.6
发布时间 :2006-03-24 19:06:00
修订时间 :2008-09-05 17:01:47
NMCO    

[原文]The configuration of NetHack 3.4.3-r1 and earlier, Falcon's Eye 1.9.4a and earlier, and Slash'EM 0.0.760 and earlier on Gentoo Linux allows local users in the games group to modify saved games files to execute arbitrary code via buffer overflows and overwrite arbitrary files via symlink attacks.


[CNNVD]Gentoo Nethack和Variants本地特权升级漏洞(CNNVD-200603-411)

        NetHack 3.4.3-r1及其早期版本,Falcon's Eye 1.9.4a及其早期版本,和Slash'EM 0.0.760及其早期版本在Gentoo Linux上的配置 ,可以让在游戏组中的本地用户通过缓冲区溢出修改存储的游戏文件、执行任意代码和通过symlink攻击来覆盖任意文件。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:gentoo:linux:1.4:rc1Gentoo Linux 1.4 rc1
cpe:/o:gentoo:linux:1.2Gentoo Linux 1.2
cpe:/o:gentoo:linux:1.4:rc2Gentoo Linux 1.4 rc2
cpe:/o:gentoo:linux:1.1a
cpe:/o:gentoo:linux:1.4Gentoo Linux 1.4
cpe:/o:gentoo:linux:0.5
cpe:/o:gentoo:linux:1.4:rc3Gentoo Linux 1.4 rc3
cpe:/o:gentoo:linux:0.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1390
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1390
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-411
(官方数据源) CNNVD

- 其它链接及资源

http://www.gentoo.org/security/en/glsa/glsa-200603-23.xml
(PATCH)  GENTOO  GLSA-200603-23
http://www.securityfocus.com/bid/17217
(UNKNOWN)  BID  17217
http://secunia.com/advisories/19376
(VENDOR_ADVISORY)  SECUNIA  19376
http://bugs.gentoo.org/show_bug.cgi?id=127319
(UNKNOWN)  MISC  http://bugs.gentoo.org/show_bug.cgi?id=127319
http://bugs.gentoo.org/show_bug.cgi?id=127167
(UNKNOWN)  MISC  http://bugs.gentoo.org/show_bug.cgi?id=127167
http://bugs.gentoo.org/show_bug.cgi?id=125902
(UNKNOWN)  MISC  http://bugs.gentoo.org/show_bug.cgi?id=125902
http://bugs.gentoo.org/show_bug.cgi?id=122376
(UNKNOWN)  MISC  http://bugs.gentoo.org/show_bug.cgi?id=122376
http://xforce.iss.net/xforce/xfdb/25528
(UNKNOWN)  XF  gentoo-multiple-games-privilege-escalation(25528)
http://www.securityfocus.com/archive/1/archive/1/428743/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060324 Re: [ GLSA 200603-23 ] NetHack, Slash'EM, Falcon's Eye: Local privilege escalation
http://www.securityfocus.com/archive/1/archive/1/428739/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060324 Re: [ GLSA 200603-23 ] NetHack, Slash'EM, Falcon's Eye: Localprivilege escalation
http://www.osvdb.org/24104
(UNKNOWN)  OSVDB  24104

- 漏洞信息

Gentoo Nethack和Variants本地特权升级漏洞
中危 缓冲区溢出
2006-03-24 00:00:00 2006-03-27 00:00:00
本地  
        NetHack 3.4.3-r1及其早期版本,Falcon's Eye 1.9.4a及其早期版本,和Slash'EM 0.0.760及其早期版本在Gentoo Linux上的配置 ,可以让在游戏组中的本地用户通过缓冲区溢出修改存储的游戏文件、执行任意代码和通过symlink攻击来覆盖任意文件。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本。

- 漏洞信息

24104
Gentoo Linux Multiple nethack Games High Score Processing Local Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

A local overflow exists in Nethack, Falsconseye, and Slashem. Gentoo's group game policy allows users to manipulate the game's record and state files. Nethack, Falsconseye, and Slashem fail to properly check record data in '/var/games/nethack/record' resulting in a buffer overflow. With a specially crafted request, an attacker can cause arbitrary code execution with the rights of other players resulting in a loss of integrity.

- 时间线

2006-03-23 2006-03-12
2006-03-23 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站