发布时间 :2006-03-24 06:02:00
修订时间 :2011-03-07 21:32:57

[原文]PHP remote file inclusion vulnerability in impex/ImpExData.php in vBulletin ImpEx module 1.74, when register_globals is disabled, allows remote attackers to include arbitrary files via the systempath parameter.

[CNNVD]vBulletin ImpEx模块远程文件包含漏洞(CNNVD-200603-406)

        require_once ($systempath . 'impex/ImpExDatabase.php');

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-1056
(UNKNOWN)  FULLDISC  20060323 XOR Crew :: vBulletin ImpEx <= 1.74 - Remote Command Execution Vulnerability
(UNKNOWN)  XF  impex-systempath-file-include(34095)
(UNKNOWN)  XF  impex-impexdata-file-include(25391)
(UNKNOWN)  BID  17206
(UNKNOWN)  BUGTRAQ  20070504 Remote File Include In Script impex

- 漏洞信息

vBulletin ImpEx模块远程文件包含漏洞
高危 输入验证
2006-03-24 00:00:00 2006-03-24 00:00:00
        require_once ($systempath . 'impex/ImpExDatabase.php');

- 公告与补丁


- 漏洞信息

vBulletin ImpEx Module ImpExData.php systempath Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

The vBulletin ImpEX module contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to ImpExData.php not properly sanitizing user input supplied to the 'systempath' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-03-22 Unknow
2006-03-22 Unknow

- 解决方案

Upgrade to version 1.75 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

VBulletin ImpEx Multiple Remote File Include Vulnerabilities
Input Validation Error 17206
Yes No
2006-03-23 12:00:00 2007-05-04 10:39:00
ReZEN of XOR Crew is credited with the discovery of the vulnerability in 'ImpExData.php'. discovered the issues in the rest of the scripts.

- 受影响的程序版本

VBulletin ImpEx 1.74
- VBulletin VBulletin 3.5.4
- VBulletin VBulletin 3.5.3
- VBulletin VBulletin 3.5.2
- VBulletin VBulletin 3.5.1

- 漏洞讨论

vBulletin ImpEx is prone to multiple remote file-include vulnerabilities because the application fails to properly sanitize user-supplied input.

An attacker can exploit these issues to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

- 漏洞利用

Attackers can use a browser to exploit this issue.

The following example URIs demonstrate these issues:[shell-attack]

The following exploit is available:

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at:

- 相关参考