CVE-2006-1347
CVSS7.5
发布时间 :2006-03-21 20:02:00
修订时间 :2017-10-10 21:30:44
NMCO    

[原文]SQL injection vulnerability in loginfunction.php in Greg Neustaetter gCards 1.45 and earlier allows remote attackers to execute arbitrary SQL commands via the username parameter.


[CNNVD]gCards ‘loginfunction.php’SQL注入漏洞(CNNVD-200603-373)

        Greg Neustaetter gCards 1.45及其早期版本的loginfunction.php中存在SQL注入漏洞,远程攻击者可通过username参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:greg_neustaetter:gcards:1.43
cpe:/a:greg_neustaetter:gcards:1.44
cpe:/a:greg_neustaetter:gcards:1.45

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1347
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1347
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-373
(官方数据源) CNNVD

- 其它链接及资源

http://attrition.org/pipermail/vim/2006-April/000698.html
(UNKNOWN)  VIM  20060414 Provable vendor ACK for gcards issues
http://www.securityfocus.com/bid/17165
(UNKNOWN)  BID  17165
http://www.vupen.com/english/advisories/2006/1015
(UNKNOWN)  VUPEN  ADV-2006-1015
https://exchange.xforce.ibmcloud.com/vulnerabilities/25344
(UNKNOWN)  XF  gcards-loginfunction-sql-injection(25344)
https://www.exploit-db.com/exploits/1595
(UNKNOWN)  EXPLOIT-DB  1595

- 漏洞信息

gCards ‘loginfunction.php’SQL注入漏洞
高危 SQL注入
2006-03-21 00:00:00 2006-03-23 00:00:00
远程  
        Greg Neustaetter gCards 1.45及其早期版本的loginfunction.php中存在SQL注入漏洞,远程攻击者可通过username参数执行任意SQL命令。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本。

- 漏洞信息

24017
gCards admin/loginfunction.php username Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

gCards contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the admin/loginfunction.php script not properly sanitizing user-supplied input to the 'username' and 'userpass' variables. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-03-20 Unknow
2006-03-20 Unknow

- 解决方案

Upgrade to version 1.46 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站