CVE-2006-1336
CVSS5.0
发布时间 :2006-03-20 21:06:00
修订时间 :2011-03-07 21:32:50
NMCO    

[原文]Cross-site scripting vulnerability in calendar.php in ExtCalendar 1.0 and possibly other versions before 2.0 allows remote attackers to inject arbitrary web script or HTML via the (1) year, (2) month, (3) next, and (4) prev parameters.


[CNNVD]ExtCalendar跨站脚本攻击漏洞(CNNVD-200603-344)

        在ExtCalendar 1.0和可能其它2.0之前版本的calendar.php中存在跨站脚本攻击漏洞,远程攻击者可通过以下途径注入任意Web脚本或HTML:(1) year,(2) month,(3) next,和(4) prev参数。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1336
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1336
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-344
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1012
(UNKNOWN)  VUPEN  ADV-2006-1012
http://www.securityfocus.com/bid/17146
(UNKNOWN)  BID  17146
http://www.securityfocus.com/archive/1/archive/1/428131/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060319 ExtCalendar v1.0 Multiple Xss Vuln
http://xforce.iss.net/xforce/xfdb/25350
(UNKNOWN)  XF  extcalendar-calendar-xss(25350)
http://www.osvdb.org/23969
(UNKNOWN)  OSVDB  23969
http://securityreason.com/securityalert/601
(UNKNOWN)  SREASON  601
http://secunia.com/advisories/19321
(UNKNOWN)  SECUNIA  19321

- 漏洞信息

ExtCalendar跨站脚本攻击漏洞
中危 跨站脚本
2006-03-20 00:00:00 2006-03-23 00:00:00
远程  
        在ExtCalendar 1.0和可能其它2.0之前版本的calendar.php中存在跨站脚本攻击漏洞,远程攻击者可通过以下途径注入任意Web脚本或HTML:(1) year,(2) month,(3) next,和(4) prev参数。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,厂商发布了相关更新。

- 漏洞信息

23969
ExtCalendar calendar.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

ExtCalendar contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'year', 'month', 'next' or 'prev' variables upon submission to the calendar.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-03-19 Unknow
2006-03-19 Unknow

- 解决方案

Upgrade to version 2.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站