CVE-2006-1329
CVSS5.0
发布时间 :2006-03-20 20:06:00
修订时间 :2011-06-16 00:00:00
NMCOS    

[原文]The SASL negotiation in Jabber Studio jabberd before 2.0s11 allows remote attackers to cause a denial of service ("c2s segfault") by sending a "response stanza before an auth stanza".


[CNNVD]Jabber Studio JabberD远程拒绝服务漏洞(CNNVD-200603-337)

        在Jabber Studio jabberd 2.0s11之前版本中的SASL谈判程序可以让远程攻击者通过发送一条"response stanza before an auth stanza"制造拒绝服务("c2s segfault") 。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:jabberstudio:jabberd:2.0_s9
cpe:/a:jabberstudio:jabberd:2.0_s5
cpe:/a:jabberstudio:jabberd:2.0_a4
cpe:/a:jabberstudio:jabberd:2.0_a1
cpe:/a:jabberstudio:jabberd:2.0_b2
cpe:/a:jabberstudio:jabberd:2.0_s2
cpe:/a:jabberstudio:jabberd:2.0_a5
cpe:/a:jabberstudio:jabberd:2.0_s10
cpe:/a:jabberstudio:jabberd:2.0_s1
cpe:/a:jabberstudio:jabberd:2.0_b1
cpe:/a:jabberstudio:jabberd:2.0_b3
cpe:/a:jabberstudio:jabberd:2.0_s3
cpe:/a:jabberstudio:jabberd:2.0_s4
cpe:/a:jabberstudio:jabberd:2.0_a3
cpe:/a:jabberstudio:jabberd:2.0_rc1
cpe:/a:jabberstudio:jabberd:2.0_a6
cpe:/a:jabberstudio:jabberd:2.0_rc2
cpe:/a:jabberstudio:jabberd:2.0_s7
cpe:/a:jabberstudio:jabberd:2.0_s6
cpe:/a:jabberstudio:jabberd:2.0_s8
cpe:/a:jabberstudio:jabberd:2.0_a2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1329
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1329
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-337
(官方数据源) CNNVD

- 其它链接及资源

http://article.gmane.org/gmane.network.jabber.admin/27372
(PATCH)  CONFIRM  http://article.gmane.org/gmane.network.jabber.admin/27372
http://xforce.iss.net/xforce/xfdb/25334
(UNKNOWN)  XF  jabberd-sasl-dos(25334)
http://www.vupen.com/english/advisories/2006/1009
(VENDOR_ADVISORY)  VUPEN  ADV-2006-1009
http://www.securityfocus.com/bid/17155
(UNKNOWN)  BID  17155
http://www.redhat.com/support/errata/RHSA-2008-0261.html
(UNKNOWN)  REDHAT  RHSA-2008:0261
http://support.apple.com/kb/HT4077
(UNKNOWN)  CONFIRM  http://support.apple.com/kb/HT4077
http://secunia.com/advisories/19281
(VENDOR_ADVISORY)  SECUNIA  19281
http://lists.apple.com/archives/security-announce/2010//Mar/msg00001.html
(UNKNOWN)  APPLE  APPLE-SA-2010-03-29-1

- 漏洞信息

Jabber Studio JabberD远程拒绝服务漏洞
中危 其他
2006-03-20 00:00:00 2006-03-24 00:00:00
远程  
        在Jabber Studio jabberd 2.0s11之前版本中的SASL谈判程序可以让远程攻击者通过发送一条"response stanza before an auth stanza"制造拒绝服务("c2s segfault") 。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Jabber Software Foundation Jabber Server 2.0
        Jabber Software Foundation jabberd-2.0s11.tar.gz
        http://jabberstudio.org/projects/jabberd2/releases/download.php?file=j abberd-2.0s11.tar.gz
        Jabber Software Foundation Jabber Server 2.0 s8
        Jabber Software Foundation jabberd-2.0s11.tar.gz
        http://jabberstudio.org/projects/jabberd2/releases/download.php?file=j abberd-2.0s11.tar.gz
        Jabber Software Foundation Jabber Server 2.0 s9
        Jabber Software Foundation jabberd-2.0s11.tar.gz
        http://jabberstudio.org/projects/jabberd2/releases/download.php?file=j abberd-2.0s11.tar.gz
        Jabber Software Foundation Jabber Server 2.0 s10
        Jabber Software Foundation jabberd-2.0s11.tar.gz
        http://jabberstudio.org/projects/jabberd2/releases/download.php?file=j abberd-2.0s11.tar.gz
        

- 漏洞信息

24009
Jabber Studio jabberd SASL Negotiation Remote DoS
Remote / Network Access Denial of Service
Loss of Availability

- 漏洞描述

- 时间线

2006-03-20 Unknow
Unknow Unknow

- 解决方案

Upgrade to version S11 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Jabber Studio JabberD Remote Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 17155
Yes No
2006-03-20 12:00:00 2010-04-02 01:02:00
The vendor credits Jeremy Lunn and Stepehn Marquard with the discovery of this issue.

- 受影响的程序版本

RedHat Network Satellite (for RHEL 4) 4.2
RedHat Network Proxy (for RHEL 3) 4.2
Red Hat Network Satellite (for RHEL 3) 4.2
Red Hat Network Proxy (for RHEL 4) 5.0
Red Hat Network Proxy (for RHEL 4) 4.2
Jabber Software Foundation Jabber Server 2.0 s9
Jabber Software Foundation Jabber Server 2.0 s8
Jabber Software Foundation Jabber Server 2.0 s10
Jabber Software Foundation Jabber Server 2.0
Apple Mac OS X Server 10.6.2
Apple Mac OS X Server 10.6.1
Apple Mac OS X Server 10.5.8
Apple Mac OS X Server 10.6
Jabber Software Foundation Jabber Server 2.0 s11
Apple Mac OS X Server 10.6.3

- 不受影响的程序版本

Jabber Software Foundation Jabber Server 2.0 s11
Apple Mac OS X Server 10.6.3

- 漏洞讨论

Jabber Studio 'jabberd' is affected by a remote denial-of-service vulnerability. This issue is due to the application's failure to properly handle malformed network messages.

An attacker may leverage this issue by causing the affected server to crash, denying service to legitimate users.

- 漏洞利用

This issue can be exploited through the use of a client application for jabber.

- 解决方案

The vendor has released Jabber Server 2.0s11 to address this issue. Please see the referenced vendor advisory for information on obtaining and applying the appropriate updates.


Apple Mac OS X Server 10.6

Apple Mac OS X Server 10.5.8

Apple Mac OS X Server 10.6.1

Apple Mac OS X Server 10.6.2

Jabber Software Foundation Jabber Server 2.0

Jabber Software Foundation Jabber Server 2.0 s8

Jabber Software Foundation Jabber Server 2.0 s9

Jabber Software Foundation Jabber Server 2.0 s10

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站