发布时间 :2006-03-19 18:02:00
修订时间 :2011-02-04 00:00:00

[原文]Untrusted search path vulnerability in Beagle might allow local users to gain privileges via a malicious beagle-info program in the current working directory, or possibly directories specified in the PATH.



- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  beagle-beagle-status-privilege-escalation(25303)
(UNKNOWN)  BID  17195

- 漏洞信息

高危 设计错误
2006-03-19 00:00:00 2006-03-21 00:00:00

- 公告与补丁


- 漏洞信息

Beagle beagle-status Path Subversion Arbitrary Command Execution
Local Access Required Misconfiguration
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Beagle contains a flaw that may allow a local attacker to trick a user into executing arbitrary commands. The issue is due to the 'beagle-status' script not securely calling the 'beagle-info' file. By placing an alternate beagle-info file in a directory such as /tmp, there is a chance a user will execute the script and have any commands in the beagle-info file executed with the privileges of the user running the script.

- 时间线

2006-03-17 Unknow
2006-03-17 Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workaround: edit the beagle-status script to call the 'beagle-info' script with the full path

- 相关参考

- 漏洞作者

- 漏洞信息

Beagle Insecure Path Arbitrary Code Execution Vulnerability
Design Error 17195
No Yes
2006-03-22 12:00:00 2009-07-12 05:56:00
James McCaw discovered this vulnerability.

- 受影响的程序版本

Red Hat Fedora Core5

- 漏洞讨论

Beagle is susceptible to an insecure path vulnerability that can lead to arbitrary code execution.

This issue can allow attackers to place malicious code in a publicly writeable directory and can cause the code to be executed by beagle wrapper scripts. This would result in the execution of arbitrary code with the privileges of the user running the vulnerable application.

- 漏洞利用

An exploit is not required.

- 解决方案

Red Hat has released security advisory FEDORA-2006-188 to address this issue.

- 相关参考