CVE-2006-1294
CVSS7.5
发布时间 :2006-03-19 18:02:00
修订时间 :2011-03-07 21:32:43
NMCO    

[原文]PHP remote file include vulnerability in PageController.php in KnowledgebasePublisher 1.2 allows remote attackers to include and execute arbitrary PHP code via a URL in the dir parameter.


[CNNVD]KnowledgebasePublisher PageController.PHP远程文件包含漏洞(CNNVD-200603-310)

        KnowledgebasePublisher 1.2的PageController.php中存在的PHP远程文件包含漏洞,可让远程攻击者通过dir参数中的URL来执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1294
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1294
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-310
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1020
(UNKNOWN)  VUPEN  ADV-2006-1020
http://www.securityfocus.com/bid/17120
(UNKNOWN)  BID  17120
http://www.milw0rm.com/exploits/1587
(UNKNOWN)  MILW0RM  1587
http://xforce.iss.net/xforce/xfdb/25338
(UNKNOWN)  XF  knowledgebasepublisher-dir-file-include(25338)
http://www.osvdb.org/24002
(UNKNOWN)  OSVDB  24002
http://sourceforge.net/project/shownotes.php?release_id=402179&group_id=144153
(UNKNOWN)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=402179&group_id=144153
http://secunia.com/advisories/19298
(UNKNOWN)  SECUNIA  19298

- 漏洞信息

KnowledgebasePublisher PageController.PHP远程文件包含漏洞
高危 输入验证
2006-03-19 00:00:00 2006-03-20 00:00:00
远程  
        KnowledgebasePublisher 1.2的PageController.php中存在的PHP远程文件包含漏洞,可让远程攻击者通过dir参数中的URL来执行任意PHP代码。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本。

- 漏洞信息

24002
KnowledgebasePublisher PageController.php dir Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

KnowledgebasePublisher contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to PageController.php not properly sanitizing user input supplied to the 'dir' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-03-15 Unknow
2006-03-15 Unknow

- 解决方案

Upgrade to version 1.2.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站