发布时间 :2006-03-18 21:02:00
修订时间 :2008-09-05 17:01:27

[原文]Cross-site scripting (XSS) vulnerability in Service_Requests.asp in VPMi Enterprise 3.3 allows remote attackers to inject arbitrary web script or HTML via the Request_Name_Display parameter.

[CNNVD]虚拟通信服务VPMi 'Service_Requests.ASP'跨站脚本攻击漏洞(CNNVD-200603-294)

        VPMi Enterprise 3.3中的Service_Requests.asp中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过Request_Name_Display参数来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VIM  20060314 vendor dispute: VCS
(UNKNOWN)  XF  vpmi-servicerequests-xss(25339)
(UNKNOWN)  BID  17172

- 漏洞信息

虚拟通信服务VPMi 'Service_Requests.ASP'跨站脚本攻击漏洞
中危 跨站脚本
2006-03-18 00:00:00 2006-03-20 00:00:00
        VPMi Enterprise 3.3中的Service_Requests.asp中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过Request_Name_Display参数来注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

VPMi Enterprise Service_Requests.asp Request_Name_Display Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

VPMi Enterprise contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'Request_Name_Display' variable upon submission to the Service_Requests.asp script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-03-14 Unknow
2006-03-14 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Virtual Communication Services VPMi Service_Requests.ASP Cross-Site Scripting Vulnerability
Input Validation Error 17172
Yes No
2006-03-21 12:00:00 2006-03-21 09:44:00
Steven M. Christey is credited with the discovery of this vulnerability.

- 受影响的程序版本

Virtual Communication Services VPMi 3.3

- 漏洞讨论

VPMi Enterprise is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

This issue can be exploited through use of a web client.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 相关参考