CVE-2006-1249
CVSS6.8
发布时间 :2006-03-18 20:02:00
修订时间 :2011-03-07 21:32:31
NMCOPS    

[原文]Integer overflow in Apple QuickTime Player 7.0.3 and 7.0.4 and iTunes 6.0.1 and 6.0.2 allows remote attackers to execute arbitrary code via a FlashPix (FPX) image that contains a field that specifies a large number of blocks.


[CNNVD]Apple QuickTime FPX图像文件处理整数溢出漏洞(CNNVD-200603-296)

        Apple QuickTime是一款流行的多媒体播放器,支持多种媒体格式。
        Apple QuickTime对FlashPix图像文件元素的处理存在整数溢出漏洞,攻击者可能利用此漏洞诱使用户打开恶意文件,在用户机器上执行任意指令或导致进程崩溃。
        在FlashPix(fpx)文件中,有一个字段用于指定该文件中存在多少个数据块,如果有一个数据块大小为0x200,QuickTime Player会根据(number*0x200)的计算结果分配内存,但没有检查值的大小,导致整数溢出。如果将块数量的值设置为0x800000就会导致堆溢出,覆盖无效内存。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-189 [数值错误]

- CPE (受影响的平台与产品)

cpe:/a:apple:itunes:6.0.1Apple iTunes 6.0.1
cpe:/a:apple:itunes:6.0.2Apple iTunes 6.0.2
cpe:/a:apple:quicktime:7.0.3Apple Quicktime 7.0.3
cpe:/a:apple:quicktime:7.0.4Apple Quicktime 7.0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1249
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1249
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-296
(官方数据源) CNNVD

- 其它链接及资源

http://www.us-cert.gov/cas/techalerts/TA06-132B.html
(UNKNOWN)  CERT  TA06-132B
http://www.kb.cert.org/vuls/id/570689
(UNKNOWN)  CERT-VN  VU#570689
http://xforce.iss.net/xforce/xfdb/26398
(UNKNOWN)  XF  quicktime-flashpix-overflow(26398)
http://www.vupen.com/english/advisories/2006/1778
(UNKNOWN)  VUPEN  ADV-2006-1778
http://www.securityfocus.com/bid/17074
(UNKNOWN)  BID  17074
http://www.securityfocus.com/archive/1/archive/1/433850/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060511 [EEYEB-20060307] Apple QuickTime FPX Integer Overflow
http://www.securityfocus.com/archive/1/archive/1/433831/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060512 Apple QuickDraw/QuickTime Multiple Vulnerabilities
http://www.eeye.com/html/research/upcoming/20060307b.html
(UNKNOWN)  MISC  http://www.eeye.com/html/research/upcoming/20060307b.html
http://securitytracker.com/id?1016067
(UNKNOWN)  SECTRACK  1016067
http://secunia.com/advisories/20069
(VENDOR_ADVISORY)  SECUNIA  20069
http://lists.apple.com/archives/security-announce/2006/May/msg00002.html
(UNKNOWN)  APPLE  APPLE-SA-2006-05-11

- 漏洞信息

Apple QuickTime FPX图像文件处理整数溢出漏洞
中危 缓冲区溢出
2006-03-18 00:00:00 2006-06-01 00:00:00
远程  
        Apple QuickTime是一款流行的多媒体播放器,支持多种媒体格式。
        Apple QuickTime对FlashPix图像文件元素的处理存在整数溢出漏洞,攻击者可能利用此漏洞诱使用户打开恶意文件,在用户机器上执行任意指令或导致进程崩溃。
        在FlashPix(fpx)文件中,有一个字段用于指定该文件中存在多少个数据块,如果有一个数据块大小为0x200,QuickTime Player会根据(number*0x200)的计算结果分配内存,但没有检查值的大小,导致整数溢出。如果将块数量的值设置为0x800000就会导致堆溢出,覆盖无效内存。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        http://wsidecar.apple.com/cgi-bin/nph-reg3rdpty1.pl/product=09374&cat=1&platform=osx&method=sa/mac.html

- 漏洞信息 (F46419)

McAfee-2006-0511.txt (PacketStormID:F46419)
2006-05-21 00:00:00
Mike Price  
advisory,arbitrary,vulnerability,code execution
windows,apple,osx
CVE-2006-1249,CVE-2006-1453,CVE-2006-1454,CVE-2006-1459,CVE-2006-1460,CVE-2006-1461,CVE-2006-1462,CVE-2006-1464,CVE-2006-1465
[点击下载]

Two code execution vulnerabilities are present in Apple QuickDraw PICT image format support. Twenty one code execution vulnerabilities are present in Apple QuickTime support for various multimedia formats including: MOV, H.264, MPEG 4, AVI, FPX and SWF. Exploitation could lead to execution of arbitrary code. In order for an attack to succeed user interaction is required and therefore the risk factor for these issues is medium. Vulnerable systems include Mac OS X versions 10.4.6 and below without the May 2006 security update installed, QuickTime versions 7.0.4 and below for Mac OS X, and QuickTime for Windows versions 7.0.4 and below.

____________________________________________________________________

McAfee, Inc.
McAfee Avert    

- 漏洞信息 (F46407)

EEYEB-20060307.txt (PacketStormID:F46407)
2006-05-21 00:00:00
Fang Xing  eeye.com
advisory,web,overflow,activex
CVE-2006-1249
[点击下载]

eEye Digital Security has discovered a critical vulnerability in QuickTime Player. There is a integer overflow in the way QuickTime processes fpx format files. An attacker can create a fpx file and send it to the user via email, web page, or fpx file with activex.

Apple QuickTime FPX Integer Overflow

Release Date:
May 11, 2006

Date Reported:
March 7, 2006

Patch Development Time (In Days):
65     

Severity:
High (Remote Code Execution)

Vendor:
Apple

Systems Affected:
Quicktime on Windows 2000
Quicktime on Windows XP
Quicktime on Mac OS X 10.3.9

References:
This vulnerability has been assigned CVE-2006-1249

Overview:
eEye Digital Security has discovered a critical vulnerability in
QuickTime Player. There is a integer overflow in the way QuickTime
processes fpx format files. An attacker can create a fpx file and send
it to the user via email, web page, or fpx file with activex.

Technical Description:
In an fpx file, there is a field that figures out how many blocks of
data there are in that file. One block data size is 0x200, QuickTime
Player will allocate memory relying on (number*0x200) but does not check
the size value and an integer overflow can occur.  If you set the block
value to 0x800000 an integer overflow will occur which will then cause a
heap overflow and write invalid memory.  

QuickTime: QuickTime File Format
http://developer.apple.com/documentation/QuickTime/QTFF/index.html

Protection:
Retina Network Security Scanner has been updated to identify this
vulnerability.
Blink - Endpoint Vulnerability Prevention - preemptively protects from
this vulnerability.

Vendor Status:
Apple has released a patch for this vulnerability information is
available at  http://docs.info.apple.com/article.html?artnum=61798

Credit:
Discovery: Fang Xing

Copyright (c) 1998-2006 eEye Digital Security Permission is hereby
granted for the redistribution of this alert electronically. It is not
to be edited in any way without express consent of eEye. If you wish to
reprint the whole or any part of this alert in any other medium
excluding electronic medium, please email alert@eEye.com for permission.

Disclaimer
The information within this paper may change without notice. Use of this
information constitutes acceptance for use in an AS IS condition. There
are no warranties, implied or express, with regard to this information.
In no event shall the author be liable for any direct or indirect
damages whatsoever arising out of or in connection with the use or
spread of this information. Any use of this information is at the user's
own risk.
    

- 漏洞信息

25514
Apple QuickTime FPX Processing Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-09 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 7.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Apple QuickTime/iTunes Integer And Heap Overflow Vulnerabilities
Boundary Condition Error 17074
Yes No
2006-03-11 12:00:00 2006-05-15 09:49:00
The vendor disclosed these vulnerabilities.

- 受影响的程序版本

eSignal eSignal 6.0.2
Apple QuickTime Player 7.0.4
Apple QuickTime Player 7.0.3
Apple Mac OS X Server 10.4.6
Apple Mac OS X Server 10.4.5
Apple Mac OS X Server 10.4.4
Apple Mac OS X Server 10.4.3
Apple Mac OS X Server 10.4.2
Apple Mac OS X Server 10.4.1
Apple Mac OS X Server 10.4
Apple Mac OS X Server 10.3.9
Apple Mac OS X 10.4.6
Apple Mac OS X 10.4.5
Apple Mac OS X 10.4.4
Apple Mac OS X 10.4.3
Apple Mac OS X 10.4.2
Apple Mac OS X 10.4.1
Apple Mac OS X 10.4
Apple Mac OS X 10.3.9
Apple iTunes 6.0.1
Apple QuickTime Player 7.1

- 不受影响的程序版本

Apple QuickTime Player 7.1

- 漏洞讨论


Two vulnerabilities have been reported in Apple QuickTime and iTunes:

- an integer overflow
- a heap-based buffer overflow

These issues affect both Mac OS X and Microsoft Windows releases of the software.

A successful exploit will result in the execution of arbitrary code in the context of the currently logged-in user.

- 漏洞利用


No exploit is required.

- 解决方案

The vendor has released QuickTime version 7.1 to address this and other issues.


Apple QuickTime Player 7.0.3

Apple QuickTime Player 7.0.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站