CVE-2006-1240
CVSS4.6
发布时间 :2006-03-15 12:06:00
修订时间 :2008-09-05 17:01:23
NMCO    

[原文]Buffer overflow in inet_server.cpp in (1) fb_inet_server and (2) fbserver in Firebird 1.5.2.4731 allows local users to gain privileges via a long value of the -p argument.


[CNNVD]Firebird Local Inet_Server缓冲区溢出漏洞(CNNVD-200603-279)

        在Firebird 1.5.2.4731的(1) fb_inet_server和(2) fbserver中的inet_server.cpp中存在缓冲区溢出,本地用户可通过-p长参数值取得特权。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:firebirdsql:firebird:1.5.1Firebird Firebird 1.5.1
cpe:/a:firebirdsql:firebird:1.5.2Firebird Firebird 1.5.2
cpe:/a:firebirdsql:firebird:1.5Firebird Firebird 1.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1240
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1240
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-279
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/17077
(PATCH)  BID  17077
http://www.securityfocus.com/archive/1/archive/1/427480/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060312 Buffer Overflow and Installation Script Error in Firebird 1.5.3
http://xforce.iss.net/xforce/xfdb/25282
(UNKNOWN)  XF  firebird-fbinetserver-fbserver-bo(25282)
http://lists.grok.org.uk/pipermail/full-disclosure/2006-March/043546.html
(UNKNOWN)  FULLDISC  20060312 Buffer Overflow and Installation Script Error in Firebird 1.5.3

- 漏洞信息

Firebird Local Inet_Server缓冲区溢出漏洞
中危 缓冲区溢出
2006-03-15 00:00:00 2006-09-05 00:00:00
本地  
        在Firebird 1.5.2.4731的(1) fb_inet_server和(2) fbserver中的inet_server.cpp中存在缓冲区溢出,本地用户可通过-p长参数值取得特权。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Firebird Firebird 1.5
        Firebird Firebird V1.5 Downloads
        http://firebird.sourceforge.net/index.php?op=files&id=engine
        Firebird Firebird 1.5.1
        Firebird Firebird V1.5 Downloads
        http://firebird.sourceforge.net/index.php?op=files&id=engine
        Firebird Firebird 1.5.2
        Firebird Firebird V1.5 Downloads
        http://firebird.sourceforge.net/index.php?op=files&id=engine
        

- 漏洞信息

24317
Firebird fbserver -p Parameter Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-03-12 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.5.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站