CVE-2006-1230
CVSS4.3
发布时间 :2006-03-14 14:06:00
修订时间 :2011-09-13 00:00:00
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in create.php in vCard 2.x allow remote attackers to inject arbitrary web script or HTML via the (1) card_id, (2) uploaded, (3) card_fontsize, or (4) card_color parameter. NOTE: the card_id vector was later reported to affect vCard 2.9, and the uploaded vector for 2.6.


[CNNVD]vCard 'Create.PHP'多个跨站脚本攻击漏洞(CNNVD-200603-252)

        在vCard 2.x的create.php中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可通过(1) card_id,(2) uploaded,(3) card_fontsize,或 (4) card_color参数,注入任意Web脚本或HTML。注意:后面有报告称card_id vector影响到vCard 2.9,和上载向量影响到2.6。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:belchior_foundry:vcard:2.8
cpe:/a:belchior_foundry:vcard:2.6
cpe:/a:belchior_foundry:vcard:2.9

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1230
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1230
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-252
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/25181
(UNKNOWN)  XF  vcard-create-xss(25181)
http://www.vupen.com/english/advisories/2006/0945
(VENDOR_ADVISORY)  VUPEN  ADV-2006-0945
http://www.securityfocus.com/bid/22819
(UNKNOWN)  BID  22819
http://www.securityfocus.com/bid/17073
(UNKNOWN)  BID  17073
http://www.securityfocus.com/archive/1/archive/1/461922/100/0/threaded
(UNKNOWN)  BUGTRAQ  20070304 XSS Remote In vCard 2.6 (c)2002
http://www.securityfocus.com/archive/1/archive/1/435310/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060527 multiple Xss exploits in : vCard 2.9
http://www.securityfocus.com/archive/1/archive/1/427408/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060311 XSS in vCard
http://www.osvdb.org/23838
(UNKNOWN)  OSVDB  23838
http://securitytracker.com/id?1016183
(UNKNOWN)  SECTRACK  1016183
http://secunia.com/advisories/19216
(VENDOR_ADVISORY)  SECUNIA  19216

- 漏洞信息

vCard 'Create.PHP'多个跨站脚本攻击漏洞
中危 跨站脚本
2006-03-14 00:00:00 2007-08-27 00:00:00
远程  
        在vCard 2.x的create.php中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可通过(1) card_id,(2) uploaded,(3) card_fontsize,或 (4) card_color参数,注入任意Web脚本或HTML。注意:后面有报告称card_id vector影响到vCard 2.9,和上载向量影响到2.6。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本。

- 漏洞信息

23838
vCard PRO create.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

vCard PRO contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'card_id', 'uploaded', 'card_fontsize', and 'card_color' variables upon submission to the create.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-03-11 Unknow
2006-03-11 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站