CVE-2006-1228
CVSS5.1
发布时间 :2006-03-14 14:06:00
修订时间 :2008-09-05 00:00:00
NMCO    

[原文]Session fixation vulnerability in Drupal 4.5.x before 4.5.8 and 4.6.x before 4.5.8 allows remote attackers to gain privileges by tricking a user to click on a URL that fixes the session identifier.


[CNNVD]Drupal 会话固定漏洞(CNNVD-200603-266)

        在Drupal 4.5.8之前版本4.5.x和4.5.8之前版本4.6.x中存在会话固定漏洞,远程攻击者可通过诱使用户去点击一个固定会话标识的URL取得特权。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-287 [认证机制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:drupal:drupal:4.6.0
cpe:/a:drupal:drupal:4.5.2
cpe:/a:drupal:drupal:4.6.1
cpe:/a:drupal:drupal:4.5.0
cpe:/a:drupal:drupal:4.5.3
cpe:/a:drupal:drupal:4.5.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1228
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1228
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-266
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/427589/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060314 [DRUPAL-SA-2006-003] Drupal 4.6.6 / 4.5.8 fixes session fixation issue
http://secunia.com/advisories/19245
(VENDOR_ADVISORY)  SECUNIA  19245
http://drupal.org/node/53805
(VENDOR_ADVISORY)  CONFIRM  http://drupal.org/node/53805
http://xforce.iss.net/xforce/xfdb/25205
(UNKNOWN)  XF  drupal-login-session-hijacking(25205)
http://www.securityfocus.com/bid/17104
(UNKNOWN)  BID  17104
http://www.osvdb.org/23911
(UNKNOWN)  OSVDB  23911
http://www.debian.org/security/2006/dsa-1007
(UNKNOWN)  DEBIAN  DSA-1007
http://securityreason.com/securityalert/580
(UNKNOWN)  SREASON  580
http://secunia.com/advisories/19257
(UNKNOWN)  SECUNIA  19257

- 漏洞信息

Drupal 会话固定漏洞
中危 输入验证
2006-03-14 00:00:00 2006-03-17 00:00:00
远程  
        在Drupal 4.5.8之前版本4.5.x和4.5.8之前版本4.6.x中存在会话固定漏洞,远程攻击者可通过诱使用户去点击一个固定会话标识的URL取得特权。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Drupal Drupal 4.5.3
        Debian drupal_4.5.3-6_all.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/d/drupal/drupal_4.5.3-6_a ll.deb
        

- 漏洞信息

23911
Drupal Login Session Fixation Hijacking
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

Drupal contains a flaw that may allow a malicious user to hijack a user's session. The issue is triggered when the victim clicks on a specially crafted link and then later logs on to Drupal resulting in a loss of integrity.

- 时间线

2006-03-13 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.5.8, 4.6.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站