CVE-2006-1225
CVSS5.0
发布时间 :2006-03-14 14:06:00
修订时间 :2008-09-05 17:01:20
NMCOS    

[原文]CRLF injection vulnerability in Drupal 4.5.x before 4.5.8 and 4.6.x before 4.5.8 allows remote attackers to inject headers of outgoing e-mail messages and use Drupal as a spam proxy.


[CNNVD]Drupal CRLF注入漏洞(CNNVD-200603-247)

        Drupal 4.5.8之前版本4.5.x和4.5.8之前版本4.6.x中存在CRLF注入漏洞,远程攻击者可注入代码进发出邮件的报头和利用Drupal作为垃圾邮件代理。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:drupal:drupal:4.6.0
cpe:/a:drupal:drupal:4.5.2
cpe:/a:drupal:drupal:4.6.1
cpe:/a:drupal:drupal:4.5.0
cpe:/a:drupal:drupal:4.5.3
cpe:/a:drupal:drupal:4.5.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1225
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1225
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-247
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/427591/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060314 [DRUPAL-SA-2006-004] Drupal 4.6.6 / 4.5.8 fixes mail header injection issue
http://secunia.com/advisories/19245
(VENDOR_ADVISORY)  SECUNIA  19245
http://drupal.org/node/53806
(VENDOR_ADVISORY)  CONFIRM  http://drupal.org/node/53806
http://xforce.iss.net/xforce/xfdb/25206
(UNKNOWN)  XF  drupal-header-data-manipulation(25206)
http://www.securityfocus.com/bid/17104
(UNKNOWN)  BID  17104
http://www.osvdb.org/23912
(UNKNOWN)  OSVDB  23912
http://www.debian.org/security/2006/dsa-1007
(UNKNOWN)  DEBIAN  DSA-1007
http://securityreason.com/securityalert/579
(UNKNOWN)  SREASON  579
http://secunia.com/advisories/19257
(UNKNOWN)  SECUNIA  19257

- 漏洞信息

Drupal CRLF注入漏洞
中危 输入验证
2006-03-14 00:00:00 2006-03-17 00:00:00
远程  
        Drupal 4.5.8之前版本4.5.x和4.5.8之前版本4.6.x中存在CRLF注入漏洞,远程攻击者可注入代码进发出邮件的报头和利用Drupal作为垃圾邮件代理。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Drupal Drupal 4.5.3
        Debian drupal_4.5.3-6_all.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/d/drupal/drupal_4.5.3-6_all.deb

- 漏洞信息

23912
Drupal Email Crafted Header Spoofing
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

Drupal contains a flaw allows a malicious user to insert line feeds and carriage returns into outgoing email. This allows the attacker to insert bogus headers into outgoing email. This could lead to Drupal sites being used to send unwanted email.

- 时间线

2006-03-13 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.5.8, 4.6.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Drupal Multiple Input Validation Vulnerabilities
Input Validation Error 17104
Yes No
2006-03-14 12:00:00 2006-07-19 10:42:00
The vendor credits Norrin, kbahey and Markus Petrux with the discovery of these issues.

- 受影响的程序版本

Drupal Drupal 4.6.5
Drupal Drupal 4.6.4
Drupal Drupal 4.6.3
Drupal Drupal 4.6.2
Drupal Drupal 4.6.1
Drupal Drupal 4.6
Drupal Drupal 4.5.7
Drupal Drupal 4.5.6
Drupal Drupal 4.5.5
Drupal Drupal 4.5.4
Drupal Drupal 4.5.3
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
+ Debian Linux 3.1
Drupal Drupal 4.5.2
Drupal Drupal 4.5.2
Drupal Drupal 4.5.1
Drupal Drupal 4.5
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Drupal Drupal 4.6.6
Drupal Drupal 4.5.8

- 不受影响的程序版本

Drupal Drupal 4.6.6
Drupal Drupal 4.5.8

- 漏洞讨论

Drupal is prone to multiple input-validation vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage these issues to:

- have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site
- access sensitive information
- hijack user sessions
- use a vulnerable Drupal installation as an email relay.

- 漏洞利用

Attackers can exploit this issue via a web client.

- 解决方案

The vendor has released updates to address these issues. Please see the referenced vendor advisories for more information.

The CRLF-injection vulnerabilities have been fixed in Drupal Form_mail 1.8.2.2; BID 18833 contains detailed information regarding these issues.


Drupal Drupal 4.5.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站