CVE-2006-1203
CVSS7.5
发布时间 :2006-03-13 20:06:00
修订时间 :2008-09-05 17:01:17
NMCO    

[原文]PHP remote file include vulnerability in common.php in txtForum 1.0.4-dev and earlier allows remote attackers to include and execute arbitrary PHP code via a URL in the skin parameter to login.php, and possibly other parameters to other PHP scripts, related to include statements in common.php.


[CNNVD]txtForum ‘common.php’ PHP远程文件包含漏洞(CNNVD-200603-227)

        txtForum 1.0.4-dev及其早期版本的common.php中存在PHP远程文件包含漏洞,远程攻击者要通过以下途径包含和执行任意PHP代码:用于login.php的skin参数中的URL,和可能用于其它脚本的其它参数,它们与common.php中的包含叙述有关。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1203
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1203
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-227
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/427188/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060309 txtForum: Script Injection Vulnerability
http://www.seclab.tuwien.ac.at/advisories/TUVSA-0603-004.txt
(VENDOR_ADVISORY)  MISC  http://www.seclab.tuwien.ac.at/advisories/TUVSA-0603-004.txt
http://xforce.iss.net/xforce/xfdb/25131
(UNKNOWN)  XF  txtforum-login-file-include(25131)
http://www.securityfocus.com/bid/17061
(UNKNOWN)  BID  17061
http://www.osvdb.org/23952
(UNKNOWN)  OSVDB  23952

- 漏洞信息

txtForum ‘common.php’ PHP远程文件包含漏洞
高危 输入验证
2006-03-13 00:00:00 2006-03-14 00:00:00
远程  
        txtForum 1.0.4-dev及其早期版本的common.php中存在PHP远程文件包含漏洞,远程攻击者要通过以下途径包含和执行任意PHP代码:用于login.php的skin参数中的URL,和可能用于其它脚本的其它参数,它们与common.php中的包含叙述有关。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本。

- 漏洞信息

23952
txtForum login.php skin Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

txtForum contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to login.php script not properly sanitizing user input supplied to the 'skin' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script. This issue stems from an include statement made in the common.php script and may allow additional vectors for exploitation.

- 时间线

2006-03-09 Unknow
2006-03-09 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站