CVE-2006-1174
CVSS3.7
发布时间 :2006-05-28 19:02:00
修订时间 :2011-03-10 00:00:00
NMCOPS    

[原文]useradd in shadow-utils before 4.0.3, and possibly other versions before 4.0.8, does not provide a required argument to the open function when creating a new user mailbox, which causes the mailbox to be created with unpredictable permissions and possibly allows attackers to read or modify the mailbox.


[CNNVD]Shadow-Utils UserAdd 权限和访问控制漏洞(CNNVD-200605-501)

        shadow-utils 4.0.3以及可能的4.0.8之前的其他版本中的useradd在创建新用户邮箱时,未提供用于打开函数的所需自变量,这会使邮箱以不可预测的权限创建,并可能使攻击者读取或修改邮箱。

- CVSS (基础分值)

CVSS分值: 3.7 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-264 [权限、特权与访问控制]

- CPE (受影响的平台与产品)

cpe:/a:debian:shadow-utils:4.0.6Debian shadow 4.0.6
cpe:/a:debian:shadow-utils:4.0.1Debian shadow 4.0.1
cpe:/a:debian:shadow-utils:4.0.2Debian shadow 4.0.2
cpe:/a:debian:shadow-utils:4.0.5Debian shadow 4.0.5
cpe:/a:debian:shadow-utils:4.0.7Debian shadow 4.0.7
cpe:/a:debian:shadow-utils:4.0.4Debian shadow 4.0.4
cpe:/a:debian:shadow-utils:4.0.4.1Debian shadow 4.0.4.1
cpe:/a:debian:shadow-utils:4.0.0Debian shadow 4.0.0

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:10807useradd in shadow-utils before 4.0.3, and possibly other versions before 4.0.8, does not provide a required argument to the open function wh...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1174
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1174
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-501
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/312692
(UNKNOWN)  CERT-VN  VU#312692
http://www.securityfocus.com/bid/18111
(PATCH)  BID  18111
http://secunia.com/advisories/20370
(VENDOR_ADVISORY)  SECUNIA  20370
https://issues.rpath.com/browse/RPL-1357
(UNKNOWN)  CONFIRM  https://issues.rpath.com/browse/RPL-1357
http://xforce.iss.net/xforce/xfdb/26958
(UNKNOWN)  XF  shadow-utils-useradd-file-permission(26958)
http://www.vupen.com/english/advisories/2007/3229
(VENDOR_ADVISORY)  VUPEN  ADV-2007-3229
http://www.vupen.com/english/advisories/2006/2006
(VENDOR_ADVISORY)  VUPEN  ADV-2006-2006
http://www.securitytracker.com/id?1018221
(UNKNOWN)  SECTRACK  1018221
http://www.securityfocus.com/archive/1/archive/1/468336/100/0/threaded
(UNKNOWN)  BUGTRAQ  20070511 rPSA-2007-0096-1 shadow
http://www.redhat.com/support/errata/RHSA-2007-0431.html
(UNKNOWN)  REDHAT  RHSA-2007:0431
http://www.redhat.com/support/errata/RHSA-2007-0276.html
(UNKNOWN)  REDHAT  RHSA-2007:0276
http://www.mandriva.com/security/advisories?name=MDKSA-2006:090
(UNKNOWN)  MANDRIVA  MDKSA-2006:090
http://www.gentoo.org/security/en/glsa/glsa-200606-02.xml
(UNKNOWN)  GENTOO  GLSA-200606-02
http://support.avaya.com/elmodocs2/security/ASA-2007-249.htm
(UNKNOWN)  CONFIRM  http://support.avaya.com/elmodocs2/security/ASA-2007-249.htm
http://secunia.com/advisories/27706
(VENDOR_ADVISORY)  SECUNIA  27706
http://secunia.com/advisories/26909
(VENDOR_ADVISORY)  SECUNIA  26909
http://secunia.com/advisories/25896
(VENDOR_ADVISORY)  SECUNIA  25896
http://secunia.com/advisories/25894
(VENDOR_ADVISORY)  SECUNIA  25894
http://secunia.com/advisories/25629
(VENDOR_ADVISORY)  SECUNIA  25629
http://secunia.com/advisories/25267
(VENDOR_ADVISORY)  SECUNIA  25267
http://secunia.com/advisories/25098
(VENDOR_ADVISORY)  SECUNIA  25098
http://secunia.com/advisories/20506
(VENDOR_ADVISORY)  SECUNIA  20506
http://lists.grok.org.uk/pipermail/full-disclosure/2007-September/065902.html
(UNKNOWN)  FULLDISC  20070920 VMSA-2007-0006 Critical security updates for all supported versions of VMware ESX Server, VMware Server, VMware Workstation, VMware ACE, and VMware Player
http://cvs.pld.org.pl/shadow/NEWS?rev=1.109
(UNKNOWN)  CONFIRM  http://cvs.pld.org.pl/shadow/NEWS?rev=1.109
ftp://patches.sgi.com/support/free/security/advisories/20070602-01-P.asc
(UNKNOWN)  SGI  20070602-01-P

- 漏洞信息

Shadow-Utils UserAdd 权限和访问控制漏洞
低危 竞争条件
2006-05-28 00:00:00 2006-08-24 00:00:00
本地  
        shadow-utils 4.0.3以及可能的4.0.8之前的其他版本中的useradd在创建新用户邮箱时,未提供用于打开函数的所需自变量,这会使邮箱以不可预测的权限创建,并可能使攻击者读取或修改邮箱。

- 公告与补丁

        厂商已发布4.0.8 版本以解决此问题。
        请参阅引用公告了解获取和应用修复补丁的更多信息。
        SGI ProPack 3.0 SP6
        
        shadow shadow 4.0.3
        

- 漏洞信息 (F59465)

VMware Security Advisory 2007-0006 (PacketStormID:F59465)
2007-09-20 00:00:00
VMware  vmware.com
advisory,denial of service,arbitrary,vulnerability,code execution
CVE-2007-2446,CVE-2007-2447,CVE-2007-0494,CVE-2007-2442,CVE-2007-2443,CVE-2007-2798,CVE-2007-0061,CVE-2007-0062,CVE-2007-0063,CVE-2007-4059,CVE-2007-4155,CVE-2007-4496,CVE-2007-4497,CVE-2007-1856,CVE-2006-1174,CVE-2006-4600,CVE-2004-0813,CVE-2007-1716
[点击下载]

VMware Security Advisory - Updates have been released for arbitrary code execution, denial of service, and other various vulnerabilities in VMware.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

- - -------------------------------------------------------------------
                   VMware Security Advisory

Advisory ID:       VMSA-2007-0006
Synopsis:          Critical security updates for all supported
                   versions of VMware ESX Server, VMware Server,
                   VMware Workstation, VMware ACE, and
                   VMware Player

Issue date:        2007-09-18
Updated on:        2007-09-18

CVE numbers:       CVE-2007-2446 CVE-2007-2447 CVE-2007-0494
                   CVE-2007-2442 CVE-2007-2443 CVE-2007-2798
                   CVE-2007-0061 CVE-2007-0062 CVE-2007-0063
                   CVE-2007-4059 CVE-2007-4155 CVE-2007-4496
                   CVE-2007-4497 CVE-2007-1856 CVE-2006-1174
                   CVE-2006-4600 CVE-2004-0813 CVE-2007-1716
                   CVE-2006-3619 CVE-2006-4146
- - -------------------------------------------------------------------

1. Summary:

Updated versions of all supported hosted products and all ESX 2x
products and patches for ESX 30x address critical security updates.

Service Console security updates for samba, bind, krb5, vixie-cron,
shadow-utils, openldap, pam, gcc, and gdb packages.

2. Relevant releases:

VMware Workstation 6.0.0
VMware Player 2.0.0
VMware ACE 2.0.0

VMware Workstation prior to 5.5.5
VMware Player prior to 1.0.5
VMware Server prior to 1.0.4
VMware ACE prior to 1.0.4

VMware ESX 3.0.2 without patches ESX-1001725 ESX-1001731 ESX-1001726
                                 ESX-1001727 ESX-1001728 ESX-1001729
                                 ESX-1001730

VMware ESX 3.0.1 without patches ESX-8258730 ESX-1001213 ESX-1001691
                                 ESX-1001723 ESX-1001214 ESX-1001692
                                 ESX-1001693 ESX-1001694 ESX-8253547
                                 ESX-8567382

VMware ESX 3.0.0 without patches ESX-4809553 ESX-1001204 ESX-1001206
                                 ESX-1001212 ESX-1001205 ESX-1001207
                                 ESX-1001208 ESX-1001209 ESX-1001210
                                 ESX-1001211

VMware ESX 2.5.4 prior to upgrade patch 10 (Build# 53326)
VMware ESX 2.5.3 prior to upgrade patch 13 (Build# 52488)
VMware ESX 2.1.3 prior to upgrade patch  8 (Build# 53228)
VMware ESX 2.0.2 prior to upgrade patch  8 (Build# 52650)

3. Problem description:

Problems addressed by these patches:

I    Arbitrary code execution and denial of service vulnerabilities

     This release fixes a security vulnerability that could allow a
     guest operating system user with administrative privileges to cause
     memory corruption in a host process, and thus potentially execute
     arbitrary code on the host. (CVE-2007-4496)

     This release fixes a denial of service vulnerability that could
     allow a guest operating system to cause a host process to become
     unresponsive or exit unexpectedly. (CVE-2007-4497)

     Thanks to Rafal Wojtczvk of McAfee for identifying and reporting
     these issues.

     ESX
     ---
     VMware ESX 3.0.1 Download Patch Bundle ESX-8258730
     http://www.vmware.com/support/vi3/doc/esx-8258730-patch.html
     md5sum a06d0e36e403b0fe6bc6fbc76220a86d

     VMware ESX 3.0.0 Download Patch Bundle ESX-4809553
     http://www.vmware.com/support/vi3/doc/esx-4809553-patch.html
     md5sum cd363526aab5fa6c45bf2509cb5ae500

     NOTE: ESX 3.0.0 is nearing its End-of-life (10/05/2007) users
     should upgrade to at least 3.0.1 and preferably the newest
     release available.

     VMware ESX 2.5.4 upgrade to patch 10 (Build# 53326)
     VMware ESX 2.5.3 upgrade to patch 13 (Build# 52488)
     VMware ESX 2.1.3 upgrade to patch  8 (Build# 53228)
     VMware ESX 2.0.2 upgrade to patch  8 (Build# 52650)

     NOTE: ESX 3.0.2 is not affected by this issue

     Hosted products
     ---------------
     VMware Workstation 6.0.0 upgrade to version 6.0.1 (Build# 55017)
     VMware Workstation 5.5.4 upgrade to version 5.5.5 (Build# 56455)
     VMware Player      2.0.0 upgrade to version 2.0.1 (Build# 55017)
     VMware Player      1.0.4 upgrade to version 1.0.5 (Build# 56455)
     VMware Server      1.0.3 upgrade to version 1.0.4 (Build# 56528)
     VMware ACE         2.0.0 upgrade to version 2.0.1 (Build# 55017)
     VMware ACE         1.0.3 upgrade to version 1.0.4 (Build# 54075)

II   Hosted products DHCP security vulnerabilities addressed

     This release fixes several vulnerabilities in the DHCP server
     that could enable a specially crafted packets to gain system-level
     privileges. (CVE-2007-0061, CVE-2007-0062, CVE-2007-0063)

     Thanks to Neel Mehta and Ryan Smith of the IBM Internet Security
     Systems X-Force for discovering and researching these
     vulnerabilities.

     Hosted products
     ---------------
     VMware Workstation 6.0.0 upgrade to version 6.0.1 (Build# 55017)
     VMware Workstation 5.5.4 upgrade to version 5.5.5 (Build# 56455)
     VMware Player      2.0.0 upgrade to version 2.0.1 (Build# 55017)
     VMware Player      1.0.4 upgrade to version 1.0.5 (Build# 56455)
     VMware Server      1.0.3 upgrade to version 1.0.4 (Build# 56528)
     VMware ACE         2.0.0 upgrade to version 2.0.1 (Build# 55017)
     VMware ACE         1.0.3 upgrade to version 1.0.4 (Build# 54075)

III  Windows based hosted product vulnerability in
     IntraProcessLogging.dll and vielib.dll.

     This release fixes a security vulnerability that could allow a
     malicious remote user to exploit the library file
     IntraProcessLogging.dll to overwrite files in a system.
     (CVE-2007-4059)

     This release fixes a security vulnerability that could allow a
     malicious remote user to exploit the library file vielib.dll to
     overwrite files in a system. (CVE-2007-4155)

     Thanks to the Goodfellas Security Research Team for discovering and
     researching these vulnerabilities.

     Hosted products
     ---------------
     VMware Workstation 6.0.0 upgrade to version 6.0.1 (Build# 55017)
     VMware Workstation 5.5.4 upgrade to version 5.5.5 (Build# 56455)
     VMware Player      2.0.0 upgrade to version 2.0.1 (Build# 55017)
     VMware Player      1.0.4 upgrade to version 1.0.5 (Build# 56455)
     VMware Server      1.0.3 upgrade to version 1.0.4 (Build# 56528)
     VMware ACE         2.0.0 upgrade to version 2.0.1 (Build# 55017)
     VMware ACE         1.0.3 upgrade to version 1.0.4 (Build# 54075)


IV  Escalation of privileges on Windows hosted systems

     This release fixes a security vulnerability in which Workstation
     was starting registered Windows services in an insecure manner.
     This vulnerability could allow a malicious user to escalate user
     privileges.

     Thanks to Foundstone for discovering this vulnerability.

     Hosted products
     ---------------
     VMware Workstation 6.0.0 upgrade to version 6.0.1 (Build# 55017)
     VMware Workstation 5.5.4 upgrade to version 5.5.5 (Build# 56455)
     VMware Player      2.0.0 upgrade to version 2.0.1 (Build# 55017)
     VMware Player      1.0.4 upgrade to version 1.0.5 (Build# 56455)
     VMware Server      1.0.3 upgrade to version 1.0.4 (Build# 56528)
     VMware ACE         2.0.0 upgrade to version 2.0.1 (Build# 55017)
     VMware ACE         1.0.3 upgrade to version 1.0.4 (Build# 54075)

V    Potential denial of service using VMware Player

     This release fixes a problem that prevented VMware Player from
     launching. This problem was accompanied by the error message VMware
     Player unrecoverable error: (player) Exception 0xc0000005 (access
     violation) has occurred.

     Hosted products
     ---------------
     VMware Player      2.0.0 upgrade to version 2.0.1 (Build# 55017)
     VMware Player      1.0.4 upgrade to version 1.0.5 (Build# 56455)

VI   ESX Service Console updates

a.   Service console package Samba, has been updated to address the
     following issues:

     Various bugs were found in NDR parsing, used to decode MS-RPC
     requests in Samba. A remote attacker could have sent carefully
     crafted requests causing a heap overflow, which may have led to the
     ability to execute arbitrary code on the server. (CVE-2007-2446)

     Unescaped user input parameters were being passed as arguments to
     /bin/sh. A remote, authenticated, user could have triggered this
     flaw and executed arbitrary code on the server. Additionally, this
     flaw could be triggered by a remote unauthenticated user if Samba
     was configured to use the non-default username map script option.
     (CVE-2007-2447)

     Thanks to the Samba developers, TippingPoint, and iDefense for
     identifying and reporting these issues.

     Note: These issues only affect the service console network, and are
     not remote vulnerabilities for ESX Server hosts that have been set
     up with the security best practices provided by VMware.
     http://www.vmware.com/resources/techresources/726

     ESX
     ---
     VMware ESX 3.0.1 Download Patch Bundle ESX-1001213
     http://www.vmware.com/support/vi3/doc/esx-1001213-patch.html
     md5sum 4e942e5b47f90654696910fb8b10b144

     VMware ESX 3.0.0 Download Patch Bundle ESX-1001204
     http://www.vmware.com/support/vi3/doc/esx-1001204-patch.html
     md5sum 08bfdec038ea900c72f04e8d50b2db62

     NOTE: ESX 3.0.0 is nearing its End-of-life (10/05/2007) users
     should upgrade to at least 3.0.1 and preferably the newest
     release available

     VMware ESX 2.5.4 prior to upgrade patch 10 (Build# 53326)
     VMware ESX 2.5.3 prior to upgrade patch 13 (Build# 52488)
     VMware ESX 2.1.3 prior to upgrade patch  8 (Build# 53228)
     VMware ESX 2.0.2 prior to upgrade patch  8 (Build# 52650)

     NOTE: ESX 3.0.2 is not affected by this issue

b.   Updated bind package for the service console fixes a flaw with the
     way ISC BIND processed certain DNS query responses.

     ISC BIND (Berkeley Internet Name Domain) is an implementation of
     the DNS (Domain Name System) protocols. Under some circumstances, a
     malicious remote user could launch a Denial-of-Service attack on
     ESX Server hosts that had enabled DNSSEC validation.
     (CVE-2007-0494)

     Note: These issues only affect the service console network, and are
     not remote vulnerabilities for ESX Server hosts that have been set
     up with the security best practices provided by VMware.
     http://www.vmware.com/resources/techresources/726

     ESX
     ---
     VMware ESX 3.0.2 Download Patch Bundle ESX-1001725
     http://www.vmware.com/support/vi3/doc/esx-1001725-patch.html
     md5sum 75aa49eecec2e84eb41a4c26683d4c7a

     VMware ESX 3.0.1 Download Patch Bundle ESX-1001691
     http://www.vmware.com/support/vi3/doc/esx-1001691-patch.html
     md5sum e288a71c4953aa6724ce53879c663f81

     VMware ESX 3.0.0 Download Patch Bundle ESX-1001206
     http://www.vmware.com/support/vi3/doc/esx-1001206-patch.html
     md5sum bd552eb70624164067039525941ce82a

     NOTE: ESX 3.0.0 is nearing its End-of-life (10/05/2007) users
     should upgrade to at least 3.0.1 and preferably the newest
     release available

     VMware ESX 2.5.4 prior to upgrade patch 10 (Build# 53326)
     VMware ESX 2.5.3 prior to upgrade patch 13 (Build# 52488)
     VMware ESX 2.1.3 prior to upgrade patch  8 (Build# 53228)
     VMware ESX 2.0.2 prior to upgrade patch  8 (Build# 52650)

c.   This patch provides updated service console package krb5 update.

     The Common Vulnerabilities and Exposures project (cve.mitre.org)
     assigned the names CVE-2007-2442, CVE-2007-2443, and CVE-2007-2798
     to these security issues.

     Thanks to Wei Wang of McAfee Avert Labs discovered these
     vulnerabilities.

     Note: The VMware service console does not provide the kadmind
     binary, and is not affected by these issues, but a update has been
     provided for completeness.

     ESX
     ---
     VMware ESX 3.0.2 Download Patch Bundle ESX-1001731
     http://www.vmware.com/support/vi3/doc/esx-1001731-patch.html
     md5sum c349b83065f5b06cee34bae90a5a01b3

     VMware ESX 3.0.1 Download Patch Bundle ESX-1001723
     http://www.vmware.com/support/vi3/doc/esx-1001723-patch.html
     md5sum 9a31d1718d6c063cf978305b84637c40

     VMware ESX 3.0.0 Download Patch Bundle ESX-1001212
     http://www.vmware.com/support/vi3/doc/esx-1001212-patch.html
     md5sum 2bc08369d3410fa59d353e45830ae9f5

     NOTE: ESX 3.0.0 is nearing its End-of-life (10/05/2007) users
     should upgrade to at least 3.0.1 and preferably the newest
     release available

     VMware ESX 2.5.4 prior to upgrade patch 10 (Build# 53326)
     VMware ESX 2.5.3 prior to upgrade patch 13 (Build# 52488)
     VMware ESX 2.1.3 prior to upgrade patch  8 (Build# 53228)
     VMware ESX 2.0.2 prior to upgrade patch  8 (Build# 52650)

d.   Service console update for vixie-cron

     This patch provides an updated service console package vixie-cron.
     Cron is a standard UNIX daemon that runs specified programs at
     scheduled times.

     A denial of service issue was found in the way vixie-cron verified
     crontab file integrity. A local user with the ability to create a
     hardlink to /etc/crontab could potentially prevent vixie-cron from
     executing certain system cron jobs. (CVE-2007-1856)

     Thanks to Raphael Marichez for identifying this issue.

     ESX
     ---
     VMware ESX 3.0.1 Download Patch Bundle ESX-1001214
     http://www.vmware.com/support/vi3/doc/esx-1001214-patch.html
     md5sum 1e63db1cc7605830b16306a35bccd878

     VMware ESX 3.0.0 Download Patch Bundle ESX-1001205
     http://www.vmware.com/support/vi3/doc/esx-1001205-patch.html
     md5sum e6b818cf885d5fd5f93d33b27051df83

     NOTE: ESX 3.0.0 is nearing its End-of-life (10/05/2007) users
     should upgrade to at least 3.0.1 and preferably the newest
     release available

     NOTE: ESX 3.0.2 and ESX 2.x are not affected by this issue.

e.   Service console update for shadow-utils

     This patch provides an updated shadow-utils package.  A new
     user's mailbox, when created, could have random permissions for a
     short period. This could enable a local malicious user to
     read or modify the mailbox. (CVE-2006-1174)

     ESX
     ---
     VMware ESX 3.0.2 Download Patch Bundle ESX-1001726
     http://www.vmware.com/support/vi3/doc/esx-1001726-patch.html
     md5sum ac55c65ddc2142a292648765e9dcb583

     VMware ESX 3.0.1 Download Patch Bundle ESX-1001692
     http://www.vmware.com/support/vi3/doc/esx-1001692-patch.html
     md5sum 27edbac467107cc1fe6c78a839ce2144

     VMware ESX 3.0.0 Download Patch Bundle ESX-1001207
     http://www.vmware.com/support/vi3/doc/esx-1001207-patch.html
     md5sum acad9bce49ac9398ab1ee502980b49cb

     NOTE: ESX 3.0.0 is nearing its End-of-life (10/05/2007) users
     should upgrade to at least 3.0.1 and preferably the newest
     release available

f.  Service console update for OpenLDAP

     This patch provides a updated OpenLDAP package. A flaw could
     allow users with selfwrite access to modify the distinguished
     name of any user, instead of being limited to modify only
     their own distinguished name. (CVE-2006-4600)

     ESX
     ---
     VMware ESX 3.0.2 Download Patch Bundle ESX-1001727
     http://www.vmware.com/support/vi3/doc/esx-1001727-patch.html
     md5sum bd137cbf65b20dae3aaf422a559f92a1

     VMware ESX 3.0.1 Download Patch Bundle ESX-1001693
     http://www.vmware.com/support/vi3/doc/esx-1001693-patch.html
     md5sum a11191b59761b6afb68ea73e9e6456d0

     VMware ESX 3.0.0 Download Patch Bundle ESX-1001208
     http://www.vmware.com/support/vi3/doc/esx-1001208-patch.html
     md5sum f3e26b66682191e024a9b094a063837f

     NOTE: ESX 3.0.0 is nearing its End-of-life (10/05/2007) users
     should upgrade to at least 3.0.1 and preferably the newest
     release available

     NOTE: ESX 2.x doesen't ship OpenLDAP

g.   Service console update for PAM

     This patch provides an updated PAM package A vulnerability was
     found that could allow console users with access to certain device
     files to cause damage to recordable CD drives. Certain file
     permissions have now been modified to disallow access.
     (CVE-2004-0813)

     A flaw was found with console device permissions. It was possible
     for various console devices to retain ownership of the previoius
     console user after logging out, which could result in leakage of
     information to an unauthorized user. (CVE-2007-1716)

     ESX
     ---
     VMware ESX 3.0.2 Download Patch Bundle ESX-1001728
     http://www.vmware.com/support/vi3/doc/esx-1001728-patch.html
     md5sum a33f0cc5b1cfc68683c4d8643c52775c

     VMware ESX 3.0.1 Download Patch Bundle ESX-1001694
     http://www.vmware.com/support/vi3/doc/esx-1001694-patch.html
     md5sum 6ce5d882d6fe9e714ce48f719cefb182

     VMware ESX 3.0.0 Download Patch Bundle ESX-1001209
     http://www.vmware.com/support/vi3/doc/esx-1001209-patch.html
     md5sum 1c7adad00a20f9e7ba1fbe1663ad4d66

     NOTE: ESX 3.0.0 is nearing its End-of-life (10/05/2007) users
     should upgrade to at least 3.0.1 and preferably the newest
     release available

h.   Service console update for GCC

     This patch provides security fixes for the service console GNU
     Compiler Collection (GCC) packages that include C, C++, Java,
     Fortran 77, Objective C, and Ada 95 GNU compilers and related
     support libraries.

     A flaw was found in the fastjar utility that could potentially
     allow a malicious user to create a JAR file which, if unpacked
     using fastjar, could write to any file that an authorized user had
     write access to. (CVE-2006-3619)

     Thanks to J    

- 漏洞信息

25848
Shadow useradd.c Mailbox Permission Weakness
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.0.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Shadow-Utils 'useradd' Local Insecure Permissions Vulnerability
Race Condition Error 18111
No Yes
2006-05-24 12:00:00 2007-12-18 08:04:00
Koblinger Egmont <egmont@uhulinux.hu> discovered this issue.

- 受影响的程序版本

VMWare ESX Server 3.0.2
VMWare ESX Server 3.0.1
VMWare ESX Server 3.0
shadow shadow 4.0.8
shadow shadow 4.0.3
SGI ProPack 3.0 SP6
rPath rPath Linux 1
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Desktop 4.0
RedHat Desktop 3.0
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Mandriva Linux Mandrake 10.2 x86_64
Mandriva Linux Mandrake 10.2
MandrakeSoft Multi Network Firewall 2.0
MandrakeSoft Corporate Server 3.0 x86_64
MandrakeSoft Corporate Server 3.0
Gentoo Linux
Avaya SES 3.1.1
Avaya Messaging Storage Server MSS 3.0
Avaya Message Networking MN 3.1
Avaya EMMC 1.021
Avaya EMMC 1.017
Avaya EMMC 0
Avaya Communication Manager 2.0.1
+ Avaya Communication Manager Server DEFINITY Server SI/CS
+ Avaya Communication Manager Server S8100
+ Avaya Communication Manager Server S8100
+ Avaya Communication Manager Server S8300
+ Avaya Communication Manager Server S8300
+ Avaya Communication Manager Server S8500
+ Avaya Communication Manager Server S8500
+ Avaya Communication Manager Server S8700
+ Avaya Communication Manager Server S8700
Avaya Communication Manager 2.0
+ Avaya Communication Manager Server DEFINITY Server SI/CS
+ Avaya Communication Manager Server S8100
+ Avaya Communication Manager Server S8100
+ Avaya Communication Manager Server S8300
+ Avaya Communication Manager Server S8300
+ Avaya Communication Manager Server S8500
+ Avaya Communication Manager Server S8500
+ Avaya Communication Manager Server S8700
+ Avaya Communication Manager Server S8700
Avaya Communication Manager 4.0
Avaya Communication Manager 3.1
+ Avaya Communication Manager Server DEFINITY Server SI/CS
+ Avaya Communication Manager Server S8100
+ Avaya Communication Manager Server S8300
+ Avaya Communication Manager Server S8500
+ Avaya Communication Manager Server S8700
Avaya Communication Manager 3.0
+ Avaya Communication Manager Server DEFINITY Server SI/CS
+ Avaya Communication Manager Server S8100
+ Avaya Communication Manager Server S8100
+ Avaya Communication Manager Server S8300
+ Avaya Communication Manager Server S8300
+ Avaya Communication Manager Server S8500
+ Avaya Communication Manager Server S8500
+ Avaya Communication Manager Server S8700
+ Avaya Communication Manager Server S8700
Avaya CCS 3.1.1
Avaya Aura Application Enablement Services 3.1.3
Avaya Aura Application Enablement Services 3.0
Avaya AES 4.0
Avaya AES 3.1

- 漏洞讨论

The 'useradd' utility in shadow-utils is prone to a local insecure-permissions vulnerability. This issue is due to a race-condition between when user mailboxes are created and when permissions are set on the file.

A local, unprivileged attacker can exploit this issue to gain access to newly created mailbox files. This may allow them to directly inject forged email messages to aid them in social-engineering attacks. Attackers may also be able to inject data into the mailbox file that will cause mail applications to fail to access the file, denying email access to targeted users. Other attacks may also be possible.

This issue affects shadow-utils 4.0.3; other versions may also be affected.

- 漏洞利用

Attackers use standard system utilities to exploit this issue.

- 解决方案

The vendor has released version 4.0.8 to address this issue.

Please see the referenced advisories for information on obtaining and applying fixes.


SGI ProPack 3.0 SP6

shadow shadow 4.0.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站