CVE-2006-1154
CVSS7.5
发布时间 :2006-03-10 06:02:00
修订时间 :2011-08-23 00:00:00
NMCO    

[原文]PHP remote file inclusion vulnerability in archive.php in Fantastic News 2.1.2 allows remote attackers to include arbitrary files via the CONFIG[script_path] variable. NOTE: 2.1.4 was also reported to be vulnerable.


[CNNVD]Fantastic News 'archive.php' 多个远程文件包含漏洞(CNNVD-200603-185)

        Fantastic News 2.1.2中的archive.php存在PHP远程文件包含漏洞,远程攻击者可以通过CONFIG[script_path]变量包含任意文件。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)

cpe:/a:fscripts:fantastic_news:2.1.4
cpe:/a:fscripts:fantastic_news:2.1.2
cpe:/a:fscripts:fantastic_news:2.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1154
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1154
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-185
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/31121
(UNKNOWN)  XF  fantasticnews-configscriptpath-file-include(31121)
http://xforce.iss.net/xforce/xfdb/25064
(UNKNOWN)  XF  fantasticnews-archive-file-include(25064)
http://www.vupen.com/english/advisories/2006/3513
(VENDOR_ADVISORY)  VUPEN  ADV-2006-3513
http://www.vupen.com/english/advisories/2006/0826
(UNKNOWN)  VUPEN  ADV-2006-0826
http://www.securityfocus.com/bid/21796
(UNKNOWN)  BID  21796
http://www.securityfocus.com/bid/16985
(UNKNOWN)  BID  16985
http://www.milw0rm.com/exploits/3027
(UNKNOWN)  MILW0RM  3027
http://sx02.coresec.de/advisories/152.txt
(UNKNOWN)  MISC  http://sx02.coresec.de/advisories/152.txt
http://secunia.com/advisories/23519
(UNKNOWN)  SECUNIA  23519
http://secunia.com/advisories/21807
(VENDOR_ADVISORY)  SECUNIA  21807

- 漏洞信息

Fantastic News 'archive.php' 多个远程文件包含漏洞
高危 代码注入
2006-03-10 00:00:00 2006-09-27 00:00:00
远程  
        Fantastic News 2.1.2中的archive.php存在PHP远程文件包含漏洞,远程攻击者可以通过CONFIG[script_path]变量包含任意文件。

- 公告与补丁

        目前厂商还没有提供此漏洞的相关补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本.

- 漏洞信息

28599
Fantastic News archive.php CONFIG[script_path] Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Fantastic News version 2.1.4 is vulnerable to a remote file inclusion attack. If successful, an attacker could control the vulnerable server remotely compromising the confidentiality, availability, and integrity of the target servers data.

- 时间线

2006-09-08 Unknow
Unknow Unknow

- 解决方案

Ensure that the variables are declared before including them into PHP scripts. This can be accomplished with the declare function.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站