CVE-2006-1141
CVSS7.5
发布时间 :2006-03-10 06:02:00
修订时间 :2011-03-07 21:32:08
NMCOS    

[原文]Buffer overflow in qmailadmin.c in QmailAdmin before 1.2.10 allows remote attackers to execute arbitrary code via a long PATH_INFO environment variable.


[CNNVD]QmailAdmin "PATH_INFO"处理缓冲区溢出漏洞(CNNVD-200603-191)

        QmailAdmin是一款由Inter7组织开发的qmail CGI形式管理程序。
        QmailAdmin的qmailadmin.c在处理PATH_INFO环境变量时存在边界条件错误,攻击者可以通过特制的URL请求触发缓冲区溢出,导致拒绝服务。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:inter7:qmailadmin:1.2.1
cpe:/a:inter7:qmailadmin:1.2.8
cpe:/a:inter7:qmailadmin:1.2.0
cpe:/a:inter7:qmailadmin:1.0.4
cpe:/a:inter7:qmailadmin:1.2.9
cpe:/a:inter7:qmailadmin:1.0.5
cpe:/a:inter7:qmailadmin:1.0.2
cpe:/a:inter7:qmailadmin:1.2.7
cpe:/a:inter7:qmailadmin:1.0.6
cpe:/a:inter7:qmailadmin:1.0.1
cpe:/a:inter7:qmailadmin:1.2.3
cpe:/a:inter7:qmailadmin:1.0.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1141
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1141
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-191
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/25065
(PATCH)  XF  qmialadmin-qmailadmin-bo(25065)
http://www.securityfocus.com/bid/16994
(PATCH)  BID  16994
http://sourceforge.net/project/shownotes.php?group_id=6691&release_id=395211
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?group_id=6691&release_id=395211
http://www.vupen.com/english/advisories/2006/0852
(UNKNOWN)  VUPEN  ADV-2006-0852
http://cvs.sourceforge.net/viewcvs.py/qmailadmin/qmailadmin/qmailadmin.c?r1=1.6.2.10&r2=1.6.2.11
(UNKNOWN)  MISC  http://cvs.sourceforge.net/viewcvs.py/qmailadmin/qmailadmin/qmailadmin.c?r1=1.6.2.10&r2=1.6.2.11
http://www.osvdb.org/23705
(UNKNOWN)  OSVDB  23705
http://security.gentoo.org/glsa/glsa-200611-15.xml
(UNKNOWN)  GENTOO  GLSA-200611-15
http://secunia.com/advisories/23019
(UNKNOWN)  SECUNIA  23019
http://secunia.com/advisories/19262
(UNKNOWN)  SECUNIA  19262

- 漏洞信息

QmailAdmin "PATH_INFO"处理缓冲区溢出漏洞
高危 缓冲区溢出
2006-03-10 00:00:00 2006-03-13 00:00:00
远程  
        QmailAdmin是一款由Inter7组织开发的qmail CGI形式管理程序。
        QmailAdmin的qmailadmin.c在处理PATH_INFO环境变量时存在边界条件错误,攻击者可以通过特制的URL请求触发缓冲区溢出,导致拒绝服务。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.inter7.com/index.php?page=qmailadmin

- 漏洞信息

23705
qmailadmin qmailadmin.c PATH_INFO Environment Variable Local Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

A local overflow exists in qmailadmin. The program fails to properly check input reveived from the PATH_INFO environment variable resulting in a buffer overflow. With a specially crafted request, an attacker can cause the execution of arbitrary code resulting in a loss of integrity.

- 时间线

2006-02-20 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.2.10 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Inter7 QmailAdmin PATH_INFO Buffer Overflow Vulnerability
Boundary Condition Error 16994
Yes No
2006-02-20 12:00:00 2006-11-23 09:25:00
Reported by the vendor.

- 受影响的程序版本

Inter7 qmailadmin 1.2.9
Inter7 qmailadmin 1.0.6
Inter7 qmailadmin 1.0.5
Inter7 qmailadmin 1.0.4
Inter7 qmailadmin 1.0.3
Inter7 qmailadmin 1.0.2
Inter7 qmailadmin 1.0.1
Gentoo Linux
Inter7 qmailadmin 1.2.10

- 不受影响的程序版本

Inter7 qmailadmin 1.2.10

- 漏洞讨论

QmailAdmin is prone to a buffer-overflow vulnerability.

A remote attacker can supply excessive data through the 'PATH_INFO' variable to trigger this issue.

A successful attack may allow an attacker to remotely compromise a computer in the context of the application.

QmailAdmin versions prior to 1.2.10 are vulnerable.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

The vendor has released version 1.2.10 to address this issue.

Please see the referenced advisories for further information.


Inter7 qmailadmin 1.0.1

Inter7 qmailadmin 1.0.2

Inter7 qmailadmin 1.0.3

Inter7 qmailadmin 1.0.4

Inter7 qmailadmin 1.0.5

Inter7 qmailadmin 1.0.6

Inter7 qmailadmin 1.2.9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站