发布时间 :2006-03-09 21:02:00
修订时间 :2011-03-07 21:32:07

[原文]SQL injection vulnerability in CyBoards PHP Lite 1.25, when magic_quotes_gpc is disabled, allows remote attackers to execute arbitrary SQL commands via the parent parameter to (1) post.php and possibly (2) process_post.php.

[CNNVD]CyBoards PHP Lite 'Process_post.PHP' SQL注入漏洞(CNNVD-200603-173)

        CyBoards PHP Lite 1.25中的SQL注入漏洞,当magic_quotes_gpc无效时,远程攻击者可以通过以下途径执行任意SQL命令:(1)post.php的父参数和可能(2)process_post.php。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-0820
(UNKNOWN)  BID  17107
(UNKNOWN)  BUGTRAQ  20060314 [eVuln] CyBoards PHP Lite SQL Injection Vulnerability
(UNKNOWN)  XF  cyboards-processpost-sql-injection(25061)
(UNKNOWN)  BID  16987

- 漏洞信息

CyBoards PHP Lite 'Process_post.PHP' SQL注入漏洞
中危 SQL注入
2006-03-09 00:00:00 2006-04-07 00:00:00
        CyBoards PHP Lite 1.25中的SQL注入漏洞,当magic_quotes_gpc无效时,远程攻击者可以通过以下途径执行任意SQL命令:(1)post.php的父参数和可能(2)process_post.php。

- 公告与补丁


- 漏洞信息

Cyboards PHP Lite post.php parent Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-03-03 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

CyBoards PHP Lite Process_post.PHP SQL Injection Vulnerability
Input Validation Error 16987
Yes No
2006-03-06 12:00:00 2007-02-20 03:56:00
Aliaksandr Hartsuyeu is credited with the discovery of this vulnerability.

- 受影响的程序版本

Cyboards Cyboards PHP Lite 1.25
Cyboards Cyboards PHP Lite 1.21

- 漏洞讨论

CyBoards PHP Lite is prone to an SQL-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

A successful exploit could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

CyBoards PHP Lite 1.25 and prior are reportedly affected by this issue.

- 漏洞利用

This issue can be exploited using a web client.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at:

- 相关参考