CVE-2006-1116
CVSS5.0
发布时间 :2006-03-09 08:06:00
修订时间 :2011-03-07 21:32:03
NMCO    

[原文]The CBC-MAC integrity functions in the nCipher nCore API before 2.18 transmit the initialization vector IV as part of a message when the implementation uses a non-zero IV, which allows remote attackers to bypass integrity checks and modify messages without being detected.


[CNNVD]nCipher非安全CBC-MAC API漏洞(CNNVD-200603-138)

        在nCipher nCore API 2.18之前版本中的CBC-MAC集成函数,当操作中使用一个非零IV时,将初始化向量IV作为短信发送,从而允许远程攻击者绕过完整性检查并修改短信而不被察觉。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1116
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1116
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-138
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/17011
(PATCH)  BID  17011
http://www.ncipher.com/resources/96/sa13_cbcmac_iv_misleading_programming_interface
(VENDOR_ADVISORY)  CONFIRM  http://www.ncipher.com/resources/96/sa13_cbcmac_iv_misleading_programming_interface
http://securitytracker.com/id?1015718
(VENDOR_ADVISORY)  SECTRACK  1015718
http://secunia.com/advisories/19137
(VENDOR_ADVISORY)  SECUNIA  19137
http://www.vupen.com/english/advisories/2006/0862
(UNKNOWN)  VUPEN  ADV-2006-0862
http://xforce.iss.net/xforce/xfdb/25062
(UNKNOWN)  XF  ncipher-ncore-bypass-security(25062)
http://www.securityfocus.com/archive/1/archive/1/427150/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060308 nCipher Advisory #13: CBC-MAC IV misleading programming interface

- 漏洞信息

nCipher非安全CBC-MAC API漏洞
中危 设计错误
2006-03-09 00:00:00 2006-03-10 00:00:00
远程  
        在nCipher nCore API 2.18之前版本中的CBC-MAC集成函数,当操作中使用一个非零IV时,将初始化向量IV作为短信发送,从而允许远程攻击者绕过完整性检查并修改短信而不被察觉。

- 公告与补丁

        暂无数据

- 漏洞信息

23737
nCipher Multiple Products nCore API CBC MAC Message Modification Detection Failure Weakness
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-21 Unknow
Unknow Unknow

- 解决方案

Upgrade to version V10 firmware version 2.22.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站