CVE-2006-1104
CVSS7.5
发布时间 :2006-03-09 08:06:00
修订时间 :2011-03-07 21:32:02
NMCO    

[原文]Multiple SQL injection vulnerabilities in Pixelpost 1.5 beta 1 and earlier allow remote attackers to execute arbitrary SQL commands via (1) the showimage parameter in index.php; and the (2) USER_AGENT, (3) HTTP_REFERER, and (4) HTTP_HOST HTTP header fields as used in the book_vistor function in includes/functions.php. NOTE: the vendor has disputed some issues from the original disclosure, but due to the vagueness of the dispute, it is not clear whether the vendor is disputing this particular issue.


[CNNVD]Pixelpost多个输入验证漏洞(CNNVD-200603-168)

        在Pixelpost 1.5 beta 1及其早期版本存在多个SQL注入漏洞,远程攻击者可以通过以下途径执行任意SQL命令:(1) 在index.php中的showimage参数;和(2) USER_AGENT,(3) HTTP_REFERER,和(4)用在includes/functions.php中的book_vistor函数时的HTTP_HOST HTTP头字段。注意:厂商对原先的反映尚有异议,但由于答复有些似是而非,不知厂商对此问题是否仍有异议。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:pixelpost:pixelpost:1.5_beta1
cpe:/a:pixelpost:pixelpost:1.4.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1104
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1104
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-168
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/25046
(UNKNOWN)  XF  pixelpost-functions-sql-injection(25046)
http://xforce.iss.net/xforce/xfdb/25044
(UNKNOWN)  XF  pixelpost-index-sql-injection(25044)
http://www.vupen.com/english/advisories/2006/0823
(UNKNOWN)  VUPEN  ADV-2006-0823
http://www.securityfocus.com/bid/16964
(UNKNOWN)  BID  16964
http://www.securityfocus.com/archive/1/archive/1/426764/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060304 Pixel Post Multiple Vulnerabilities
http://www.neosecurityteam.net/index.php?action=advisories&id=19
(VENDOR_ADVISORY)  MISC  http://www.neosecurityteam.net/index.php?action=advisories&id=19
http://forum.pixelpost.org/showthread.php?t=3535
(UNKNOWN)  MISC  http://forum.pixelpost.org/showthread.php?t=3535

- 漏洞信息

Pixelpost多个输入验证漏洞
高危 SQL注入
2006-03-09 00:00:00 2006-03-10 00:00:00
远程  
        在Pixelpost 1.5 beta 1及其早期版本存在多个SQL注入漏洞,远程攻击者可以通过以下途径执行任意SQL命令:(1) 在index.php中的showimage参数;和(2) USER_AGENT,(3) HTTP_REFERER,和(4)用在includes/functions.php中的book_vistor函数时的HTTP_HOST HTTP头字段。注意:厂商对原先的反映尚有异议,但由于答复有些似是而非,不知厂商对此问题是否仍有异议。

- 公告与补丁

        目前厂商还没有提供此漏洞的相关补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本.

- 漏洞信息

23799
Pixelpost index.php showimage Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Vendor Verified

- 漏洞描述

Pixelpost contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'index.php' script not properly sanitizing user-supplied input to the 'showimage' parameter. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-03-04 Unknow
2006-03-04 Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站