CVE-2006-1095
CVSS7.2
发布时间 :2006-03-09 08:06:00
修订时间 :2011-04-01 00:00:00
NMCO    

[原文]Directory traversal vulnerability in the FileSession object in Mod_python module 3.2.7 for Apache allows local users to execute arbitrary code via a crafted session cookie.


[CNNVD]Apache mod_python FileSession对象 目录遍访漏洞(CNNVD-200603-155)

        在应用于Apache的Mod_python module 3.2.7中的FileSession对象存在目录遍访漏洞,本地用户可以通过一个伪cookie执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-22 [对路径名的限制不恰当(路径遍历)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1095
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1095
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-155
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16916
(PATCH)  BID  16916
http://www.cgisecurity.com/2006/02/07
(PATCH)  MISC  http://www.cgisecurity.com/2006/02/07
http://securitytracker.com/id?1015764
(PATCH)  SECTRACK  1015764
http://secunia.com/advisories/19239
(VENDOR_ADVISORY)  SECUNIA  19239
http://xforce.iss.net/xforce/xfdb/24965
(UNKNOWN)  XF  modpython-filesession-command-execution(24965)
http://www.vupen.com/english/advisories/2006/0768
(VENDOR_ADVISORY)  VUPEN  ADV-2006-0768
http://www.modpython.org/fs_sec_warn.html
(UNKNOWN)  CONFIRM  http://www.modpython.org/fs_sec_warn.html
http://svn.apache.org/viewcvs.cgi/httpd/mod_python/branches/3.2.x/NEWS?rev=378945
(UNKNOWN)  CONFIRM  http://svn.apache.org/viewcvs.cgi/httpd/mod_python/branches/3.2.x/NEWS?rev=378945

- 漏洞信息

Apache mod_python FileSession对象 目录遍访漏洞
高危 路径遍历
2006-03-09 00:00:00 2006-09-21 00:00:00
远程  
        在应用于Apache的Mod_python module 3.2.7中的FileSession对象存在目录遍访漏洞,本地用户可以通过一个伪cookie执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        Gregory Trubetskoy mod_python 3.2.7
        Apache Software Foundation mod_python 3.2.8
        http://httpd.apache.org/modules/python-download.cgi

- 漏洞信息

23906
Apache mod_python for Apache HTTP Server FileSession Privileged Local Command Execution
Input Manipulation
Loss of Integrity Upgrade
Exploit Private Vendor Verified

- 漏洞描述

- 时间线

2006-02-15 Unknow
Unknow 2006-03-05

- 解决方案

Upgrade to version 3.2.8, 3.3.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站