CVE-2006-1089
CVSS4.3
发布时间 :2006-03-09 08:06:00
修订时间 :2011-03-07 21:32:00
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in header.php in PunBB 1.2.10 allows remote attackers to inject arbitrary web script or HTML via the URL, which is not properly handled when the PHP_SELF variable is used to handle a pun_page tag.


[CNNVD]PunBB 'Header.PHP'跨站脚本攻击漏洞(CNNVD-200603-146)

        在PunBB 1.2.10 中的header.php存在跨站脚本攻击漏洞,远程攻击者可以通过URL地址,注入任意Web脚本或HTML,当PHP_SELF变量用于操作一个pun_page标签时,该URL没有被妥善处理。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:punbb:punbb:1.2.7
cpe:/a:punbb:punbb:1.1.3
cpe:/a:punbb:punbb:1.1.2
cpe:/a:punbb:punbb:1.2.9
cpe:/a:punbb:punbb:1.0_rc2
cpe:/a:punbb:punbb:1.0_rc1
cpe:/a:punbb:punbb:1.2.5
cpe:/a:punbb:punbb:1.2.8
cpe:/a:punbb:punbb:1.2.2
cpe:/a:punbb:punbb:1.0_beta1a
cpe:/a:punbb:punbb:1.2.10
cpe:/a:punbb:punbb:1.2.4
cpe:/a:punbb:punbb:1.0
cpe:/a:punbb:punbb:1.1.1
cpe:/a:punbb:punbb:1.1.4
cpe:/a:punbb:punbb:1.0.1
cpe:/a:punbb:punbb:1.1.5
cpe:/a:punbb:punbb:1.2.3
cpe:/a:punbb:punbb:1.0_beta2
cpe:/a:punbb:punbb:1.2.6
cpe:/a:punbb:punbb:1.0_beta1
cpe:/a:punbb:punbb:1.0_alpha
cpe:/a:punbb:punbb:1.2
cpe:/a:punbb:punbb:1.2.1
cpe:/a:punbb:punbb:1.0_beta3
cpe:/a:punbb:punbb:1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1089
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1089
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-146
(官方数据源) CNNVD

- 其它链接及资源

http://www.punbb.org/download/patch/punbb-1.2.10_to_1.2.11.patch
(PATCH)  CONFIRM  http://www.punbb.org/download/patch/punbb-1.2.10_to_1.2.11.patch
http://secunia.com/advisories/19039
(VENDOR_ADVISORY)  SECUNIA  19039
http://www.vupen.com/english/advisories/2006/0773
(UNKNOWN)  VUPEN  ADV-2006-0773
http://www.punbb.org/changelogs/1.2.10_to_1.2.11.txt
(UNKNOWN)  CONFIRM  http://www.punbb.org/changelogs/1.2.10_to_1.2.11.txt
http://xforce.iss.net/xforce/xfdb/24982
(UNKNOWN)  XF  punbb-header-xss(24982)
http://www.securityfocus.com/bid/16891
(UNKNOWN)  BID  16891

- 漏洞信息

PunBB 'Header.PHP'跨站脚本攻击漏洞
中危 跨站脚本
2006-03-09 00:00:00 2006-03-09 00:00:00
远程  
        在PunBB 1.2.10 中的header.php存在跨站脚本攻击漏洞,远程攻击者可以通过URL地址,注入任意Web脚本或HTML,当PHP_SELF变量用于操作一个pun_page标签时,该URL没有被妥善处理。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        PunBB PunBB 1.2.1
        PunBB punbb-1.2.11.tar.gz
        http://www.punbb.org/download/punbb-1.2.11.tar.gz

- 漏洞信息

23568
PunBB header.php XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-28 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.2.11 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站