CVE-2006-1038
CVSS10.0
发布时间 :2006-03-07 06:02:00
修订时间 :2011-03-07 21:31:45
NMCO    

[原文]Buffer overflow in SecureCRT 5.0.4 and earlier and SecureFX 3.0.4 and earlier allows remote attackers to have an unknown impact when a Unicode string is converted to a "narrow" string.


[CNNVD]Van Dyke SecureCRT SecureFX缓冲区溢出漏洞(CNNVD-200603-103)

        在SecureCRT 5.0.4及其早期版本以及SecureFX 3.0.4及其早期版本中存在缓冲区溢出漏洞,当一条Unicode字符串被转换成"窄"字符串时,远程攻击者可以施加不明影响。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:van_dyke_technologies:securefx:3.0.1
cpe:/a:van_dyke_technologies:securecrt:5.0.4
cpe:/a:van_dyke_technologies:securecrt:5.0.1
cpe:/a:van_dyke_technologies:securecrt:5.0_beta_3
cpe:/a:van_dyke_technologies:securefx:3.0
cpe:/a:van_dyke_technologies:securefx:3.0_beta_5
cpe:/a:van_dyke_technologies:securefx:3.0_beta_3
cpe:/a:van_dyke_technologies:securecrt:5.0_beta_6
cpe:/a:van_dyke_technologies:securecrt:5.0.3
cpe:/a:van_dyke_technologies:securecrt:5.0_beta_2
cpe:/a:van_dyke_technologies:securefx:3.0_beta_1
cpe:/a:van_dyke_technologies:securefx:3.0.2
cpe:/a:van_dyke_technologies:securefx:3.0.4
cpe:/a:van_dyke_technologies:securecrt:5.0_beta_4
cpe:/a:van_dyke_technologies:securefx:3.0_beta_6
cpe:/a:van_dyke_technologies:securefx:3.0_beta_2
cpe:/a:van_dyke_technologies:securecrt:5.0_beta_5
cpe:/a:van_dyke_technologies:securecrt:5.0
cpe:/a:van_dyke_technologies:securefx:3.0.3
cpe:/a:van_dyke_technologies:securecrt:5.0.2
cpe:/a:van_dyke_technologies:securefx:3.0_beta_7
cpe:/a:van_dyke_technologies:securefx:3.0_beta_4
cpe:/a:van_dyke_technologies:securecrt:5.0_beta_1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1038
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1038
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-103
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/19040
(VENDOR_ADVISORY)  SECUNIA  19040
http://www.vupen.com/english/advisories/2006/0806
(UNKNOWN)  VUPEN  ADV-2006-0806
http://www.vandyke.com/products/securecrt/history.txt
(UNKNOWN)  CONFIRM  http://www.vandyke.com/products/securecrt/history.txt
http://xforce.iss.net/xforce/xfdb/25092
(UNKNOWN)  XF  securecrt-securefx-string-bo(25092)
http://www.vandyke.com/products/securefx/history.txt
(UNKNOWN)  CONFIRM  http://www.vandyke.com/products/securefx/history.txt
http://www.securityfocus.com/bid/16935
(UNKNOWN)  BID  16935

- 漏洞信息

Van Dyke SecureCRT SecureFX缓冲区溢出漏洞
危急 缓冲区溢出
2006-03-07 00:00:00 2006-03-08 00:00:00
远程  
        在SecureCRT 5.0.4及其早期版本以及SecureFX 3.0.4及其早期版本中存在缓冲区溢出漏洞,当一条Unicode字符串被转换成"窄"字符串时,远程攻击者可以施加不明影响。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        Van Dyke Technologies SecureFX 2.0.4
        Van Dyke Technologies SecureFX 3.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureFX
        
        Van Dyke Technologies SecureFX 2.0.5
        Van Dyke Technologies SecureFX 3.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureFX
        
        Van Dyke Technologies SecureFX 2.1.1
        Van Dyke Technologies SecureFX 3.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureFX
        
        Van Dyke Technologies SecureFX 2.1.2
        Van Dyke Technologies SecureFX 3.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureFX
        
        Van Dyke Technologies SecureFX 2.1.3
        Van Dyke Technologies SecureFX 3.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureFX
        
        Van Dyke Technologies SecureCRT 2.4
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.0
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureFX 3.0.4
        Van Dyke Technologies SecureFX 3.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureFX
        
        Van Dyke Technologies SecureCRT 3.1
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.1.1
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.1.2
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.2
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.2.1
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.2.2
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.3
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.3.1
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.3.2
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.3.3
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.3.4
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.4
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.4.1
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.4.2
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.4.3
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.4.4
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        
        Van Dyke Technologies SecureCRT 3.4.5
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.vandyke.com/cgi-bin/download_form.cgi?PRODUCT=SecureCRT
        Van Dyke Technologies SecureCRT 3.4.6
        Van Dyke Technologies SecureCRT 5.0.5
        https://secure.

- 漏洞信息

23629
SecureCRT / SecureFX Unicode String Conversion Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-14 Unknow
Unknow Unknow

- 解决方案

Upgrade SecureFX to version 3.0.5 or higher or SecureCRT to 5.0.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站