CVE-2006-1037
CVSS7.5
发布时间 :2006-03-07 06:02:00
修订时间 :2008-09-05 17:00:52
NMCOS    

[原文]SQL injection vulnerability in the Oracle Diagnostics module 2.2 and earlier allows remote attackers to execute arbitrary SQL commands via uknown attack vectors.


[CNNVD]Oracle诊断多个SQL注入漏洞(CNNVD-200603-082)

        在Oracle诊断模块 2.2和更早期版本中的SQL注入漏洞,允许远程攻击者通过不明攻击矢量,执行任意SQL指令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:oracle:e-business_suite:11.5.10.1Oracle Oracle E-Business Suite and Applications 11.5.10CU1
cpe:/a:oracle:diagnostics:2.0Oracle Diagnostics 2.0
cpe:/a:oracle:diagnostics:2.1Oracle Diagnostics 2.1
cpe:/a:oracle:diagnostics:2.2Oracle Diagnostics 2.2
cpe:/a:oracle:e-business_suite:11.5.3Oracle E-Business Suite 11i 11.5.3
cpe:/a:oracle:e-business_suite:11.5.9Oracle E-Business Suite 11i 11.5.9
cpe:/a:oracle:e-business_suite:11.5.8Oracle E-Business Suite 11i 11.5.8
cpe:/a:oracle:e-business_suite:11.5.4Oracle E-Business Suite 11i 11.5.4
cpe:/a:oracle:e-business_suite:11.5.6Oracle E-Business Suite 11i 11.5.6
cpe:/a:oracle:e-business_suite:11.5.7Oracle E-Business Suite 11i 11.5.7
cpe:/a:oracle:e-business_suite:11.5.5Oracle E-Business Suite 11i 11.5.5
cpe:/a:oracle:e-business_suite:11.5.10.2Oracle E-Business Suite 11i 11.5.10.2
cpe:/a:oracle:e-business_suite:11.5.10Oracle E-Business Suite 11i 11.5.10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1037
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1037
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-082
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16844
(UNKNOWN)  BID  16844
http://www.integrigy.com/info/IntegrigySecurityAnalysis-OracleDiag0206.pdf
(VENDOR_ADVISORY)  MISC  http://www.integrigy.com/info/IntegrigySecurityAnalysis-OracleDiag0206.pdf
http://xforce.iss.net/xforce/xfdb/25259
(UNKNOWN)  XF  oracle-diagnostics-sql-injection(25259)
http://secunia.com/advisories/19076
(UNKNOWN)  SECUNIA  19076

- 漏洞信息

Oracle诊断多个SQL注入漏洞
高危 SQL注入
2006-03-07 00:00:00 2006-03-08 00:00:00
远程  
        在Oracle诊断模块 2.2和更早期版本中的SQL注入漏洞,允许远程攻击者通过不明攻击矢量,执行任意SQL指令。

- 公告与补丁

        暂无数据

- 漏洞信息

23651
Oracle E-Business Suite Diagnostics Utilities Unspecified SQL Injections
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-23 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Oracle Diagnostics Multiple Vulnerabilities
Unknown 16844
Yes No
2006-02-27 12:00:00 2007-06-27 10:18:00
The original discoverer of these issues is currently unknown. These issues were disclosed by the vendor.

- 受影响的程序版本

Oracle Diagnostics 2.2
Oracle Diagnostics 2.1
Oracle Diagnostics 2.0
Oracle Applications 11i 11.5.10 CU2
Oracle Applications 11i 11.5.10 CU1
Oracle Applications 11i 11.5.10
Oracle Applications 11i 11.5.9
Oracle Applications 11i 11.5.8
Oracle Applications 11i 11.5.7
Oracle Applications 11i 11.5.6
Oracle Applications 11i 11.5.5
Oracle Applications 11i 11.5.4
Oracle Applications 11i 11.5.3
Oracle Diagnostics 2.3

- 不受影响的程序版本

Oracle Diagnostics 2.3

- 漏洞讨论

The Oracle Diagnostics module is susceptible to multiple vulnerabilities. These issues include insecure permissions, insecure default access, and SQL injection.

- Insecure-permissions vulnerability. This may allow remote attackers to gain access to potentially sensitive information that may aid them in further attacks.

- Default-access vulnerabilities. Successful exploits could allow an attacker to gain access to potentially sensitive information that may aid them in further attacks.

- Unspecified SQL-injection issues. Successful exploits could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

Oracle has released the 'Diagnostics Support Pack February 2006' with 'Oracle Diagnostics 2.3 RUP A' to address these vulnerabilities. This update addresses the vulnerabilities for supported releases. Earlier, unsupported releases are likely to be affected by the issues as well.

Other issues may have also been addressed with these fixes. This BID will be updated as further information is disclosed.

- 漏洞利用

These issues would likely be exploited from a web browser.

An example URI to a diagnostic test file was provided:
http://www.example.com/OA_HTML/jtfqalgn.htm

- 解决方案

Oracle has released an updated Oracle Diagnostics version 2.3 to address these issues. Contact the vendor for information on obtaining fixes.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站