发布时间 :2006-03-06 19:02:00
修订时间 :2011-07-14 00:00:00

[原文]The c-client library 2000, 2001, or 2004 for PHP before 4.4.4 and 5.x before 5.1.5 do not check the (1) safe_mode or (2) open_basedir functions, and when used in applications that accept user-controlled input for the mailbox argument to the imap_open function, allow remote attackers to obtain access to an IMAP stream data structure and conduct unauthorized IMAP actions.

[CNNVD]PHP c-client library多个安全绕过漏洞(CNNVD-200603-064)

        用于PHP的c-client library 2000、2001、或2004在4.4.4版本之前和5.1.5版本之前的5.x,不会检查(1) safe_mode 或(2) open_basedir 函数,还有当使用在用于imap_open函数的邮箱参数并接受用户控制输入的应用程序中时,会使远程攻击者取得对一条IMAP流数据结构的访问和实施非法操作。

- CVSS (基础分值)

CVSS分值: 9.3 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php:php:3.0.17PHP PHP 3.0.17
cpe:/a:php:php:5.0.0:rc1PHP PHP 5.0.0 RC1
cpe:/a:php:php:3.0.13PHP PHP 3.0.13
cpe:/a:php:php:4.4.3PHP PHP 4.4.3
cpe:/a:php:php:5.0.0:beta3PHP PHP 5.0.0 Beta3
cpe:/a:php:php:4.0.1PHP PHP 4.0.1
cpe:/a:php:php:5.0.0:beta2PHP PHP 5.0.0 Beta2
cpe:/a:php:php:5.0.5PHP PHP 5.0.5
cpe:/a:php:php:5.0.0:rc3PHP PHP 5.0.0 RC3
cpe:/a:php:php:4.3.1PHP PHP 4.3.1
cpe:/a:php:php:4.3.10PHP PHP 4.3.10
cpe:/a:php:php:4.0.0PHP PHP 4.0.0
cpe:/a:php:php:4.3.7PHP PHP 4.3.7
cpe:/a:php:php:3.0.1PHP PHP 3.0.1
cpe:/a:php:php:4.2.0PHP PHP 4.2.0
cpe:/a:php:php:5.0.1PHP PHP 5.0.1
cpe:/a:php:php:3.0.14PHP PHP 3.0.14
cpe:/a:php:php:4.2.2PHP PHP 4.2.2
cpe:/a:php:php:4.0.2PHP PHP 4.0.2
cpe:/a:php:php:4.0.6PHP PHP 4.0.6
cpe:/a:php:php:4.1.2PHP PHP 4.1.2
cpe:/a:php:php:4.0.5PHP PHP 4.0.5
cpe:/a:php:php:5.1.1PHP PHP 5.1.1
cpe:/a:php:php:4.3.6PHP PHP 4.3.6
cpe:/a:php:php:4.0.4PHP PHP 4.0.4
cpe:/a:php:php:4.4.2PHP PHP 4.4.2
cpe:/a:php:php:3.0.15PHP PHP 3.0.15
cpe:/a:php:php:5.0.4PHP PHP 5.0.4
cpe:/a:php:php:5.0.0:rc2PHP PHP 5.0.0 RC2
cpe:/a:php:php:4.3.4PHP PHP 4.3.4
cpe:/a:php:php:3.0.9PHP PHP 3.0.9
cpe:/a:php:php:4.0.3PHP PHP 4.0.3
cpe:/a:php:php:4.3.2PHP PHP 4.3.2
cpe:/a:php:php:4.3.3PHP PHP 4.3.3
cpe:/a:php:php:5.1.3PHP PHP 5.1.3
cpe:/a:php:php:3.0.16PHP PHP 3.0.16
cpe:/a:php:php:3.0.2PHP PHP 3.0.2
cpe:/a:php:php:5.1.2PHP PHP 5.1.2
cpe:/a:php:php:3.0.5PHP PHP 3.0.5
cpe:/a:php:php:5.1.0PHP PHP 5.1.0
cpe:/a:php:php:3.0.7PHP PHP 3.0.7
cpe:/a:php:php:5.0.0PHP PHP 5.0.0
cpe:/a:php:php:5.0.2PHP PHP 5.0.2
cpe:/a:php:php:4.2.1PHP PHP 4.2.1
cpe:/a:php:php:4.4.1PHP PHP 4.4.1
cpe:/a:php:php:5.0.3PHP PHP 5.0.3
cpe:/a:php:php:3.0.11PHP PHP 3.0.11
cpe:/a:php:php:4.1.1PHP PHP 4.1.1
cpe:/a:php:php:3.0.6PHP PHP 3.0.6
cpe:/a:php:php:4.0.7PHP PHP 4.0.7
cpe:/a:php:php:5.1.4PHP 5.1.4
cpe:/a:php:php:3.0.10PHP PHP 3.0.10
cpe:/a:php:php:3.0.12PHP PHP 3.0.12
cpe:/a:php:php:4.3.11PHP PHP 4.3.11
cpe:/a:php:php:5.0.0:beta1PHP PHP 5.0.0 Beta1
cpe:/a:php:php:3.0.8PHP PHP 3.0.8
cpe:/a:php:php:3.0.18PHP PHP 3.0.18
cpe:/a:php:php:5.0.0:beta4PHP PHP 5.0.0 Beta4
cpe:/a:php:php:4.3.8PHP PHP 4.3.8
cpe:/a:php:php:3.0.3PHP PHP 3.0.3
cpe:/a:php:php:4.1.0PHP PHP 4.1.0
cpe:/a:php:php:3.0PHP PHP 3.0
cpe:/a:php:php:4.4.0PHP PHP 4.4.0
cpe:/a:php:php:4.3.9PHP PHP 4.3.9
cpe:/a:php:php:3.0.4PHP PHP 3.0.4
cpe:/a:php:php:4.3.5PHP PHP 4.3.5
cpe:/a:php:php:4.2.3PHP PHP 4.2.3

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  php-imap-restriction-bypass(24964)
(UNKNOWN)  BUGTRAQ  20060228 (PHP) imap functions bypass safemode and open_basedir restrictions

- 漏洞信息

PHP c-client library多个安全绕过漏洞
高危 访问验证错误
2006-03-06 00:00:00 2006-09-05 00:00:00
        用于PHP的c-client library 2000、2001、或2004在4.4.4版本之前和5.1.5版本之前的5.x,不会检查(1) safe_mode 或(2) open_basedir 函数,还有当使用在用于imap_open函数的邮箱参数并接受用户控制输入的应用程序中时,会使远程攻击者取得对一条IMAP流数据结构的访问和实施非法操作。

- 公告与补丁


- 漏洞信息

PHP imap_open() Function open_basedir/safe_mode Bypass
Local Access Required Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

PHP contains a flaw that may allow a malicious local user to view arbitrary files and create or modify existing files with the same level of privelege as the web server. The issue is triggered when a script misuses the imap_open() function. It is possible that the flaw may allow reading arbitrary files or creating, renaming, or deleting existing files resulting in a loss of confidentiality or integrity.

- 时间线

2006-02-28 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.4.4, 5.1.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者