CVE-2006-1012
CVSS7.5
发布时间 :2006-03-06 16:02:00
修订时间 :2008-09-05 17:00:47
NMCO    

[原文]SQL injection vulnerability in WordPress 1.5.2, and possibly other versions before 2.0, allows remote attackers to execute arbitrary SQL commands via the User-Agent field in an HTTP header for a comment.


[CNNVD]WordPress User-Agent SQL注入漏洞(CNNVD-200603-042)

        在WordPress 1.5.2(可能还有其它2.0之前版本)中的SQL注入漏洞, 允许远程攻击者通过在一个HTTP报头中用于一条意见的User-Agent字段,执行任意SQL指令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1012
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1012
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200603-042
(官方数据源) CNNVD

- 其它链接及资源

http://www.gentoo.org/security/en/glsa/glsa-200603-01.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200603-01
http://secunia.com/advisories/19109
(VENDOR_ADVISORY)  SECUNIA  19109
http://www.securityfocus.com/bid/16950
(UNKNOWN)  BID  16950
http://xforce.iss.net/xforce/xfdb/25321
(UNKNOWN)  XF  wordpress-comment-sql-injection(25321)
http://secunia.com/advisories/19123
(UNKNOWN)  SECUNIA  19123

- 漏洞信息

WordPress User-Agent SQL注入漏洞
高危 SQL注入
2006-03-06 00:00:00 2006-03-07 00:00:00
远程  
        在WordPress 1.5.2(可能还有其它2.0之前版本)中的SQL注入漏洞, 允许远程攻击者通过在一个HTTP报头中用于一条意见的User-Agent字段,执行任意SQL指令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        WordPress WordPress 1.5.2
        http://wordpress.org/latest.tar.gz

- 漏洞信息

23665
WordPress Article Comment User-Agent Header SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

<PRODUCT> contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the article comment function not properly sanitizing user-supplied input to the HTTP user-agent header. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-03-06 Unknow
Unknow 2006-01-31

- 解决方案

Upgrade to version 2.0.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站